none
Ordnerumleitung - kein Zugriff mehr auf umgeleitet Ordner RRS feed

  • Frage

  • Hallo zusammen,

    wir haben ein kleines Problem mit der Ordnerumleitung. Die Ordnerumleitung ist schon länger auf foglende Ordner aktiv: Bilder, Filme, Dokumente, Videos und Favoriten. Diese liegen auf einem Netzlaufwerk.

    Bisher hat das ohne Probleme funktioniert. Die User haben alle einen eigenen Odner "Benutzername" unter dem Verzeichnis "Home".

    Nun haben wir auf das Verzeichnis "Home" die Berechtigungen angepasst (wie von MS vorgeschlagen - darf leider noch keine Links posten). Wir mussten nur Jeder auf "Home" richtig berechtigen und haben "Ersteller-Besitzer" wie von MS auf den "Home" Ordner berechtigt. Damit ist es uns nun möglich, dass die Home Verzeichnisse automatisch erstellt werden und wir nicht wie bisher die Ordern und Berechtigungen manuell vergeben müssen.

    Das funktioniert auch - bei Windows 7 gibt es allerdings folgendes Probelm. Die User sehen die umgeleiteten Ordner (Bilder, Filme, Dokumente, Videos und Favoriten) nicht mehr. Wenn sie  "Benutzerdateien" auf dem Desktop anlicken sehen Sie statt den umgeleiteten Ordner nur weiße Icons.

    Auch sind die Favoriten im IE nicht mehr sichtbar und in den Bibliotheken kann man die Orte nicht mehr anklicken. Alle umgeleiteten Ordner sind einfach nicht mehr sichtbar bzw nutzbar.

    Die Berechtigungen habe ich schon geprüft, alles OK. Die User sind ja auch noch direkt auf ihre Home Verzeichnisse berechtigt.

    Es sind auch nur Win7 PC betroffen - Server 2003 und XP haben dieses Problem nicht.

    Die Dateien sind aber alle noch vorhanden, wenn die User über das Netzlaufwerk (das auf ihre umgeleiteten Eigenen Dateien zeigt) klicken, sehen sie alles.

    Irgendwie scheint Windows intern da was zerschossen zu haben.

    Wenn ich das Profil auf den Win7 PCs lösche und ein neues anlegen lasse, funktioniert auch dort wieder das umleiten - nur gehen dann natürlich alle User Einstellungen verloren

    Im Ereignisprotokoll steht nur das die folder redirection erfolgreich durchgeführt wurde.

    Hatte jemand das Problem schon mal oder hat einen Tip wie ich das Problem lösen kann?

    Ich wäre sehr dankbar.

    EDIT: Ich glaube ich habe das Problem gefunden

    Der Pfad zu den umgeleiteten Ordnern war früher wie folgt "\\server\files\home\%username%"

    Durch die Änderung der Berechtigungen ist aus dem "home" Odner eine versteckte Freigabe geworden. Die Ordnerumleitung ist weiterhin auf den oben genannten Pfad eingestellt. DAmit scheint W7 aber ein Problem zu haben - ändere ich den Pfad auf "\\server\home$\%Username%" ab, werden auch die Ordner wieder angezeigt.... Ich finde es ziemlich unlogisch - da es den Pfad "\\server\files\home" ja noch gibt - aber durch die versteckte Freigabe scheint W7 da irgendwie Probleme zu haben. Aber auch nur bei bestehenden Profilen. Bei neu angelegten wird es ja wieder richtig gemacht.

    Habe den gleichen Beitrag auch im MCSEBoard gestellt - nur damit keine irritationen aufkommen



    • Bearbeitet cameo13 Montag, 8. April 2013 11:06
    Montag, 8. April 2013 11:01

Antworten

  • Zur Info - ich hab das Problem gelöst. Ich habe die Berechtigung Erweiterete Attribute lesen und Berechtigung lesen mit aufgenommen (Nur dieser Ordner) und jetzt sind die umgeleiteten Ordner wieder sichtbar.

    Vielen Dank Mark!!!

    Montag, 8. April 2013 13:28

Alle Antworten

  • Hi,

    Am 08.04.2013 13:01, schrieb cameo13:

    nicht mehr. Wenn sie  "Benutzerdateien" auf dem Desktop anlicken

    Sind das wirklich die "umgeleiteten" ORdern, oder sind das noch Reste im lokalen Benutzerprofil? Schau dir mal die Eigenschaften der Links an.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Montag, 8. April 2013 11:07
  • Hi Mark,

    danke für die schnelle Antwort. Nein es sind wirklich die umgeleiteten Ordner. Ich kann auf die weißen "Ordner" nicht mal die Eigenschaften anschauen. wenn ich die Ordner allerdings im Umleitungsziel lösche - verschwinden auch die weißen Ordner.

    Als ich dann die Pfade in der registry zu den Ordner angepasst habe, wie im 1. Post (Edit) geschrieben, gehen auch die Ordner wieder.

    Finde es nur komisch, das W7 so auf einen Freigabe reagiert.

    Montag, 8. April 2013 11:11
  • Hi,

    Am 08.04.2013 13:11, schrieb cameo13:

    Nein es sind wirklich die umgeleiteten Ordner.

    Hm ... ich habe es nie "nachträglich" korrigieren müssen.

    Hast du "Grant exclusive rights" aktiviert? Sollte ausgeschaltet werden.

    Ich erweitere die Rechte immer ein wenig:
    http://www.gruppenrichtlinien.de/artikel/ordnerumleitung-2-berechtigungen-auf-home-folder/

    Es kann sein, daß du am fehlenden:
    - Ordner durchsuchen/Dateiausführen
    - Ordner auflisten/Daten lesen
    scheiterst, denn dann kannst du auch nicht mehr auf dem UNC pfad "browsen".

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Montag, 8. April 2013 11:36
  • Ja gefällt mir auch nicht, dass wir es erst nachträglich ändern ... :/

    Den Haken bei "Grant exclusive rights" ist nicht gesetzt.

    Auf das home Verzeichnis habe ich der User Gruppe folgende Berechtigung gegeben:

    • Ordner erstellen / Daten anhängen (Übernehmen für: Nur diesen Ordner)
    • Ordner auflisten / Daten lesen (Übernehmen für: Nur diesen Ordner)
    • Attribute lesen (Übernehmen für: Nur diesen Ordner)
    • Ordner durchsuchen / Datei ausführen (Übernehmen für: Nur diesen Ordner)

    Du hast noch

    • Erweiterete Attribute lesen
    • Berechtigungen lesen

    Kann es sein das man die noch für Win7 benötigt?

    Das komische ist das es bei XP/2003 weiterhin funktioniert. Bei win7 erst nach dem neu anlegen des Profiles oder wenn ich die Pfade zu den Ordner in der registry ändere. Habe mal versucht bei einem Win7 PC den "alten" und immer noch vorhandenen Pfad als UNC einzugeben - also \\server\files\home\%username%\Musik - erhalte ich eine Fehlermeldung "Auf ....\Musik konnte nicht zugegriffen werden". Mache ich das gleiche mit dem Freigabepfad \\server\home$\%username%\Musik - dann geht es. Auf \\server\files\home\%username\ komme ich auch so..

    Bei WinXP funktioniert es immer - egal ob über die Freigabe oder den kompletten Pfad.

    Montag, 8. April 2013 11:55
  • Zur Info - ich hab das Problem gelöst. Ich habe die Berechtigung Erweiterete Attribute lesen und Berechtigung lesen mit aufgenommen (Nur dieser Ordner) und jetzt sind die umgeleiteten Ordner wieder sichtbar.

    Vielen Dank Mark!!!

    Montag, 8. April 2013 13:28
  • Hi,

    Am 08.04.2013 15:28, schrieb cameo13:

    Zur Info - ich hab das Problem gelöst. Ich habe die Berechtigung
    Erweiterete Attribute lesen und Berechtigung lesen mit aufgenommen
    (Nur dieser Ordner) und jetzt sind die umgeleiteten Ordner wieder
    sichtbar.

    Echt? Die sind das? Das ist ja irre. Cool. Danke für die Rückmeldung!
    Darf ich dein "Problem" mit in die Seite einbauen?
    In der Ordnerumleitungs Serie gibt es noch am Ende ein "Troubleshooting"

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Montag, 8. April 2013 13:40
  • Hi Mark,

    ja klar, kannst du gerne verwenden. Bin froh drüber wenn ich auch mal helfen kann und nicht immer nur Hilfe benötige :)

    Habe es jetzt bei 3 Win7 PCs getestet, nach der Änderung der Berechtigung mit den 2 oben genannten Attributen funktioniert alles wieder wie bisher.

    Gruß

    Steffen

    Montag, 8. April 2013 13:56