locked
Block Sund Cart RRS feed

  • Frage

  • How to lock sund in my network?

    Montag, 27. April 2009 05:40

Antworten

  • Excuse my ignorance -- but what is sund?
    Microsoft MVP - Group Policy -- blog: http://www.frickelsoft.net/blog
    • Als Antwort markiert Amir Sotoudeh Montag, 27. April 2009 06:19
    Montag, 27. April 2009 06:03
  • Hi,

    Additional to Florian’s suggestions:

    You can also disable the Windows Audio service to disable sound on clients using the following policy.

    [Computer Configuration\Policies\Windows Settings\Security Settings\System Services\Windows Audio]

    However, Local Admin on clients could start this service manually. You can remove users from Local Admin by using Restricted Group:

    [Computer Configuration\Policies\Windows Settings\Security Settings\Restricted Group]

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Als Antwort markiert Mervyn Zhang Donnerstag, 30. April 2009 10:43
    Montag, 27. April 2009 10:57
  • Hi Amir,
    Server 2003 does have this option.
    Do you see the "Security Setting" node at all?
    If not, something with your local system is wrong...
    Try registering the DLL again:
    regsvr32 %systemroot%\system32\wsecedit.dll
    Patrick
    • Als Antwort markiert Mervyn Zhang Mittwoch, 3. Juni 2009 09:37
    Mittwoch, 3. Juni 2009 06:29

Alle Antworten

  • Excuse my ignorance -- but what is sund?
    Microsoft MVP - Group Policy -- blog: http://www.frickelsoft.net/blog
    • Als Antwort markiert Amir Sotoudeh Montag, 27. April 2009 06:19
    Montag, 27. April 2009 06:03
  • sound
    Montag, 27. April 2009 06:20
  • Okay - so there is no 100% easy way to do that. Here's a reply from Mark Heitbrink to that issue:
    http://help.lockergnome.com/windows2/disable-audio-devices--ftopict476700.html

    --Start reply--

    You can create a ADM Template and disable the driver in CurrentControlSet.

    Import -> mark "adm templates" -> View -> Filtering
    uncheck "show only fully managed" ...

    like this:
    ----- sound.adm -----
    ; you have to find the right Key for the driver, replace "aeaudio"
    ; with your driverkey in Registry
    ; Start = 4 (disable), 3 (manual), 2(automatic), 1 (system), 0 (boot)

    Class Machine
    CATEGORY "Hardware Control"
    POLICY "Disable Soundcard"
    KEYNAME "SYSTEM\CurrentControlSet\Services\aeaudio"
    PART "HW: Analog Devices (Soundmax)" Checkbox
    VALUENAME "Start"
    VALUEON NUMERIC 4 VALUEOFF "3"
    END PART
    END POLICY ;Disable Soundcard
    END CATEGORY ;Hardware Control

    ----- sound.adm -----

    --End repy--

    You can use the KEYNAME above to find the corresponding Registry key. Go test it on one of your machines and if disabling the sound service is successful, you can either customize the ADM template above, export the registry modification to a .reg file and apply the reg file to the clients in a computer startup script ("regedit /s myReg.reg")  OR use Group Policy Preferences to push the registry key.

    Cheers,
    Florian


    Microsoft MVP - Group Policy -- blog: http://www.frickelsoft.net/blog
    Montag, 27. April 2009 06:33
  • Hi,

    Additional to Florian’s suggestions:

    You can also disable the Windows Audio service to disable sound on clients using the following policy.

    [Computer Configuration\Policies\Windows Settings\Security Settings\System Services\Windows Audio]

    However, Local Admin on clients could start this service manually. You can remove users from Local Admin by using Restricted Group:

    [Computer Configuration\Policies\Windows Settings\Security Settings\Restricted Group]

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Als Antwort markiert Mervyn Zhang Donnerstag, 30. April 2009 10:43
    Montag, 27. April 2009 10:57
  • Hi,
    I do not have any System Services in GP
    I have windows server 2003

    Dienstag, 2. Juni 2009 08:25
  • Hi Amir,
    Server 2003 does have this option.
    Do you see the "Security Setting" node at all?
    If not, something with your local system is wrong...
    Try registering the DLL again:
    regsvr32 %systemroot%\system32\wsecedit.dll
    Patrick
    • Als Antwort markiert Mervyn Zhang Mittwoch, 3. Juni 2009 09:37
    Mittwoch, 3. Juni 2009 06:29