none
Autodiscover Meldung vom Provider RRS feed

  • Frage

  • Hallo Forumsgemeinde.

    Wir haben bei einem Kunden einen SBS 2008 mit Exchange 2007 und einen Serv 2008R2 mit Exchange 2010. Am 2007 laufen nur mehr die öffentlichen Ordner. Die Mailboxen sind am 2010er. Gestern haben wir am SBS das SP2 installiert und seit dem haben wir folgendes Phänomen.

    Beim Start von Outlook2010 kommt immer die Meldung: Konfigurieren vom Mailadresse -Servereinstellung von dieser Website zulassen. Hier kommt dann der autodiscover link vom Strato Server (https://autoconfigure.strato.de/autodiscover/autodiscover.xml

    Zur Info:

    Die Kundendomain wird von Strato gehostet. Auch der MX Eintrag ist bei Strato. (Mails werden per POP Connector abgeholt). Ich habe nun bereits am lokalen DNS System nach einem Autodiscover Eintrag oder einem SRV Eintrag gesucht - gibt es nicht. In der Shell habe ich mit "get-clientaccessserver | fl AutodiscoverServiceInternalUri " nachgeschaut. Hier stehen nur die beiden lokalen Exchange Server drinnen.

    Testweise habe ich versucht über die Registry das Autodiscover auszuschalten - ohne Erfolg.

    Also wo bitte holt sich Outlook plötzlich das Autodiscover von Strato her. (Wobei wenn ich diese URL eingebe ein http Error kommt)

    Es wird kein Outlook über OLAnywhere verwendet. Alle befinden sich lokal im Netzwerk.

    Ich hoffe es kann mir jemand helfen


    • Bearbeitet Peter Putz Samstag, 30. November 2013 08:21
    Samstag, 30. November 2013 08:18

Antworten

  • Hallo.

    Ich habe den Fehler bereits gefunden.

    Outlook 2010 macht ja immer Autodiscover. Dadurch wird auch Autodiscover auf die Maildomäne gemacht. In meinem Fall ist die Maildomäne ja bei Strato. Aus diesem Grund wird eine DNS Anfrage auf autodiscover.meinedomain.com über den lokalen DNS an den Provider DNS weitergeleitet. Nun kommt die Antwort als SRV Eintrag von Strato retour (in den zwischengespeicherten Lookupvorgängen sieht man das sehr gut.

    Mein Workaround: Ich habe eine neue Zone mit der Domain (meinedomain.com) erstellt und dort einen manuellen SRV Eintrag für den lokalen Exchange Server eingetragen (plus die weiteren wie WWW etc.)

    Gibt es eine andere Lösung?

    Sonntag, 1. Dezember 2013 13:26

Alle Antworten

  • Hallo.

    Ich habe den Fehler bereits gefunden.

    Outlook 2010 macht ja immer Autodiscover. Dadurch wird auch Autodiscover auf die Maildomäne gemacht. In meinem Fall ist die Maildomäne ja bei Strato. Aus diesem Grund wird eine DNS Anfrage auf autodiscover.meinedomain.com über den lokalen DNS an den Provider DNS weitergeleitet. Nun kommt die Antwort als SRV Eintrag von Strato retour (in den zwischengespeicherten Lookupvorgängen sieht man das sehr gut.

    Mein Workaround: Ich habe eine neue Zone mit der Domain (meinedomain.com) erstellt und dort einen manuellen SRV Eintrag für den lokalen Exchange Server eingetragen (plus die weiteren wie WWW etc.)

    Gibt es eine andere Lösung?

    Sonntag, 1. Dezember 2013 13:26
  • Hallo,

    auch wir haben bei unseren Kunden mit autodiscover seit Office 2013 leidlich unsere Probleme.
    Zu Deiner Frage:

    How to suppress the AutoDiscover redirect warning in Outlook 2010 and Outlook 2013
    bzw: http://support.microsoft.com/kb/2480582/en-us

    Achtung: Die automatische deutsche Übersetzung des KB ist unbrauchbar...

    Wenn ich das richtig verstehe, hast Du im lokalen DNS der Domäne eine neue Zone mit dem Namen der externen Domäne angelegt. Wie kommen die User dann noch auf die eigene Homepage? Oder ist diese Intern?

    Gruß Martin Sauerteig

     

    Montag, 2. Dezember 2013 09:28
  • Hallo Martin.

    Da dein lokaler DNS Server nun deine offzielle Domain als Zone hat, musst du natürlich z.B. für www.meinedomain.com einen Hosteintrag machen.

    Wir machen das z.B. auch bei den Mailservern und mobilen Clients so. Am mobilen Client ist als Mailserver mail.meinedomain.com und nicht mail.meinedomain.local eingetragen. Ist der User nun im lokalen Netz, so würde die Anfrage raus ins Internet gehen, um dann wieder von dort kommend auf den im lokalen Netz befindlichen Mailserver zu landen.

    Deshalb machen wir dann auch eine zusätzliche Zone für die externe Domain. Ist der mobile Client dann im lokalen LAN fragt er den lokalen DNS Server und der gibt ihm dann die lokale IP vom Mailserver. Damit gibt es keinen Verkehr raus.

    Montag, 2. Dezember 2013 11:21
  • Hallo,
    ich habe seit ca. 1 Woche das gleiche Problem. Komischerweise wurden keinerlei Änderungen am System vorgenommen. (Exchange 2010 / Outlook 2010 und 2013) 
    Wir hatten das Problem lediglich von extern (also nicht im internen LAN) und ich hab einfach bei strato eine "sub"Domain mit autodiscover.meinedomain.com angelegt und den A-HostEintrag auf die statische IP des Outlook Anywhere bzw. OWA gesetzt.

    Funktioniert problemlos. Vielleicht hilft es ja jemanden.

    Nur komisch dass das Problem "einfach so" auftauchte.

    Viele Grüße


    • Als Antwort vorgeschlagen Alex Pitulice Mittwoch, 4. Dezember 2013 15:31
    Dienstag, 3. Dezember 2013 10:25
  • Guten Abend zusammen,

    wenn jemand noch immer mit diesem Problem "rumhühnert" .... bei Strato kann das für die Domains extra ausgeschaltet werden.

    Kommt man nur drauf wenn man dem Rat folgen will um eine Sub einzurichten - dann sieht man die Option.

    Ist bei uns übrigens nur bei Postfächern aufgetreten, die bereits in Nutzung waren, also längere Zeit existiert haben.

    Neue Einrichtungen liefen immer problemlos durch.Grüße durch die Nacht.....

    Montag, 27. Juli 2015 19:03
  • Moin,

    wieso kommen eigentlich seit geraumer Zeit wieder so alte Beiträge hoch?

    Die vorletzte Antwort war am 04.12.2013 ..... Und Alex macht auch schon eine ganze Zeit etwas anderes.

    Btw.: die Split-DNS Konfiguration ist schon ziemlich lange empfohlen:

    http://blogs.technet.com/b/exchange/archive/2014/02/28/namespace-planning-in-exchange-2013.aspx

    Zitat: "Since the release of Exchange 2007, the recommendation is to deploy a split-brain DNS infrastructure for the Internet-based client namespaces. "

    Ist also schon geringfügig länger die Empfehlung. ;)

    Zugriffspunkte sind die üblichen, auch die gibt es alle schon seit 2007

     - OWA

     - OA

     - EAS

     - EWS

    Das einzige, für das man einen anderen Namen nehmen sollte, ist das CAS-Array bei 2010. Das gab es nur dort und es sollte nicht der gleiche Namen sein, weil Outlook den als erstes ausprobiert und dann der Anwender auf einen Time-Out warten muss, wenn er außerhalb der Firma ist.

    Geklaut aus dem Beitrag von Robert:
    https://social.technet.microsoft.com/Forums/de-DE/11811989-645b-4abd-a524-ea55a133369c/exchange-2013-outlook-anywhere-internalexternal-url?forum=exchange_serverde

    ;)


    Gruß Norbert

    Montag, 27. Juli 2015 21:37
    Moderator
  • Zum Beispiel weil das Problem heute aktuell bei uns aufgetreten ist bei Outlook 2010 und Exchange 2003 nach jahrelanger problemloser Arbeit des Systems...

    Leider kann man das bei 1&1 nicht ausschalten.

    Donnerstag, 20. August 2015 06:31
  • Wie Norbert schon schrieb, eine Pinpoint-Zone ist hier die Lösung - nicht aber wie weiter oben erwähnt das Eintragen der eigenen Domain als komplette Domäne im eigenen DNS. Nutzt man die o.g. Methode, so müsste man tatsächlich für alle anderen Server in der eigenen Domain weitere A-Records im eigenen DNS definieren, bspw. für www.contoso.com, ftp.contoso.com etc.

    Hier gilt es ganz einfach eine Zone mit dem Namen autodiscover.contoso.com zu erstellen, hierin einen A-Record erstellen, diesem dann aber keinen Namen geben, sondern nur die IP-Adresse eintragen. Das nennt sich dann Pinpoint-Zone ;-)


    http://machinewithoutbrain.blogspot.de/


    • Bearbeitet Sebastian Hoffmann Mittwoch, 25. November 2015 15:54 Verwechslung / Typo Split-DNS und Pinpoint-Zone
    Mittwoch, 25. November 2015 14:52

  • Hier gilt es ganz einfach eine Zone mit dem Namen autodiscover.contoso.com zu erstellen, hierin einen A-Record erstellen, diesem dann aber keinen Namen geben, sondern nur die IP-Adresse eintragen. Das nennt sich dann Split-DNS ;-)


    http://machinewithoutbrain.blogspot.de/

    Das was du beschreibst ist eine Pinpoint Zone. Bei SplintDNS betreibe die DNS Zone Firma.de intern und extern. Jenachdem wo die Zone ist, werden eben die internen oder externen IP-Adressen aufgelöst. Problem ist halt das ich alles doppelt pflegen muss.

    Grüße

    Jörg


    Mittwoch, 25. November 2015 15:43
  • Korrekt danke. Da habe ich doch glatt genau das betitelt was ich ja als Lösung versucht habe auszureden :-D

    Die Begriffe werden nur all zu häufig im Netz durcheinander geworfen.

    Selbst wenn man sich das obige Zitat von Microsoft anschaut "Since the release of Exchange 2007, the recommendation is to deploy a split-brain DNS infrastructure for the Internet-based client namespaces. " Dann suggeriert es ja eigentlich, dass man nur die client namespaces in sein lokales DNS einträgt, das dann Split-DNS nennt.... selbst bei Microsoft wird es also vermischt.


    http://machinewithoutbrain.blogspot.de/

    Mittwoch, 25. November 2015 15:57
  • Bin grade über das Problem gestolpert wegen Outlook und der Meldung dass ich autodiscover.1und1.info vertrauen soll...

    Das mit dem DNS-Eintrag auf dem lokalem Server ist natürlich die geschickteste Methode (siehe Pinpoint Zone). Hilft aber nur für Rechner im lokalem Netzwerk, die auch Zugriff auf den DNS-Server haben.

    Wir haben in nem kleinen Betrieb nen Exchange laufen und für den Zugriff von außen (Laptops, Tablets) ist dieser über ne Dynamischen IP Adresse zu erreichen. Da kann ich den autodiscover nicht mit nem DNS-Eintrag umleiten.

    Hab jetzt die Lösungen gefunden: 

    • Die elegante Methode
      ne Subdomain anlegen namens autodiscover.meinedomain.de
      Diese dann auf die dynamische dyndns.info Adresse verweisen lassen. Dann kommt der mobile Client auch beim eigenem Exchange server raus und nicht bei autodiscover.1und1.info oder bei  autodiscover.strato.de
      (siehe auch Antwort von D.Jung)

    • Quick and Dirty - hosts Eintrag
      Wenn einen nur die Meldung nervt, dann kann man in der 
      C:\Windows\System32\drivers\etc\hosts den Eintrag
      127.0.0.1 autodiscover.meinedomain.de
      einfügen. Nun landet die Anfrage des Outlook-Autodiscover auf dem lokalem Rechner, läuft ins leere und es gibt keine nervige Meldung mehr.

      Der Hosts Eintrag kann auch auf den den eigenen DYNDNS-Server verweisen.
      Hier das Beispiel:
      server.dyndns.info autodiscover.meinedomain.de
      (das hab ich aber nicht ausprobiert)

    • hosts Eintrag + xml Datei
      Wer das noch erweitern will, kann nen Registry Eintrag auf ne lokale autodiscover.xml File setzen.
      Infos dazu hier: http://windowsitpro.com/windows/how-can-i-force-my-microsoft-outlook-2007-client-particular-autodiscovery-server
      .

    Hoffe das hilft jemandem.

    LG Alex

    PS: Den von Martin Sauerteig erwähnten MS-KB Artikel bringt in der Konfig mit nem dyndns Server leider recht wenig, da das Szenario mit ner Dynamischen IP zu spezifisch und zu weit ab der Microsoft'schen Norm ist.





    • Bearbeitet KasperXY Dienstag, 26. Januar 2016 14:11
    Dienstag, 26. Januar 2016 14:06