none
VPN Problem RRS feed

  • Frage

  • Hallo zusammen,

    leider funktioniert das Verbinden ( mit Laptop) von Skype for Business ohne VPN nicht mehr. Die ist so gewollt. Nur wenn ich eine W-Lan oder LAN Verbindung habe klappt auch die Skype Verbindung. Ich bekomme eine fehlermeldung auf dem Skype

    Server:

    Ereignis-ID 36871

    Schwerwiegender Fehler beim Erstellen der Anmeldeinformationen Client für SSL. Der interne Fehlerstatus ist 10013.

    Ich habe die IT vor kurzem übernommen und habe keine Doku oder einweisung dazu erhalten. Vieleicht könnt Ihr mir helfen.

    Windows Server 2012 R2 Standard

    Skype for Business 2015

    Danke für eure unterstützung!


    • Bearbeitet Bummelbaer Mittwoch, 16. November 2016 14:42 gelöst!!!
    Mittwoch, 12. Oktober 2016 10:13

Alle Antworten

  • Hi Bummelbär,

    den Zusammenhang zwischen VPN und WLAN und LAN verstehe ich nicht. SfB geht ohne VPN nicht - OK. Aber zum Aufbau eines VPN-Tunnels braucht man ja logischerweise irgendeine Netzwerkverbindung (LAN oder WLAN), somit verstehe ich die Aussage als überflüssig.

    Wann bekommst Du die Fehlermeldung auf dem Skype-Server? Wenn Du versuchst, eine Verbindung aufzubauen? Oder ist Dir der Fehler beim Überprüfen des Servers aufgefallen, ohne dass Du funktionale Einschränkungen bemerkt hättest?


    Liebe Grüße

    Ben

    ____________________________

    MCSA Office 365

    MCSA SQL Server 2014

    MCITP Windows 7

    MCSA Windows 8/10

    MCSE Server Infrastructure

    ____________________________

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort. Danke! :-).

    Mittwoch, 12. Oktober 2016 12:52
  • Hallo Ben,

    klar hast Du mit Deiner Aussage recht. VPN brauch LAN oder WAN verbindung. Schlecht von mir beschrieben!!

    Ich versuche es nochmal zu beschreiben:

    Ich möchte mich mit dem iPhone über Skype for Business Verbinden. Hierfür wurde ein Zertifikat erstellt und importiert. Dies hat alles mein Vorgänger gemacht. Nun kann ich mich nicht mehr von meinem iPhone verbinden, die Fehlermeldung: Der Server konnte nicht erreicht werden. Überprüfen Sie die Serveradresse, oder wiederholen Sie den Vorgang später.

     

    Ich habe alles versucht zu prüfen, Dienste, DNS Einträge ich konnte nichts finden! Weis nicht mehr weiter....

    Montag, 17. Oktober 2016 13:09
  • Hi Bummelbär,

    irgendwie bin ich jetzt noch verwirrter - oben schreibst Du "Laptop", nun schreibst Du, dass die Verbindung vom iPhone nicht klappt? :-)

    Baust Du nun die Verbindung vom Laptop oder vom iPhone auf? Deine Vorgehensweise:
    1. Zertifikat importiert
    2. VPN-Tunnel aufbauen
    3. Skype for Business starten

    ?

    Könnte es schlicht sein, dass das Zertifikat abgelaufen ist? Ansonsten könntest Du über den RCA mal die Skype-Verbindung testen:

    https://testconnectivity.microsoft.com/


    Liebe Grüße

    Ben

    ____________________________

    MCSA Office 365

    MCSA SQL Server 2014

    MCITP Windows 7

    MCSA Windows 8/10

    MCSE Server Infrastructure

    ____________________________

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort. Danke! :-).

    Montag, 17. Oktober 2016 14:25
  • Hi Ben,

    vielen Dank für Deine Mühe. Ich versuche hier alles irgendwie zu verstehen. Ja, ich versuche per iPhone und Skype for Business eine Verbindung aufzubauen und per NB über LTE.

    Testing remote connectivity to Microsoft Lync server through the Lync Access Edge server Edge.firma.de on port 443 to verify user benutzer@firma.de can connect remotely.

    Specified remote connectivity test(s) to Microsoft Lync server failed. See details below for specific failure reasons.

    Additional Details

    Elapsed Time: 267 ms.

    Test Steps

    Attempting to resolve the host name Edge.firma.de in DNS.

    The host name resolved successfully.

    Additional Details

    IP addresses returned: 217.91.xxx.xxx

    Elapsed Time: 18 ms.

    Testing TCP port 443 on host Edge.firma.de to ensure it's listening and open.

    The port was opened successfully.

    Additional Details

    Elapsed Time: 61 ms.

    Testing the SSL certificate to make sure it's valid.

    The SSL certificate failed one or more certificate validation checks.

    Additional Details

    Elapsed Time: 188 ms.

    Test Steps

    The Microsoft Connectivity Analyzer is attempting to obtain the SSL certificate from remote server Edge.ponturo.de on port 443.

    The Microsoft Connectivity Analyzer successfully obtained the remote SSL certificate.

    Additional Details

    Remote Certificate Subject: CN=lyncpoolfe01.firma.lan, OU=IT, O=firma AG, L=seppelhausen, S=Hessen, C=DE, Issuer: CN=firma-SERVSBS-CA.

    Elapsed Time: 163 ms.

    Validating the certificate name.

    Certificate name validation failed.

    Tell me more about this issue and how to resolve it

    Additional Details

    Host name Edge.firma.de doesn't match any name found on the server certificate CN=lyncpoolfe01.firma.lan, OU=IT, O=firma AG, L=seppelhausen, S=Hessen, C=DE.

    Elapsed Time: 0 ms.


    Montag, 17. Oktober 2016 14:38
  • Certificate name validation failed.

    Tell me more about this issue and how to resolve it

    Additional Details

    Host name Edge.firma.de doesn't match any name found on the server certificate CN=lyncpoolfe01.firma.lan, OU=IT, O=firma AG, L=seppelhausen, S=Hessen, C=DE.

    Elapsed Time: 0 ms.

    Da haben wir einen Fehler. Ob dieser für das beobachtete Problem verantwortlich ist, kann ich leider nicht sagen, aber es wäre zu vermuten.

    Du wirst hier wohl ein neues bzw. anders konfiguriertes Zertifikat brauchen. Normalerweise hätte man früher den Namen als sog. Subject Alternate Name einfach dem Zertifikat hinzugefügt, das wird aber spätestens seit November 2015 als Sicherheitsrisiko bewertet, daher bekommt man keine Zertifikate mehr mit SANs.


    Liebe Grüße

    Ben

    ____________________________

    MCSA Office 365

    MCSA SQL Server 2014

    MCITP Windows 7

    MCSA Windows 8/10

    MCSE Server Infrastructure

    ____________________________

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort. Danke! :-).

    Montag, 17. Oktober 2016 14:59
  • Hallo Ben,

    Danke für Deine Antwort. Ich bin mir aber nicht ganz sicher ob es dieser Fehler ist oder ich das Prinzip hier in der Firma noch nicht verstanden habe? Wenn ich das Tool von Microsoft mit Standard Einstellungen durchführe, kommt das raus? Ich komm gerade nicht klar!!!!! Kennst du jemanden der sich da mal remote anschauen kann?


     


    Testing remote connectivity for user benutzer@firma.de to the Microsoft Lync server.

    Specified remote connectivity test(s) to Microsoft Lync server failed. See details below for specific failure reasons.

    Additional Details

    Elapsed Time: 22822 ms.

    Test Steps

    Attempting to resolve the host name sip.firma.de in DNS.

    The host name resolved successfully.

    Additional Details

    IP addresses returned: 217.91.xxx.xxx

    Elapsed Time: 515 ms.

    Testing TCP port 5061 on host sip.firma.de to ensure it's listening and open.

    The specified port is either blocked, not listening, or not producing the expected response.

    Tell me more about this issue and how to resolve it

    Additional Details

    A network error occurred while communicating with the remote host.

    Elapsed Time: 21288 ms.

    Dienstag, 18. Oktober 2016 07:14
  • Hi Bummelbär,

    Skype for Business ist recht komplex in der Einrichtung und nicht mal eben so per Klick-Klick-Glück eingerichtet. Ich bin selbst auch kein SfB-Experte und fummle ungern in Konfigurationen rum, die ich nicht selbst aufgesetzt habe.

    Der Port 5061 dient zur internen SIP-Kommunikation, ich bin mir nicht sicher, warum das an der Stelle angemeckert wird. Intern läuft SfB ja?

    Quelle: https://technet.microsoft.com/de-de/library/gg398833.aspx?f=255&MSPPError=-2147217396

    Wahrscheinlich ist der RCA hier auch eher fehl am Platz, weil ja die Verbindung nur über VPN funktionieren soll. Ich schätze, dass deswegen die ganzen Tests fehlschlagen.


    Liebe Grüße

    Ben

    ____________________________

    MCSA Office 365

    MCSA SQL Server 2014

    MCITP Windows 7

    MCSA Windows 8/10

    MCSE Server Infrastructure

    ____________________________

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort. Danke! :-).

    Mittwoch, 19. Oktober 2016 09:05
  • Hallo Ben,

    ja, intern läuft der S4B ohne Probleme! Das ist ja das was ich nicht verstehe! Ich vermute ja das ein Eintrag im DNS fehlt, sicher bin ich mir da nicht. Aber dir Danke ich für Deine Ideen.

    Viele Grüße

    Andy

    Mittwoch, 19. Oktober 2016 09:16
  • Hi Andy,

    naja, VPN ist immer noch was anderes als eine lokale Netzverbindung. Bei VPN sind meistens irgendwelche Firewall-Freischaltungen nicht richtig konfiguriert. Wenn SfB intern problemlos läuft, könntest Du noch folgendes tun:
    1. DNS-Auflösung von einem externen Client (Laptop) aus testen - kannst Du den Namen des Skype-Serverpools bzw. der benötigten Gegenstelle über das VPN auflösen (ping <SERVER-/POOLNAME>)?
    2. Prüfe die Firewall-Einstellungen, was alles über VPN hin zu Skype for Business erlaubt ist. Die bereits genannte Quelle aus dem TechNet kann Dir als Referenz dienen, welche Ports offen sein müssen, damit der SfB-Client funktioniert.


    Liebe Grüße

    Ben

    ____________________________

    MCSA Office 365

    MCSA SQL Server 2014

    MCITP Windows 7

    MCSA Windows 8/10

    MCSE Server Infrastructure

    ____________________________

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort. Danke! :-).

    Mittwoch, 19. Oktober 2016 09:41
  • Hallo Ben,

     

    bin noch dran. Wollte dir nur noch kurze Info geben. Wenn ich weiß was das Problem ist oder war, melde ich noch bei Dir.

     

    VG

    Andy


    Montag, 24. Oktober 2016 13:50
  • Hallo Ben,

    ich habe gerade gesehen, dass der Skype EDGE Server keine Verbindung zum Internet hat! Ich dachte dieser brauch den Zugang ins Internet für Sharing, Federation usw! Nun bin ich nicht mehr sicher....

    Könnte dass das Problem wegen VPN sein?

    Hast du eine Idee dazu?

     

    Danke für Deine Hilfe!

     

    VG

    Andy

    Mittwoch, 26. Oktober 2016 14:10
  • ME muss der Edge-Server eine Internetverbindung haben, da er ja quasi eine Schnittstelle zwischen internen und externen Nutzern darstellt. Was mich dann aber zu der Frage führt, wer dem Server den Zugriff geklaut hat, wenn das der Grund sein sollte. https://technet.microsoft.com/de-de/library/dn933903.aspx Der Artikel enthält alle Informationen rund um die Edge-Bereitstellung. Nach dem, was ich auf die Schnelle gelesen habe, sollte man daran aber nicht ohne Ahnung herumfummeln. Du solltest Dir eher einen SFB-Experten suchen und Dich schnellstens um eine Fortbildung bemühen, um das Teil administrieren zu können...

    Liebe Grüße

    Ben

    ____________________________

    MCSA Office 365

    MCSA SQL Server 2014

    MCITP Windows 7

    MCSA Windows 8/10

    MCSE Server Infrastructure

    ____________________________

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort. Danke! :-).

    Mittwoch, 26. Oktober 2016 17:53