none
Exchange 2010 msftefd.exe Prozess zieht temp. 100%CPU

    Frage

  • Hallo

    immer mittwochs zwischen 7:45 und 8:35 Uhr laufen auf dem EXC2010 mit der Mailboxrolle 6-7 msftefd.exe Prozesse und 2-3  von denen ziehen 100% CPU. An dem Prozess steht MS Office SharePoint Portal Server 2004 Server dran. Hat in dem Fall aber nichts mit dem SPS zu tun, da auf dem MBX kein SPS installiert ist. Der Prozess wird wohl von Exchange dafür verwendet, den Index der Datenbanken zu erstellen/warten, was auch immer. Ich habe u.a. das Logging für den Index/Searchprozess im Exchange auf Expert gestellt, finde dazu aber nichts im Eventlog. Es gibt auch keine geschedulten Jobs die immer mittwochs laufen und das Problem verursachen könnten. Über die PS Befehle ContentIndexState, test-exchangeSearch  und get-FailedContentIndexDocumentsuser kann ich keine Fehler finden!
    Linderung kann man schaffen, wenn man beim Auftreten des Problems die Affinität der Prozesse manuell auf eine CPU stellt. Aber das gilt wohl nur für den laufenden Prozess und nach einer Woche, wenn der Prozess neu startet nimmt er sich wieder beide CPUs.
    Die Frage ist, ob jemand eine Möglichkeit sieht die Affinität für den Prozess generell und dauerhaft auf eine CPU zu beschränken und ob es in der Regestry für den Prozess evtl. einen Scheduler gibt, der ihn immer Mittwoch morgens antriggert.

    Danke!

    Mittwoch, 2. Mai 2018 14:04

Antworten

  • Moin,

    ich bin ein Freund davon, die Ursache zu erkunden und zu beseitigen und nicht an den Symptomen rumzufrickeln.

    Daher zuerst mal die wichtigste Frage - welche SP und RU Version hat der Server genau:

    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    Wenn Du nicht auf SP 3 mit RU 19 kommst, ist patchen der ersten Schritt.

    Nicht dass wir über einen schon längst behobenen Bug reden.

    Falls das nicht zutrifft, brauchen wir mehr Infos. Welches OS, virtualisiert (wie?), läuft ein Virenscanner im OS auf dem Server (mal testweise abschalten).


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Mittwoch, 2. Mai 2018 16:30

Alle Antworten

  • Moin,

    ich bin ein Freund davon, die Ursache zu erkunden und zu beseitigen und nicht an den Symptomen rumzufrickeln.

    Daher zuerst mal die wichtigste Frage - welche SP und RU Version hat der Server genau:

    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    Wenn Du nicht auf SP 3 mit RU 19 kommst, ist patchen der ersten Schritt.

    Nicht dass wir über einen schon längst behobenen Bug reden.

    Falls das nicht zutrifft, brauchen wir mehr Infos. Welches OS, virtualisiert (wie?), läuft ein Virenscanner im OS auf dem Server (mal testweise abschalten).


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Mittwoch, 2. Mai 2018 16:30
  • Hallo Robert,

    danke für die Antwort.
    Prinzipiell bin ich auch dafür die Ursache zu beheben. Dies sollte nur als Workarround dienen und wenn es einen irgendwie gearteten Scheduler für das Indexing geben sollte, auch eine Eingrenzung, da ich nicht zu 100% sicher bin ob es der Indexing ist. Ich hatte bereits einen Dienstleister an dem Thema, der hat aber bereits die Flügel gestreckt. Hätte ja sein können das jemand das Problem kennt oder irgend welche Einträge in der Reg die das verursachen.

    SP3 RU18
    W2k8R2 virtuell VMWare

    Es gibt einen Virenscanner der aber keinen Job zu dem Zeitpunkt laufen hat und deaktiviert hatte ich den auch schon mal an den besagten Mittwochen.

    Im Normalfall läuft der msftefd.exe Job auch nur als einzelner Prozess im Taskmanager, nur Mittwoch morgens bis zu sieben mal.

    Dann muss ich bei nächster Gelegenheit das RU19 einspielen. Bin nur aktuell knapp an Zeit.

    Danke!

    Donnerstag, 3. Mai 2018 06:33