none
Mail routing problems between two sites

    Frage

  • Dear Concern,

    I have two site Site A (DC site) and Site B (DR site) and 3 Exchange server 2010, 2 are in Site A and 1 is in Site B. When Site A users send mail to site A users it passes to Site B Exchange server and mails are queued in submission queue and give a error:

    Failed to process message due to a transient exception with message The user and the mailbox are in different Active Directory sites.

    I also enable site affinity and DR site exchange shows in Site B.

    what's the cause of this internal mail routing issue.

    Thanks.

    Dienstag, 5. Juni 2018 04:58

Alle Antworten

  • Dear concern,

    Any update!!!

    Mittwoch, 6. Juni 2018 02:08
  • Tip:  Don't post "Any update!!!" or anything else in response to your own question because it causes it to no longer show up in "No Replies".  I look at "No Replies" first in the forums I work and I didn't see your question until now because you replied to it yourself in your impatience.

    What roles are installed on the three servers?

    Have you created any send connectors?  If so, tell us about them.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Mittwoch, 6. Juni 2018 23:22
    Moderator
  • Hi Ed Crowley, thanks for your  suggestion. Three servers has CAS, Mailbox and Hub transport role and also has a send connector for outbound mail.

    Thanks



    • Bearbeitet Raz07 Donnerstag, 7. Juni 2018 03:07
    Donnerstag, 7. Juni 2018 03:06
  • Does this help?

    http://sarveshgoel.com/user-mailbox-two-different-active-directory-sites-performing-datacenter-switchover/


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Donnerstag, 7. Juni 2018 11:17
    Moderator
    • Thanks Crowley for replying but how can I fixed the Active Directory replication between two sites. Please advice.

    • Bearbeitet Raz07 Donnerstag, 7. Juni 2018 15:24
    Donnerstag, 7. Juni 2018 15:23
  • First, make sure that the firewalls have all ports opened between all domain controllers.  You can use DCDIAG and REPADMIN to troubleshoot AD replication.

    I recommend that you start a new thread about your AD replication issues in the Active Directory Services Forum: http://social.technet.microsoft.com/Forums/en-US/winserverDS/threads

    Before doing that, I recommend you perform your own research on troubleshooting AD replication so that you don't get slammed for asking basic questions you should be able to answer from an Internet search.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!



    Donnerstag, 7. Juni 2018 19:04
    Moderator
  • Thanks Crowley for updating.
    Freitag, 8. Juni 2018 02:00
  • Hi,

    It has been a long time since you made the last post on this thread. If you need further help, please feel free to reply this post directly so we will be notified to follow it up.

    Thanks for your understandings!

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Dienstag, 12. Juni 2018 09:50
    Moderator