none
Fehler bei SQL Server-Anmeldung: HYT00 RRS feed

  • Frage

  • Wir nutzen einen SBS Server 2003 mit SQL-Server 2005.

    Hier läuft eine FiBu-Anwendungsdatenbank.

    Nach einem Serverneustart ist jedoch kein TCP-Zugriff mehr von Clients auf den SQL-Server möglich.

    Richten wir am Server selbst eine ODBC-Verbindung zur Datenbank ein, erhalten wir sowohl über TCP/1433 bzw. named pipes NP Zugriff auf die Datenbank.

    Machen wir das Gleiche an einem Windows XP-Client funktioniert der Zugriff nur über named pipes.

    Beim Zugriff über TCP/1433 erhalten wir eine Fehlermeldung:

    Fehler bei der Verbindung

    SQLState: `HYT00'

    SQL Server-Fehler: 0

    MS ODBC SQL Server Timeout abgelaufen.

    Die Überprüfung der Netzwerkverbindung hat keine Einschränkungen erkennen lassen,

    PortQuery liefert folgendes Ergebnis:

    =============================================

     Starting portqry.exe -n Master -e 1434 -p UDP ...


    Querying target system called:

     Master

    Attempting to resolve name to IP address...


    Name resolved to 10.0.0.1

    querying...

    UDP port 1434 (ms-sql-m service): LISTENING or FILTERED

    Sending SQL Server query to UDP port 1434...

    Server's response:

    ServerName MASTER
    InstanceName MSSQLSERVER
    IsClustered No
    Version 9.00.4035.00
    tcp 1433
    np \\MASTER\pipe\sql\query

     

    ==== End of SQL Server query response ====

    UDP port 1434 is LISTENING
    portqry.exe -n Master -e 1434 -p UDP exits with return code 0x00000000.
    =============================================

     Starting portqry.exe -n Master -e 1433 -p TCP ...


    Querying target system called:

     Master

    Attempting to resolve name to IP address...

    Name resolved to 10.0.0.1

    querying...

    TCP port 1433 (ms-sql-s service): LISTENING
    portqry.exe -n Master -e 1433 -p TCP exits with return code 0x00000000.

    Am Server selbst wird der ISA-Server 2004 verwendet.

    Weiterhin sind im Netzwerk noch zwei weitere SQL-Server auf unterschiedlichen Maschinen installiert.

    Momentan bin ich ratlos, wo ich noch nach dem Fehler suchen kann.

    Die HYT00-Fehler-Berichte bin ich schon mehrmals durch. Irgendwie habe ich den Eindruck der ISA-Server oder eine andere Firewall blockt den Verbindungsaufbau, aber die Protokollierung ergibt keine Zugriffsverweigerung.

    mfg

    JF

     

     

    Dienstag, 9. November 2010 11:58

Alle Antworten

  • Hallo,

    ist das Problem noch aktuell?

    Schon probiert vom XP Client mittels telnet eine Verbindung auf Port 1433 herzustellen?

    Gruß,
    Andrei

    Dienstag, 16. November 2010 14:12
  • Selbstverständlich ausprobiert, läuft bestens?
    Dienstag, 16. November 2010 17:33
  • Hallo Jenny,

    ich nehme an, in den ODBC Verbindungen wurde der Name des Servers angegeben und wenn ich das oben richtig interpretiere, handelt es sich um eine Standard-Instanz (MSSQLSERVER) und keine benannte, richtig?

    Hast Du schon mal versucht, statt den Namen die TCP/IP Daten als Servernamen anzugeben? Also statt "MASTER" => "tcp:10.0.0.1, 1433".


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    Mittwoch, 17. November 2010 06:54
  • Nein, das habe ich noch nicht gecheckt. Werde ich aber noch in dieser Woche ausprobieren.

     

    mfg

    jf

     

    Dienstag, 7. Dezember 2010 21:34
  • Die von Olaf vorgeschlagene Lösung funktioniert nicht!
    Mittwoch, 8. Dezember 2010 18:55