none
Outlook 2010 <-> Exchange 2007 Sendeintervall RRS feed

  • Allgemeine Diskussion

  • Hallo Leute,

    ich hab ein Outllook 2010, dass über eine IPSEC-VPN an einem Exchange 2007 per TCP/IP (kein https over TCP/IP) mit eingeschaltetem Cache hängt.

    Mitunter wird beobachtet, dass sich ein abgeschickte Mail in Outlook bereits im Ordner "gesendete Objekte" befindet, die den Exchange aber noch nicht erreicht hat. Somit ist sie wohl im lokalen Cache. Der Benutzer geht aber davon aus, dass die Mail verschickt ist, und schließt Outlook bzw. fährt den Rechner runter mit dem Resultat, dass die Mail erst am nächsten Tag - wenn Outlook wieder online ist - raus geht.

    Ist dieses Verhalten normal bzw. kann ich das irgendwo beeinflussen? Ich möchte gerne, dass die Mail erst dann in "gesendete Objekte" erscheint, wenn sich auch wiklich erfolgreich an den Exchange übergeben wurde. Ein Abschalten des Caches scheidet aus.


    Viele Grüße Dirk

    • Typ geändert Alex Pitulice Mittwoch, 19. September 2012 09:18 Warten auf Feedback nach Testen
    Mittwoch, 12. September 2012 14:03

Alle Antworten

  • Hi Dirk,

    kann mir nur vorstellen, dass dies an der Firewall / VPN liegt.

    TCP/IP RPC verwendet die Ports von 1024 - 65535 (kein https). Sporadisch kann es sein, dass genau diese Ports zum Versand genommen werden aber in der FW nicht freigeschaltet sind, was das Phänomen erklären könnte.

    Existiert zwischen VPN und Exchange noch eine extra Firewall?

    http://www.proexchange.be/blogs/exchange2007/archive/2009/05/18/configuring-static-ports-for-exchange-2007.aspx

    Hast du ein CAS-Array und dort feste Ports für RPC konfiguriert?

    Gruß

    Dominik


    Lync-Federation: dominik.hoefling@newcotec.com


    Donnerstag, 13. September 2012 11:50
  • Hi Dominik,

    zwischen E2k7 und Outllok ist keine weitere Firewall, die Outlooks connecten sich über ein Router-Router IPSEC-VPN, bei dem nichts (keine Ports) limitiert sind. Es existeirt auch nur ein E2k7, kein separater CAS.


    Viele Grüße Dirk

    Donnerstag, 13. September 2012 12:17
  • Kannst du im TrackingLog noch etwas bzgl. der Zustellungszeit der Mails feststellen?

    ExBPA bringt keine Fehlermeldungen?

    Gruß

    Dominik


    Lync-Federation: dominik.hoefling@newcotec.com

    Donnerstag, 13. September 2012 12:19
  • Im Log sehe ich, dass die Mail am Tag danach etwa 3 Minuten nach Anmeldung des Users am Exchange eingetroffen ist. Das passt ganz gut zu dem Vorgang "Anmelden und dann Outlook starten". Der Benutzer hat am Vorabend beim Schließen keine Meldung "Es befinden sich noch Mails im Postausgang.." bekommen, was ja auch stimmt, er hat extra darauf geachtet, dass die Mail in "gesendete Objekte" auftaucht, bevor den Rechner heruntergefahren hat.

    Interessant zu wissen wäre hier der exakte Ablauf: Ich denke Outook leg sie in "gesendete Objekte" im lokalen Cache ab, der dann kurz danach synchronisiert wird. Macht der User Outlook zu, bevor der sync durch ist, ensteht das Problem.

    ExBPA zeigt nichts relevantes an.


    Viele Grüße Dirk

    Donnerstag, 13. September 2012 13:08
  • Den Ablauf kannst du bei Frank nachlesen:

    http://www.msxfaq.de/clients/cachedmode.htm

    "Verzögerung beim Senden"

    In welcher Zeit schließt der User sein Outlook nach dem Senden?



    Donnerstag, 13. September 2012 13:16
  • Prima, danke, das erklärt das Verhalten ein Stück weit.

    Der User hat Outlook unmittelbar geschlossen, als er gesehen hat, dass die Mail aus "Postausgang" verschwunden ist. Das kann gut inerhalb dieser 15 Sekunden gewesen sein.

    Weisst Du (oder jemand anders), ob man diesen Wert beeinflussen kann?


    Viele Grüße Dirk

    Donnerstag, 13. September 2012 13:22
  • Hallo,

    mich würde auch das Nachrichtenträcking interessieren. Ich wette der Sync ist noch nicht abgeschlossen und die Email wird erst bei nächsten Start synchronisiert.

    Sende eine Email am Notebook, zieh das Kabel und versuch das Problem nachzustellen.

    Outlook ist dumm und legt die Email erst am, wenn sie gesendet ist. Im Nachrichtentracking sieht du auch einen Storedrive-Event der die Email in den gesendeten Objekten ablegt, sofern nicht schon geschehen.

    Viele Grüße

    Christian

    Donnerstag, 13. September 2012 13:25
    Moderator
  • Hi Dirk,

    ja, das geht:

    http://www.msoutlook.info/question/300

    Tweaking the synchronization timers

    You can adjust the above timers if needed by modifying the following registry keys;

    Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\<version>\Outlook\Cached Mode

    Value name: Download
    Value type: REG_DWORD
    Default value: 0000001e (30 seconds)

    Value name: Upload
    Value type: REG_DWORD
    Default value: 0000000f (15 seconds)

    Value name: Maximum
    Value type: REG_DWORD
    Default value: 0000003c (60 seconds)


    Lync-Federation: dominik.hoefling@newcotec.com

    Donnerstag, 13. September 2012 13:28
  • Hier das anonymisierte Tracking und was der User im Outlook sieht:


    Viele Grüße Dirk

    Donnerstag, 13. September 2012 13:34
  • Danke Dominik, das probiere ich nächste Woche mal aus.

    Viele Grüße Dirk

    Donnerstag, 13. September 2012 13:35
  • Gerne, geht auch über GPOs Unternehmensweit.

    Ich bin gespannt :-) Lass es uns bitte wissen, danke.


    Lync-Federation: dominik.hoefling@newcotec.com

    Donnerstag, 13. September 2012 13:36
  • Ich bin auch gespannt und hatte mir das noch nicht so genau angeschaut, da wir bisher noch keine Probleme in der Richtung hatten.

    Wird die EMail aus dem Postausgang entfernt nachdem oder bevor der Sync abgeschlossen wird? Finde ich wirklich interessant... :-)

    Viele Grüße
    Christian

    Donnerstag, 13. September 2012 13:56
    Moderator
  • @Dirk: du kannst nach dem Senden auch mal ins OWA gucken, ob dort die Mail unter gesendete Objekte abgelegt wurde.

    @Christian: soweit ich weiß, bevor der Sync abgeschlossen ist. Outlook hat einen intelligenten Algorithmus, was die Synchronisation von Ordnern angeht. Hier die Links:

    http://www.msoutlook.info/question/670 (die Seite ist richtig gut)

    http://support.microsoft.com/kb/2686906

    Gruß

    Dominik


    Lync-Federation: dominik.hoefling@newcotec.com

    Donnerstag, 13. September 2012 14:09
  • Hi Dominik,

    @Christian: soweit ich weiß, bevor der Sync abgeschlossen ist. Outlook hat einen intelligenten Algorithmus, was die Synchronisation von Ordnern angeht. Hier die Links:

    Sehr intelligent eine Email in den Ordner gesendet zu verschieben ohne sie an den Exchange übergeben zu haben. :D

    http://www.msoutlook.info/question/670 (die Seite ist richtig gut)

    Kann ich nur zustimmen! :-)

    http://support.microsoft.com/kb/2686906

    Die ist auch gut, aber nur auf englisch! :')


    Viele Grüße
    Christian

    Donnerstag, 13. September 2012 17:41
    Moderator

  • Sehr intelligent eine Email in den Ordner gesendet zu verschieben ohne sie an den Exchange übergeben zu haben. :D


    Vielleicht sollten die diese Logik auch mal bei vollen Festplatten anwenden. Dann muss man dem Kunden nicht immer erklären, warum zu wenig Platz zum Löschen da ist ;-)

    Guido Over MCITP Server Administrator 2008 & MCSA Windows 2008 & MCITP Enterprise Administrator 2008

    Freitag, 14. September 2012 06:18
  • Land unter heute, bin noch nicht dazugekommen, weiter zu testen. Melde mich aber dann umgehend.

    Viele Grüße Dirk

    Montag, 17. September 2012 12:50
  • Also ich habe jetzt zig Mal versucht, das Verhalten nachzustellen am Remotestandort (=mit gleichem Connect). Ich habs nicht geschafft. Auch wenn ich Outlook sofort nach dem Senden schließe, wird die Mail korrekt zugestellt.

    Es muss also bei dem berichtenden User (kein DAO) etwas anderes zugeschlagen haben, vemutlich war die Verbindung kurz weg oder Outlook offline oder sonst was.

    Ich haks mal ab und warte, ob es wieder kommt.

    Herzlichen Dank Euch allen für die Tipps.


    Viele Grüße Dirk

    Dienstag, 18. September 2012 12:14
  • Mittwoch, 19. September 2012 09:18
  • Ich komm nochmal auf das Problem zurück, weil es immer noch existiert.

    Ganz konkret hat ein Benutzer (im LAN) eine Mail verschickt, die in Outlook in den gesendeten Objekten landed. Schaue ich mit OWA aufs Postfach, dann fehlt sie dort. Selbst nach Stunden ist sie dort nicht synchronisiert, während Outlook frech behauptet: Alle Ordner sind aktualisiert.

    Das kanns doch nicht sein. Ideen?

    Ergänzung: sende ich dann eine neue Mail, ist sie sofort an beiden Stellen da. Das treibt mich in den Wahnsinn...


    Viele Grüße Dirk


    • Bearbeitet -Dirk- Freitag, 1. Februar 2013 15:20
    Freitag, 1. Februar 2013 15:19