none
KB2830145 - Hotfix lässt sich nicht installieren RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    ich habe das Problem, welches mit KB2830145 behoben werden soll.

    Dieses Hotfix lässt sich bei mir aber weder auf Windows7 noch Server 2008 R2 installieren.

    Es passiert über Stunden (auf einem Server mittlerweile 17 Stunden) gar nichts.

     

    Wenn ich einen Client oder Server neu installiere (ohne Windows-Updates) kann ich das Hotfix innerhalb von Minuten installieren.

    Wenn ich es aber auf einem aktuellen System probiere, auf dem dann alle Updates installiert sind, passiert nichts. Ein Deinstallieren der Updates bringt auch keine Lösung.

    Auch auf Rechnern von Freunden konnte ich das so nachstellen. In alten Beiträgen steht nur, dass mit dem Hotfix alles in Ordnung ist. Die sind aber alle schon älter.

     

    Gibt es eine Lösung für dieses Problem? Kennt das jemand?

    Samstag, 10. Oktober 2015 18:23

Alle Antworten

  • Hallo zusammen,

    ich habe das Problem, welches mit KB2830145 behoben werden soll.

    Dieses Hotfix lässt sich bei mir aber weder auf Windows7 noch Server 2008 R2 installieren.

    Es passiert über Stunden (auf einem Server mittlerweile 17 Stunden) gar nichts.

     

    Wenn ich einen Client oder Server neu installiere (ohne Windows-Updates) kann ich das Hotfix innerhalb von Minuten installieren.

    Wenn ich es aber auf einem aktuellen System probiere, auf dem dann alle Updates installiert sind, passiert nichts. Ein Deinstallieren der Updates bringt auch keine Lösung.

    Auch auf Rechnern von Freunden konnte ich das so nachstellen. In alten Beiträgen steht nur, dass mit dem Hotfix alles in Ordnung ist. Die sind aber alle schon älter.

     

    Gibt es eine Lösung für dieses Problem? Kennt das jemand?

    Bei uns hier genau das selbe Problem. Installation hängt. Kann nicht fertig gestellt oder abgebrochen werden.

    PC muss "hart" ausgeschaltet werden!!

    Montag, 16. November 2015 13:36
  • Hallo,

    wie sieht es in den Eventslogs aus? "Installation"

    Auch mal die cbs.log aufmachen unter c:\windows\logs\cbs\cbs.log und mal durchschauen.

    Das folgende Skript bereinigt grundlegende Update-Thematiken.

    In eine Textdatei kopieren, als Skript.bat abspeichern und mit Rechtsklick als Admin ausführen:

    sfc /scannow
    findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >c:\windows\logs\cbs\sfcdetails.log
     
    net stop wuauserv
    net stop cryptSvc
    net stop bits
    net stop msiserver
    ren %WINDIR%\SoftwareDistribution SoftwareDistribution.bak
    ren %WINDIR%\System32\catroot2 catroot2.bak
    net start wuauserv
    net start cryptSvc
    net start bits
    net start msiserver
     
    fsutil resource setautoreset true c:\ 
    echo #### Info:
    fsutil resource info C:
     
    echo MSI
    sc config msiserver start= demand
    Net stop msiserver
    MSIExec /unregister
    MSIExec /regserver
    regsvr32.exe /s %windir%\system32\msi.dll
    Net start msiserver
    sc config msiserver start= auto
    
    pause

    Danach 2 mal neustarten und nochmal versuchen.

    Wenn das auch nix bringt, einmal nen CheckSUR auspobieren. Der verifiziert alle Updates nochmal und spuckt auch ne Log aus. Link

    Bitte hier unbedingt auf die Version achten. Das Log landet dann auch im CBS-Ordner. Dann auch mal anschauen. Update dann natürlich erst wieder nach einem Neustart erst versuchen.


    Best regards,

    David das Neves

    Technology Specialist - Consulting Services
    Computacenter AG & Co. oHG - Munich

    Blog    
    Creating Powershell GUIs with XAML? Take a look! PSGUI

    Mittwoch, 18. November 2015 21:34