none
Proxy-Einstellungen mittels unattend.xml funktioniert nicht RRS feed

  • Frage

  • Hallo Forum!

    Wir versuchen seit geraumer Zeit vergeblich die Proxy-Einstellungen mittels unattend.xml bei der Installation mit zu geben.
    Leider ohne Erfolg. Wir haben schon viele Varianten probiert, funktioniert hat leider keine. Sprich: der Proxy bleibt immer deaktiviert und
    die Ausnahmen werden nicht übernommen.

    ----------------------------------
            <component name="Microsoft-Windows-IE-ClientNetworkProtocolImplementation" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <HKLMProxyEnable>true</HKLMProxyEnable>
                <HKLMProxyServer>proxy.domain.local:8080</HKLMProxyServer>
            </component>
    ----------------------------------
    Auszug aus der Unattend.xml

    Gibt es da einen Trick bei Windows 7?

    Vielen Dank im Voraus!

    Dietmar
    Dienstag, 9. Februar 2010 10:40

Antworten

  • OK. Obwohl keine Policies auf den Client wirken muss folgende Zeile in die unattend.xml eingefügt werden:


    ----------------------------------
            <component name="Microsoft-Windows-IE-ClientNetworkProtocolImplementation" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               <POLICYProxySettingsPerUser>0</POLICYProxySettingsPerUser>
                <HKLMProxyEnable>true</HKLMProxyEnable>
                <HKLMProxyServer>proxy.domain.local:8080</HKLMProxyServer>
            </component>
    ----------------------------------

    Jetzt funktioniert's.

    Dietmar
    • Als Antwort markiert Dietmar H. _ Dienstag, 9. Februar 2010 12:42
    Dienstag, 9. Februar 2010 12:42

Alle Antworten

  • OK. Obwohl keine Policies auf den Client wirken muss folgende Zeile in die unattend.xml eingefügt werden:


    ----------------------------------
            <component name="Microsoft-Windows-IE-ClientNetworkProtocolImplementation" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               <POLICYProxySettingsPerUser>0</POLICYProxySettingsPerUser>
                <HKLMProxyEnable>true</HKLMProxyEnable>
                <HKLMProxyServer>proxy.domain.local:8080</HKLMProxyServer>
            </component>
    ----------------------------------

    Jetzt funktioniert's.

    Dietmar
    • Als Antwort markiert Dietmar H. _ Dienstag, 9. Februar 2010 12:42
    Dienstag, 9. Februar 2010 12:42
  • Hi, bin auch schon darauf gestoßen, habe die Policy per Reg Import auf "not configured" also 0 konfiguriert (OOBE | Shell Setup | FirstLogonCommands | ).
      
    Was ich allerdings bisher noch nicht gefunden habe ist wie man eine AutoConfigURL für den Proxy hinterlegen kann.

    Zur Zeit setzte ich den Proxy per Setup Responsefile (jedes xml hat einen anderen Proxy, das autounattend.xml wird von einem REX Script generiert) und führe nach dem Setup ein Script via FirstLogonCommand aus welches den Proxy aus der Reg ausliest und dann den Reg key:

        [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
        "AutoConfigURL"="http://proxy0XX.MandantXX:81"

    setzt. Durch diesen RegKey bekommt jeder User der sich neu an den Server (TerminalServer) diese Proxy Einstellung gesetzt.
    Donnerstag, 11. Februar 2010 15:45