none
Excel 2016: Formelfehler bei Summewenn(..)

    Frage

  • Hallo zusammen,

    die Formel Summewenn() liefert völlig falsche Ergebnisse. Dies scheint seit Office >2010 kein wirklich unbekanntes Problem zu sein. In diversen Foren wird die Ursache bei der Länge des Kriteriums vermutet, was aber anhand eines kleinen Beispiels nicht der Grund sein kann. Für den Suchbereich markiere ich die gesamte Tabelle, das einzige Suchkriterium hat eine Länge max. 5 Buchstaben und der Ergebnisbereich entspricht den Zellen der Spalte mit den relevanten Werten, die addiert werden sollen. 

    Mache ich hier einen grundsätzlichen Fehler und wo liegt der oder haben wir hier einen Programmierfehler? Wenn Letzteres zutrifft, hätte ich gerne gewusst wann es endlich eine funktionierende Formel gibt.  

    Viele Grüße.

    PS: Den Screenshot des Beispiels kann ich leider nicht einfügen, da ich hier neu bin und mein Konto erst noch geprüft werden muss.


    • Bearbeitet MBaumwurz Freitag, 26. Januar 2018 13:59
    Freitag, 26. Januar 2018 13:52

Alle Antworten

  • Ich vermute da eher, dass die Vergleichs und Suchwerte nicht ganz passen.
    Relevant sind da auf jeden Fall immer Leerzeichen am Anfang oder Ende sowohl des Spalteninhaltes als auch des Prüfwertes.
    Wenn also eine Zelle z.B "A " enthält kann sie nicht mit "A" vergleichen werden.
    In diesem Fall kannst du u.U. mit GLÄTTEN(Spalte) und GLÄTTEN(Suchwert) was erreichen.

    Freitag, 26. Januar 2018 14:05
  • Vielen Dank für die Antwort, aber dieses Problem sehe ich bei meinem Beispiel nicht, vor allem, wenn ich Zelle A2 direkt in Zelle A6 kopiere.

    1      A          B

    2     Alpha    10

    3     Beta     20

    4     Alpha    50

    5     Beta     70

    6     Alpha   =Summewenn(A1:B4;A6;B2:B5)

    7     Beta     =Summewenn(A1:B4;A7;B2:B5)


    • Bearbeitet MBaumwurz Freitag, 26. Januar 2018 16:17
    Freitag, 26. Januar 2018 16:15
  • Wieso läst du Spalte B mit durchsuchen? Spalte B ist doch für die Summe:

    =SUMMEWENN($A$1:$A$4;A5;B1:B4)

    Freitag, 26. Januar 2018 17:13
  • Stimmt, der Fehler lag bei mir!!!

    War davon ausgegangen, dass ich die gesamte Tabelle markieren muss. 

    Vielen herzlichen Dank für den Tipp.

    Samstag, 27. Januar 2018 09:42