none
AD-Schemamaster nicht erreichbar RRS feed

  • Frage

  • Hallo zusammen,

    es gilt die Hardware eines Exchange Server 2010 zu ersetzen. Die neue Hardware wurde aufgesetzt, W2k8 R2, und Exchange Server 2010 SP1 installiert. Bei der Installation des SP3 für Exchange Server 2010 meldet die Installationsroutine nun Fehler:

    --------------------------------------------------------------------------------------------------

    Zusammenfassung: 6 Element(e). Erfolgreich: 2, Fehler: 4.
    Verstrichene Zeit: 00:00:43

    Voraussetzungen werden konfiguriert
    Abgeschlossen

    Verstrichene Zeit: 00:00:00


    Voraussetzungen für Organisation
    Fehler

    Fehler:
    Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen, dieser Computer befindet sich jedoch nicht am gleichen Active Directory-Standort wie der Schemamaster (Default-First-Site-Name).
    Hier klicken, um die Hilfe aufzurufen... http://go.microsoft.com/fwlink/?linkid=30939&l=de&v=ExBPA.14&id=2376fec1-b9ce-44db-beb6-cb9ac4788988

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'ikt' und im Standort 'Default-First-Site-Name' aus, und warten Sie auf den Abschluss der Replikation.
    Hier klicken, um die Hilfe aufzurufen... http://technet.microsoft.com/de-DE/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.123.3&e=ms.exch.err.Ex28883C&l=0&cl=cp

    Verstrichene Zeit: 00:00:14


    Sprachen Voraussetzungen
    Abgeschlossen

    Verstrichene Zeit: 00:00:01


    Hub-Transport-Rolle Voraussetzungen
    Fehler

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'ikt' und im Standort 'Default-First-Site-Name' aus, und warten Sie auf den Abschluss der Replikation.
    Hier klicken, um die Hilfe aufzurufen... http://technet.microsoft.com/de-DE/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.123.3&e=ms.exch.err.Ex28883C&l=0&cl=cp

    Verstrichene Zeit: 00:00:12


    Clientzugriffsrolle Voraussetzungen
    Fehler

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'ikt' und im Standort 'Default-First-Site-Name' aus, und warten Sie auf den Abschluss der Replikation.
    Hier klicken, um die Hilfe aufzurufen... http://technet.microsoft.com/de-DE/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.123.3&e=ms.exch.err.Ex28883C&l=0&cl=cp

    Fehler:
    Die Komponente 'IIS 6 WMI Compatibility' ist erforderlich. Installieren Sie die Komponente über den Server-Manager.
    Hier klicken, um die Hilfe aufzurufen... http://go.microsoft.com/fwlink/?linkid=30939&l=de&v=ExBPA.14&id=0a71c4f6-68de-40f7-94cf-74b73cbda37b

    Verstrichene Zeit: 00:00:05


    Postfachrolle Voraussetzungen
    Fehler

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'ikt' und im Standort 'Default-First-Site-Name' aus, und warten Sie auf den Abschluss der Replikation.
    Hier klicken, um die Hilfe aufzurufen... http://technet.microsoft.com/de-DE/library/ms.exch.err.default(EXCHG.141).aspx?v=14.3.123.3&e=ms.exch.err.Ex28883C&l=0&cl=cp

    Warnung:
    Installieren Sie den Hotfix des Microsoft Knowledge Base-Artikels 2550886 unter "http://support.microsoft.com/kb/2550886", um die vorübergehende Kommunikationsinstabilität von Windows-Failoverclustern bei der Bereitstellung von Database Availability Groups in Datencentern zu verbessern.


    Verstrichene Zeit: 00:00:08

    --------------------------------------------------------------------------------------------------

    Nun bin ich meine Notizen durchgegangen und dabei ist mir aufgefallen, dass ich auf dem neuen Exchange Server 2010 kein

    setup /prepareschema

    durchgeführt habe. Ich vermute hier die Ursache der Fehlermeldungen, da hiermit ja verschiedene Vorbereitungen in der AD-Gesamtstruktur getroffen werden.

    Kann ich nun mittels der SP3 Installationsroutine setup /prepareschema ausführen um Versäumtes nachzuholen oder muss ich erst Exchange Server 2010 SP1 deinstallieren?

    Gruss

    Kai

    Montag, 28. Juli 2014 14:41

Antworten

  • KIannst du mal schauen ob der folgende Registry Key noch gesetzt ist?

    HKLM\SYSTEM\CurrentControlSet\Control\SessionManager\PendingFileRenameOperations

    Und falls ja, dann ihn löschen.

    Gruß

    Jörg

    • Als Antwort markiert Alex Pitulice Montag, 4. August 2014 08:28
    Mittwoch, 30. Juli 2014 06:14

Alle Antworten

  • Moin,

    Du hast garantiert damals das Schema aktualisiert, sonst würde Dein Exchange gar nicht laufen.

    Du kannst nun die Aktualisierung direkt mit dem SP 3 durchführen, die Schema-Updates sind kumulativ.

    Theoretisch kann man sogar das von Ex 2013 nehmen, aber da der zwingend ein Ex 2010 SP 3 erwartet, würde ich damit noch nicht rumspielen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Montag, 28. Juli 2014 14:46
  • Hallo Robert,

    Du hast natürlich Recht. Die Schemaanpassung ist bereits gelaufen.

    Das setup läuft trotzdem nicht durch. Er meldet, dass er keine Verbindung zum AD-Schemamaster herstellen kann, da dieser nicht am selben Standort wie der Schemamaster befindet.

    Der Schemamaster befindet sich in der Tat an einem anderen Standort. Aber es kann doch nicht sein, dass man die Installation am Standort des Schemamasters durchführen muss. Zudem ist Exchange Server 2010 SP1 sauber durchgelaufen.

    Vielleicht sind auch noch nicht alle Änderungen auf die anderen DCs repliziert worden.

    Gruss

    Kai

    Montag, 28. Juli 2014 15:52
  • Am 28.07.2014 schrieb Vanakai:
    Hi,

    Der Schemamaster befindet sich in der Tat an einem anderen Standort. Aber es kann doch nicht sein, dass man die Installation am Standort des Schemamasters durchführen muss.

    Doch, das kann sein.
    Du hast jetzt zwei Möglichkeiten. Den Schemamaster verschieben oder den
    Exchange zuordnen. ;)
    http://technet.microsoft.com/de-de/library/ms.exch.setupreadiness.notinschemamasterdomain(v=exchg.150).aspx
    (zwar für 2007, aber dein Fehler sagt ja genau das selbe aus)

    Zudem ist Exchange Server 2010 SP1 sauber durchgelaufen.

    Tja, vielleicht war der Schemamaster da ja auch noch in einer anderen Site?

    Bye
    Norbert


    Frank, I never thought I'd say this again. I'm getting the pig!
    nntp-bridge Zugriff auf die MS Foren wieder möglich:
    https://communitybridge.codeplex.com/

    Montag, 28. Juli 2014 16:18
  • Hallo Norbert,

    danke für die Info!

    Da muss ich mich erst einmal einlesen, was das Verlegen des Schemamasters angeht. Langfristig gesehen wird der Standort des jetzigen Schemamasters eh aufgegeben. Insofern wäre das wohl die sinnvollste Variante.

    Im Übrigen war der Schemamaster bisher stets in der selben Site.

    Gruss

    Kai

    Montag, 28. Juli 2014 18:55
  • Hallo Norbert,

    nun habe ich doch erst versucht den Exchange Server 2010 am Standort des Schemamasters auf den aktuellen Stand mit SP 3 zu bringen. Leider werden hier ebenfalls Fehler bei der Überprüfung der Bereitschaft gemeldet. Die Server habe ich alle neu gestartet. Ohne Erfolg. Der Link zur Hilfe ist nicht sehr aussagekräftig. "Sie haben einen Fehler gefunden, zu dem noch kein Artikel verfasst wurde. Dennoch können Sie Unterstützung finden. Die Foren sind dafür die ideale Anlaufstelle.

    Hast Du oder Robert noch einen Hinweis, den ich nachgehen könnte?

    Gruss

    Kai

    Fehlermeldung:

    Zusammenfassung: 6 Element(e). Erfolgreich: 1, Fehler: 5.
    Verstrichene Zeit: 00:01:10


    Voraussetzungen werden konfiguriert
    Abgeschlossen

    Verstrichene Zeit: 00:00:01


    Voraussetzungen für Organisation
    Fehler

    Fehler:
    Der Neustart einer vorangegangenen Installation steht noch aus. Starten Sie den Computer neu, und führen Sie Setup erneut aus.
    Hier klicken, um die Hilfe aufzurufen...

    Verstrichene Zeit: 00:00:12


    Sprachen Voraussetzungen
    Fehler

    Fehler:
    Der Neustart einer vorangegangenen Installation steht noch aus. Starten Sie den Computer neu, und führen Sie Setup erneut aus.
    Hier klicken, um die Hilfe aufzurufen...

    Verstrichene Zeit: 00:00:02


    Hub-Transport-Rolle Voraussetzungen
    Fehler

    Fehler:
    Der Neustart einer vorangegangenen Installation steht noch aus. Starten Sie den Computer neu, und führen Sie Setup erneut aus.
    Hier klicken, um die Hilfe aufzurufen...

    Verstrichene Zeit: 00:00:15


    Clientzugriffsrolle Voraussetzungen
    Fehler

    Fehler:
    Der Neustart einer vorangegangenen Installation steht noch aus. Starten Sie den Computer neu, und führen Sie Setup erneut aus.
    Hier klicken, um die Hilfe aufzurufen...

    Verstrichene Zeit: 00:00:14


    Postfachrolle Voraussetzungen
    Fehler

    Fehler:
    Der Neustart einer vorangegangenen Installation steht noch aus. Starten Sie den Computer neu, und führen Sie Setup erneut aus.
    Hier klicken, um die Hilfe aufzurufen...

    Warnung:
    Installieren Sie den Hotfix des Microsoft Knowledge Base-Artikels 2550886, um die vorübergehende Kommunikationsinstabilität von Windows-Failoverclustern bei der Bereitstellung von Database Availability Groups in Datencentern zu verbessern.


    Verstrichene Zeit: 00:00:23

    Dienstag, 29. Juli 2014 21:22
  • KIannst du mal schauen ob der folgende Registry Key noch gesetzt ist?

    HKLM\SYSTEM\CurrentControlSet\Control\SessionManager\PendingFileRenameOperations

    Und falls ja, dann ihn löschen.

    Gruß

    Jörg

    • Als Antwort markiert Alex Pitulice Montag, 4. August 2014 08:28
    Mittwoch, 30. Juli 2014 06:14
  • Hallo Jörg,

    der Key war's. Nach dem Löschen des Key lief die Überprüfung der Bereitschaft durch. Dann werde ich heute Abend das SP3 aufspielen können.

    Super und vielen Dank!

    Kai

    Mittwoch, 30. Juli 2014 07:10