none
Probleme mit dem RemoteApp RRS feed

  • Frage

  • Hallo zusammen,

    wir haben einen neuen Windows Server 2008 R2 aufgesetzt und werden ih  als Remotedesktop-Sitzungshost einsetzen. Die Rolle sind bereits installiert (Remotedesltopsitzungshost) auch das Programm welches von den Usern benutzt werden soll ist bereits entsprechend mit "change user /install" Modus installiert worden.

    Wenn sich die Benutzer auf die klassiche Art und Weise auf dem TS anmelden und das Programm starten, läuft alles und das Programm wird auch korrekt ausgeführt. Auch wenn man das Programm über die Registerkarte "Umgebung" im ActiveDirectory einen bestimmtem Programm öffnen lässt, läuft das Programm sauber.

    Nun habe ich aber die RemoteApps entdeckt, und wollte die Benutzer über diese Art das Programm öffnen lassen. Hier treten aber bei den Benutzern nach dem öffnen Probleme auf. Über die Menüpunkte des Programms lassen sich die Formulare nicht öffnen. Wählt man aber zum öffnen der Formulare die Shortcut, gehen die Formulare auf. Nach dem öffnen der Formulare mit den Shortcuts funktioniert plötzlich auch die Auswahl über die Menüpunkte. Irdgendwann aber wieder nicht mehr.

    habe schon fast alles versucht aber es will nicht gelingen, dass das Programm mit Remote App sauber funktioniert. Dabei spielt es keine Rolle ob ich das Programm als Admin öffne oder als Remotedesktop Benutzer mit eingeschränkten Rechten. 

    Der Clientrechner ist ein Win7 32 & 64 bit.

    der TS ist ein W2K8 R2

    Hat jemand noch eine Idee. Wäre für alle Lösungsansätze dankbar.

     

    Sonntag, 17. März 2013 09:00

Antworten

  • Hallo Matthias,

    danke für die Info. Habe nochmals das Caching deaktiviert und die Farbtiefe auf dem TS begrenzt. Leider haben auch diese Einstellungen zu keinem positiven Ergebnis geführt.

    Habe aber einen Workaround gefunden, wie man die Formulare über die Menüpunkte wieder aufrufen kann.

    Das Programm hat ebenfalls einen Shortcut zum schließen geöffneter Formulare. wenn man diesen nun 2-3 mal drückt, kann man wieder mit den Menüpunkten alle Formulare aufrufen.

    Es scheint so als ob ein Fenster das Aufrufen blockiert, welches aber über RemoteApp auf dem Client nicht sichtbar ist. Mit dem Shortcut "Formular schließen" wird das Fenster wieder geschlossen und man kann die Menüpunkte wieder nutzen.

    Das mit dem RDP 8.0 werde ich wohl erst mit einem Test Server testen. Ich werde dann mal erneut berichten.

    Sonntag, 17. März 2013 22:23
  • Das mit dem RDP 8.0 werde ich wohl erst mit einem Test Server testen. Ich werde dann mal erneut berichten.

    Gemeint ist natürlich die Clientseite auf RDP 8.0 upzudaten.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Montag, 18. März 2013 08:24
  • muss das Protokoll nicht auf beiden Seiten installiert werden oder bin ich hier falsch informiert?

    Die Serverkomponente kannst du leider nicht aktualisieren.

    Erst wenn du dich mit einem Server 2012 per RDP verbinden würdest, ist sowohl die Client- als auch
    Serverkomponente RDP 8.0.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Montag, 18. März 2013 15:34

Alle Antworten

  • hat keiner eine Idee?
    Sonntag, 17. März 2013 14:58
  • Am 17.03.2013 schrieb FALK75:

    hat keiner eine Idee?

    Langsam mit den wilden Pferden. 24 - 48 Stunden kann es locker dauern,
    bis Du Antwort bekommst. Ist es dringend, mußt Du wohl einen
    Dienstleister beauftragen.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Sonntag, 17. März 2013 16:47
  • Hallo,

    eine RemoteApp RDP Sitzung ist keine vollständige RDP Sitzung.
    Es gibt vereinzelt Programme, die mit der Darstellung als RemoteApp nicht klar kommen.

    In diesem Falle kannst du meist auch wenig daran ändern.

    Du kannst versuchen am Client verschiedene Einstellungen auszuprobieren, z.B. ändern der RDP
    Farbtiefe, deaktivieren des Bitmap Caching...

    Versuche bitte auch einmal auf RDP 8.0 zu aktualisieren.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Sonntag, 17. März 2013 19:12
  • Hallo Matthias,

    danke für die Info. Habe nochmals das Caching deaktiviert und die Farbtiefe auf dem TS begrenzt. Leider haben auch diese Einstellungen zu keinem positiven Ergebnis geführt.

    Habe aber einen Workaround gefunden, wie man die Formulare über die Menüpunkte wieder aufrufen kann.

    Das Programm hat ebenfalls einen Shortcut zum schließen geöffneter Formulare. wenn man diesen nun 2-3 mal drückt, kann man wieder mit den Menüpunkten alle Formulare aufrufen.

    Es scheint so als ob ein Fenster das Aufrufen blockiert, welches aber über RemoteApp auf dem Client nicht sichtbar ist. Mit dem Shortcut "Formular schließen" wird das Fenster wieder geschlossen und man kann die Menüpunkte wieder nutzen.

    Das mit dem RDP 8.0 werde ich wohl erst mit einem Test Server testen. Ich werde dann mal erneut berichten.

    Sonntag, 17. März 2013 22:23
  • Das mit dem RDP 8.0 werde ich wohl erst mit einem Test Server testen. Ich werde dann mal erneut berichten.

    Gemeint ist natürlich die Clientseite auf RDP 8.0 upzudaten.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Montag, 18. März 2013 08:24
  • Hallo Matthias,

    muss das Protokoll nicht auf beiden Seiten installiert werden oder bin ich hier falsch informiert?

    Montag, 18. März 2013 10:49
  • muss das Protokoll nicht auf beiden Seiten installiert werden oder bin ich hier falsch informiert?

    Die Serverkomponente kannst du leider nicht aktualisieren.

    Erst wenn du dich mit einem Server 2012 per RDP verbinden würdest, ist sowohl die Client- als auch
    Serverkomponente RDP 8.0.


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!

    Montag, 18. März 2013 15:34