none
GET-CSUser funktioniert nicht mehr RRS feed

  • Frage

  • Hallo,

    vor 2 Monaten habe ich zuletzt den Befehl get-csuser ausgeführt, der Teil eines Scripts ist. Das Script habe ich von einem Kollegen erhalten. Damals lief alles sauber durch. Seit einigen Tagen versuche ich aber verzweifelt, diese Aufgabe erneut durchzuführen, erhalte jetzt aber folgende Fehlermeldung:

    get-csuser : Die Benennung "get-csuser" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder
    eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern
    enthalten), und wiederholen Sie den Vorgang.
    In Zeile:1 Zeichen:1
    + get-csuser
    + ~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (get-csuser:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    Testweise habe ich es auf einem anderen Computer ausgeführt, mit selbem Ergebnis. Das Modul SkypeOnlineConnector ist geladen. Mein Kollege hat das Problem nicht. Es spielt auch keine Rolle, wenn ich die Powershell aufmache und nur diesen Befehle eintippe. Weder an meiner Konfiguration oder am Script habe ich bewusst irgendwas geändert.

    Ich hoffe, jemand kann mir weiterhelfen.

    Grüße


    • Bearbeitet Valeska82 Dienstag, 8. September 2020 10:57
    Dienstag, 8. September 2020 10:53

Antworten

  • Hier steht noch etwas mehr dazu - übrigens 2. Treffer bei der Websuche :-()

    https://stackoverflow.com/questions/50765207/get-csuser-error-powershell


    Greetings/Grüße, Martin - https://mvp.microsoft.com/en-us/PublicProfile/5000017 Mal ein gutes Buch über GPOs lesen? - http://www.amazon.de/Windows-Server-2012--8-Gruppenrichtlinien/dp/3866456956 Good or bad GPOs? My blog - http://evilgpo.blogspot.com And if IT bothers me? Coke bottle design refreshment - http://sdrv.ms/14t35cq

    Dienstag, 8. September 2020 13:48
  • Dann prüfe, ob die Assembly bei dir noch vorhanden ist und importiere diese:
    https://docs.microsoft.com/en-us/powershell/module/skype/?view=skype-ps

    https://docs.microsoft.com/en-us/microsoft-365/enterprise/manage-skype-for-business-online-with-microsoft-365-powershell?view=o365-worldwide

    Dienstag, 8. September 2020 14:25

Alle Antworten

  • Möglicherweise hast du nun Teams installiert?
    Dann gibt es Skype for Business nicht mehr, denn Teams hat diesen abgelöst.

    get-csuser ist ein cmdlet von Skype.

    Dienstag, 8. September 2020 12:13
  • Hier steht noch etwas mehr dazu - übrigens 2. Treffer bei der Websuche :-()

    https://stackoverflow.com/questions/50765207/get-csuser-error-powershell


    Greetings/Grüße, Martin - https://mvp.microsoft.com/en-us/PublicProfile/5000017 Mal ein gutes Buch über GPOs lesen? - http://www.amazon.de/Windows-Server-2012--8-Gruppenrichtlinien/dp/3866456956 Good or bad GPOs? My blog - http://evilgpo.blogspot.com And if IT bothers me? Coke bottle design refreshment - http://sdrv.ms/14t35cq

    Dienstag, 8. September 2020 13:48
  • @Der Suchende

    Wir haben den Befehl auch für Teams verwendet, z.B. um Teams mit der Telefonanlage zu verbandeln.

    @Martin Binder

    Die Google Ergebnisse habe ich gelesen, aber das kann nicht wirklich stimmen, denn wie gesagt kann mein Kollegen den Befehl problemlos ausführen.

    Dienstag, 8. September 2020 14:20
  • Dann prüfe, ob die Assembly bei dir noch vorhanden ist und importiere diese:
    https://docs.microsoft.com/en-us/powershell/module/skype/?view=skype-ps

    https://docs.microsoft.com/en-us/microsoft-365/enterprise/manage-skype-for-business-online-with-microsoft-365-powershell?view=o365-worldwide

    Dienstag, 8. September 2020 14:25