none
DNS Clientaktualisierung RRS feed

  • Frage

  • Hallo zusammen!

    Ich sage gleich vorab, dass ich nur das wesentlichste und oberflächlichste über DNS weiß.
    Ich betreibe einen 2008 R2 Server ohne Domäne. Da dieser als Router fungiert, ist dort ein DNS-Server installiert, der Anfragen von Internetnamen an den DNS-Server meines Providers weiterleitet.Ich habe eine DNS-Zone mit dem Namen "local" angelegt und den DNS-Server im DHCP-Bereich hinzugefügt.Alle Clients können den Servernamen.local auflösen und die Auflösung der Internetnamen funktioniert auch einwandfrei.

    Ich hätte es nun aber gerne, dass alle Clients per DHCP den DNS-Suffix zugewiesen bekommen (Option 015) was auch klappt. Aber diese tragen sich nicht in den DNS-Server ein, so dass die Namen natürlich auch nicht aufgelöst werden.

    Wie konfiguriere ich das System, dass die Clients Einträge im DNS anlegen. Geht das ohne Domäne überhaupt?

    Grüße
    Daniel

    Sonntag, 24. Oktober 2010 10:09

Antworten

  • Hi,

    Am 25.10.2010 22:15, schrieb Daniel 2150:

    Ich habe die Ursache gefunden. Es liegt ganz offensichtlich am Namen.

    Jetzt lese ich dein Problem erst richtig.
    | Ich habe eine DNS-Zone mit dem Namen "local" angelegt

    Bei "local" waren alle hier der Meinung, das das deine TLD ist. Also zB
    "meineZone.local" denn das ist eine sehr gebräuchliche Endung für
    eine interne Zone. Sorry, das hat hier wohl jeder flasch gelesen, bzw.
    gleich weitergedacht und nicht wörtlich genommen.

    "local" ist im Gegensatz zu "test.local" kein vollständiger Name.
    Es ist eine sogenannte Singel Label Domain, die ab Vista nicht mehr
    unterstützt wird.

    Ein vollständiger Zonen name braucht den "."

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    • Als Antwort markiert Daniel 2150 Montag, 25. Oktober 2010 20:33
    Montag, 25. Oktober 2010 20:23

Alle Antworten

  • Hi Daniel,
     
    hast du dem DHCP-Server gesagt, dass er die Registrierung vornehmen soll:
     
    DHCP-Infos:
     
    Viele Grüße
    Christian
     
    Sonntag, 24. Oktober 2010 12:24
  • Ja, diese Einstellung war schon bei der Rolleninstalaltion aktiviert. Folgendes ist dort standardmäßig aktiviert:

    http://home.arcor.de/daniel_2k/forums/dhcp_4.jpg

    Aber es erscheinen trotzdem keine Einträge im DNS, wenn ein Client ein DHCP-Lease bekommt.

    Sonntag, 24. Oktober 2010 14:26
  • Hi Daniel,
     
    setz mal beim Client den DNS-Suffix manuell und prüf mal, ob der Punkt "Diese
    Verbindnung im DNS registrieren" aktiv ist...
     
    Klappt es jetzt?
     
    Viele Grüße
    Christian
     
    Sonntag, 24. Oktober 2010 15:14
  • Habe den Suffix manuell eingetragen und den Haken gesetzt.

    Aber es geht immernoch nicht.

    http://home.arcor.de/daniel_2k/forums/dns_checkbox.jpg

    Sonntag, 24. Oktober 2010 15:40
  • Hi,

    Am 24.10.2010 16:26, schrieb Daniel 2150:

    Ja, diese Einstellung war schon bei der Rolleninstalaltion aktiviert.
    http://home.arcor.de/daniel_2k/forums/dhcp_4.jpg

    ... aber es ist kein Konto definiert, daß die Einträge dann machen darf.
    Schau in den Reiter "erweitert".

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    Sonntag, 24. Oktober 2010 15:55
  • Also, ich glaub das wars. Jetzt kann ich alle Clients (auch ohne den Haken in den erweiterten Netzwerkeinstellungen) mit Rechnername.local anpingen. Die Namen werden korrekt aufgelöst.
    Aber Einträge sind in meiner Forward-Lookupzone nicht zu sehen. Oder stehen da nur statische Einträge sichtbar?
    Sonntag, 24. Oktober 2010 16:09
  • Hi Daniel,
     
    ist die Ansicht vielleicht nicht aktualisiert - es sollte sich für jeden
    Client ein  A-record und ein PRT-record erstellt werden.
     
    Viele Grüße
    Christian 
     
    Sonntag, 24. Oktober 2010 16:54
  • Habe Ansicht aktualisiert und Neu geladen, aber da stehen nur die Einträge des Servers selbst drin.
    Sonntag, 24. Oktober 2010 17:26
  • Hi Daniel,
     
    > Habe Ansicht aktualisiert und Neu geladen, aber da stehen nur die Einträge
    > des Servers selbst drin.
     
    Dann scheint es noch nicht zu klappen.
     
    Können sich die Clients mit "ipconfig /registerdns" im DNS eintragen?
     
    Funktioniert die auflösung mit nslookup?
     
    Viele Grüße
    Christian
     
    Montag, 25. Oktober 2010 05:47
  • Ja die Namensauflösung funktioniert auf den Clients auch noch nicht richtig. Der Sever löst alles auf.

    ipconfig /registerdns bringt folgende Meldung:

    C:\Windows\system32>ipconfig /registerdns

    Windows-IP-Konfiguration

    Die Registrierung der DNS-Ressourceneinträge für alle Adapter dieses Computer wu
    rde initialisiert. Fehler werden in der Ereignisanzeige in 15 Minuten aufgeführt.

    Geändert hat sich aber nichts.

     

    nslookup auf einem Client bring folgendes Ergebnis:

    C:\Windows\system32>nslookup <Clientname>.local
    Server:  UnKnown
    Address:  192.168.0.1

    *** <Clientname>.local wurde von UnKnown nicht gefunden: Non-existent domain.

    Wenn ich den Namen des Servers nehme, dann gehts natürlich.

    Montag, 25. Oktober 2010 15:09
  • Was ist eigentlich mit der Option "Dynamische Updates"? Wenn man den DNS-Server installiert, dann ist standardmäßig der Haken raus.

    Im Eigenschaftenmenü der Forward- und Reverse-Loopup-Zone findet sich diese Einstellung:

    http://home.arcor.de/daniel_2k/forums/dns_dynmic_updates.jpg

    Ich habe diese jetzt (wie im Screenshot zu sehen) aktiviert. In der Reverse-Lookup-Zone werden die PTR-Einträge jetzt angelegt. In der Forward-Lookup-Zone fehlen sie nach wie vor.

    Montag, 25. Oktober 2010 18:32
  • Am 24.10.2010 19:26, schrieb Daniel 2150:

    Habe Ansicht aktualisiert und Neu geladen, aber da stehen nur die Einträge des Servers selbst drin.

    Wie ist die Sicherheit deiner Zone konfiguriert?
    Lässt diese Sichere und Unsichere Updates zu oder nur Sichere?
    Wobei ich gerade nicht sicher bin, ob es diese Einstellung im Zonenfile
    überhaupt gibt, wenn diese nicht AD integriert ist ...

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    Montag, 25. Oktober 2010 20:06
  • Wie ist die Sicherheit deiner Zone konfiguriert?
    Lässt diese Sichere und Unsichere Updates zu oder nur Sichere?
    Wobei ich gerade nicht sicher bin, ob es diese Einstellung im Zonenfile
    überhaupt gibt, wenn diese nicht AD integriert ist ...



    Siehe Screenshot. Nicht sichere und sichere Updates habe ich jetzt zugelassen.

    Ich habe die Ursache gefunden. Es liegt ganz offensichtlich am Namen. Ich habe es gerade in 2 virtuellen Maschinen in einem virtuellen Netzwerk getestet. Ich habe DNS und DHCP installiert und als Zonenname für die Forward-Lookup-Zone "test.local" vergeben. Wichtig ist auch, dass der DNS-Suffix als primärer DNS-Suffix im Client angegeben werden muss. Option 015 - Domänenname im DHCP ist nur ein verbindungsspezifisches Suffix und wird vom DHCP nicht verwendet den Namen im DNS zu registrieren. Jedenfalls funktioniert es so. Vergebe ich als namen aber nur "local" (so wie es in meiner aktuellen Serverkonfiguration ist) registriert der DHCP den Namen nur in der Reverse-Lookup-Zone und in der Forward-Lookup-Zone wird nichts angelegt. Also gleiches Verhalten in der virtuellen Maschine wie in meinem System.

    Aber warum mach er das für "test.local" und für "local"?

    Montag, 25. Oktober 2010 20:15
  • Hi,

    Am 25.10.2010 22:15, schrieb Daniel 2150:

    Ich habe die Ursache gefunden. Es liegt ganz offensichtlich am Namen.

    Jetzt lese ich dein Problem erst richtig.
    | Ich habe eine DNS-Zone mit dem Namen "local" angelegt

    Bei "local" waren alle hier der Meinung, das das deine TLD ist. Also zB
    "meineZone.local" denn das ist eine sehr gebräuchliche Endung für
    eine interne Zone. Sorry, das hat hier wohl jeder flasch gelesen, bzw.
    gleich weitergedacht und nicht wörtlich genommen.

    "local" ist im Gegensatz zu "test.local" kein vollständiger Name.
    Es ist eine sogenannte Singel Label Domain, die ab Vista nicht mehr
    unterstützt wird.

    Ein vollständiger Zonen name braucht den "."

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    • Als Antwort markiert Daniel 2150 Montag, 25. Oktober 2010 20:33
    Montag, 25. Oktober 2010 20:23
  • Hi Mark,
     
    > eine interne Zone. Sorry, das hat hier wohl jeder flasch gelesen, bzw.
    > gleich weitergedacht und nicht wörtlich genommen.
     
    Ja, das habe ich auch übergelesen und im Nachhinein scheiterte es an dieser
    Kleinigkeit...
     
    Schön. :-)
     
    Viele Grüße
    Christain
     
    Dienstag, 26. Oktober 2010 04:13
  • Hi Mark,
     
    > eine interne Zone. Sorry, das hat hier wohl jeder flasch gelesen, bzw.
    > gleich weitergedacht und nicht wörtlich genommen.
     
    Ja, das habe ich auch übergelesen und im Nachhinein scheiterte es an dieser
    Kleinigkeit...
     
    Schön. :-)
     
    Viele Grüße
    Christain
     
    Dienstag, 26. Oktober 2010 04:29