none
SharePoint Search - Index Reset stoppen RRS feed

  • Frage

  • Hallo,

    ich habe den Index Reset über diese Powershell-Befehle

    $searchapp = Get-SPEnterpriseSearchServiceApplication
    $searchapp.Reset($true, $false)

    gestartet. Seit Stunden ist es am Laufen. Wie kann ich den Reset wieder stoppen.

    Danke für Eure Hilfe!

    Dienstag, 3. Februar 2015 12:58

Antworten

  • Hallo Peter,

    vielen Dank für die Antwort. Obwohl der Dienst für den Index angehalten war habe ich auf Index zurücksetzen geklickt. Dies brachte mich zur Lösung. Anscheinend hing der Job und musste nochmal ausgeführt werden.

    Viele Grüße

    Mittwoch, 4. Februar 2015 09:57

Alle Antworten

  • Hallo,

    bei machen Anwendungen hilft ein STRG+C im Terminal zu beenden o.ä.

    Andernfalls kannst du doch diesen Terminal beenden und dann soltle auch der drunterliegende Prozess beendet werden.


    © 2015 Thomas Roskop

    Germany // Deutschland

    Dienstag, 3. Februar 2015 13:53
  • Danke für die Antwort. Leider ist das Terminalfenster nicht mehr offen. Wie bekomme ich den Reset zum Abbruch. Serverneustarts oder Serviceneustarts helfen nicht. Sollte ich den Server komplett runterfahren oder könnte ich anhand Monitoring es finden können :(
    Dienstag, 3. Februar 2015 15:00
  • Du könntest dir mal eine Liste aller Prozesse anzeigen lassen, vielleicht hilft dir das diesen zu finden und zu terminieren.


    © 2015 Thomas Roskop

    Germany // Deutschland

    Dienstag, 3. Februar 2015 17:34
  • Hi Thomas,
    der SharePoint nutzt sehr wenig Dienste. Der wichtigste Dienst ist der "SharePoint Timer Service". Er bedient eine Job-Schlange, die der SharePoint intern befüllt und verwaltet.

    Für die Suche gibt es den "SharePoint Search Host Controller". Ein Rücksetzen dieses Dienstes bringt aber nichts, da die Zustände der Farm in der Config-Datenbank und den Service-Datenbanken abgelegt werden. Sowohl nach dem Neustart des Servers als auch nach dem Neustart des Services wird beim alten Zustand fortgesetzt.

    Für den konkreten Fall hilft entweder warten und ULS analysieren oder Neuinstallation der Serviceanwendung.

    --
    Peter

    • Als Antwort markiert darmstadt1 Mittwoch, 4. Februar 2015 09:53
    • Tag als Antwort aufgehoben darmstadt1 Mittwoch, 4. Februar 2015 09:53
    Dienstag, 3. Februar 2015 20:46
  • Hallo Peter,

    vielen Dank für die Antwort. Obwohl der Dienst für den Index angehalten war habe ich auf Index zurücksetzen geklickt. Dies brachte mich zur Lösung. Anscheinend hing der Job und musste nochmal ausgeführt werden.

    Viele Grüße

    Mittwoch, 4. Februar 2015 09:57