none
Änderungen am Synchronisierungsprofil nicht möglich, Events 3 und 22, Standardsync möglich RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen

    dieses Problem raubt mir schier den Nerv. Nachdem ich es geschafft hatte wegen einem Event 22 meine alte Farm, in der bis zum Dezember der UserSync funktioniert hatte, zu zerschiessen (zum Glück bisher nur Staging-System gewesen) - habe ich jetzt alles nochmal aufgesetzt in einer neuen Fam.

    Das Importieren der Userdaten klappt mit allen Details wie Vor/Nachname, Abteilung, Vorgesetzter etc, die MySites werden korrekt dargestellt mitsamt dem Organization Browser.

    Die Userberechtigungen habe ich auch vielerlei Arten versucht, unter anderem 2x mit den exakten Einstellungen von Harbar (http://www.harbar.net/articles/sp2010ups.aspx)

    Ich habe mit der aktuellen Installation SP2010 auf 2008R2 SP1 mit SQL2008R2 SP1 im Domain Functional Level 2008 R2 nun folgende 2 Probleme:

    1. Es werden keine Gruppen synchronisiert - obwohl diese zur Synchronisation gewählt sind. Dort keine spezifischen Fehlermeldungen

    2. Ich kann keine Änderungen an den Benutzereigenschaften vornehmen - wann immer ich versuche diese Einstellungen vorzunehmen (Foto->thumbnailPicture Export) wird diese beim Exportvorgang nach dem Syncclient offensichtlich ignoriert, im Moment in dem ich die Änderungen speichere erscheinen 4 events im Eventlog des SP-Servers:

    - System

      - Provider

       [ Name]  Forefront Identity Manager
     
      - EventID 3

       [ Qualifiers]  0
     
       Level 2
     
       Task 0
     
       Keywords 0x80000000000000
     
      - TimeCreated

       [ SystemTime]  2011-06-01T13:20:24.000000000Z
     
       EventRecordID 8112
     
       Channel Application
     
       Computer XXX.DOMAIN.net
     
       Security
     

    - EventData

       Microsoft.ResourceManagement.Service: System.ServiceModel.FaultException: Access to the requested resource(s) is denied bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.GetCurrentUserFromSecurityIdentifier() bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.GetCurrentUser() bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.Enumerate(Message request)

    -------------------------------

    - System

      - Provider

       [ Name]  Forefront Identity Manager
     
      - EventID 3

       [ Qualifiers]  0
     
       Level 2
     
       Task 0
     
       Keywords 0x80000000000000
     
      - TimeCreated

       [ SystemTime]  2011-06-01T13:20:25.000000000Z
     
       EventRecordID 8113
     
       Channel Application
     
       Computer XXXX.DOMAIN.net
     
       Security
     

    - EventData

       Microsoft.ResourceManagement.Service: System.ServiceModel.FaultException: Access to the requested resource(s) is denied bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.GetCurrentUserFromSecurityIdentifier() bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.GetCurrentUser() bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.Enumerate(Message request)

    ---------------------------------

     

    - System

      - Provider

       [ Name]  Forefront Identity Manager
     
      - EventID 3

       [ Qualifiers]  0
     
       Level 2
     
       Task 0
     
       Keywords 0x80000000000000
     
      - TimeCreated

       [ SystemTime]  2011-06-01T13:20:25.000000000Z
     
       EventRecordID 8114
     
       Channel Application
     
       Computer XXXX.DOMAIN.net
     
       Security
     

    - EventData

       Microsoft.ResourceManagement.Service: System.ServiceModel.FaultException: Access to the requested resource(s) is denied bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.GetCurrentUserFromSecurityIdentifier() bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.GetCurrentUser() bei Microsoft.ResourceManagement.WebServices.ResourceManagementService.Enumerate(Message request)

    ----------------------------------------------

    - System

      - Provider

       [ Name]  Microsoft.ResourceManagement.ServiceHealthSource
     
      - EventID 22

       [ Qualifiers]  0
     
       Level 2
     
       Task 0
     
       Keywords 0x80000000000000
     
      - TimeCreated

       [ SystemTime]  2011-06-01T13:20:53.000000000Z
     
       EventRecordID 8115
     
       Channel Application
     
       Computer XXXX.DOMAIN.net
     
       Security
     

    - EventData

       The Forefront Identity Manager Service cannot connect to the SQL Database Server. The SQL Server could not be contacted. The connection failure may be due to a network failure, firewall configuration error, or other connection issue. Additionally, the SQL Server connection information could be configured incorrectly. Verify that the SQL Server is reachable from the Forefront Identity Manager Service computer. Ensure that SQL Server is running, that the network connection is active, and that the firewall is configured properly. Last, verify the connection information has been configured properly. This configuration is stored in the Windows Registry.

    ------------------------------------------------

    Im Datenbanklog finden sich keine Fehlermeldungen über fehlgeschlagene Anmeldungen.

    ich verwende eine named Instance für die Datenbank, der MSDTC ist für Remoteverbindungen auf dem SQL und dem SP aktiviert, die selbe Named Instance bedient die restliche SP Farm ohne Probleme.

    Mittlerweile habe ich auch schon versucht alle Serviceaccounts zu lokalen Admins zu machen, auch ohne Erfolg.

    Die Logfiles enthalten trotz höchster Loggingstufefür den Profile Sync leider keine für mich ersichtlich relevanten infos.

     

    Hat irgendjemand eine Idee?


    Mittwoch, 1. Juni 2011 13:36

Alle Antworten

  • Hallo,

    für Event Id 3:

    diesen TechNet Artikle bist Du auch durchgegangen?

    http://technet.microsoft.com/en-us/library/ff519520.aspx

    Verfügt das Sync Konto über die Nötigen Berechtigungen im AD?

    Verzeichnisänderungen replizieren / Replicate directory changes

    für Event Id 22:

    http://blogs.technet.com/b/steve_chen/archive/2011/01/25/sharepoint-2010-event-id-22-234-and-multiple-forefront-certificates.aspx

    Wenn das nicht hilft könntest du das Problem reproduzieren und das ULS log auf Skydrive hochladen und hier verlinken?

    Gruß,
    Andrei

    Donnerstag, 2. Juni 2011 09:21
  • Hallo und danke für deine Antwort

     

    irgendwie ist mir die durchgerutscht :)

    Ich werde mich sobald wie möglich nochmal mit dem Thema befassen und die Ergebnisse hier posten

    Freitag, 22. Juli 2011 09:11
  • So konnte es schnell nochmal durchgehen, der Artikel http://technet.microsoft.com/en-us/library/ff519520.aspx bezieht sich auf Event 4, habve den aber auch schon diverse male geprüft.

    Die Rechte im AD hab ich jetzt nochmal abgeklappert, leider nur um festzustellen dass die exakt so eingestellt sind wie bei Harbar beschrieben.

    Über den Artikel http://blogs.technet.com/b/steve_chen/archive/2011/01/25/sharepoint-2010-event-id-22-234-and-multiple-forefront-certificates.aspx hatte ich es übrigens geschafft die letzte Farm zu zerlegen da ich ein aktives Zertifikat gelöscht hatte und mich das System kein neues über die PS anlegen lassen wollte.

     

    folgende Informationen finden sich im ULS zur betreffenden Zeit:

     

    2011 11:52:41.22     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     d3b3    High        LoadConnections failed trying to fill the connections list. Most likely during RetriveResources because of permissions --- {1}.  Available parameters: Microsoft.ResourceManagement.WebServices.Client.PermissionDeniedException: Access to the requested resource(s) is denied     bei Microsoft.ResourceManagement.WebServices.Client.ResourceTemplate.EnumerateResources(SearchParameters parameters)     bei Microsoft.ResourceManagement.WebServices.ResourceManager.RetrieveResources()     bei Microsoft.Office.Server.UserProfiles.ConnectionManager.LoadConnections() .    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.22     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     a3xu    High        ConnectionManager.LoadConnections(): Could not find MOSS MA despite being marked as fully configured, was it deleted?    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.46     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     1y13    Medium      Microsoft.Office.Server.UserProfiles.CoreProperty: Profile property updated: PictureURL    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.50     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     d3b3    High        LoadConnections failed trying to fill the connections list. Most likely during RetriveResources because of permissions --- {1}.  Available parameters: Microsoft.ResourceManagement.WebServices.Client.PermissionDeniedException: Access to the requested resource(s) is denied     bei Microsoft.ResourceManagement.WebServices.Client.ResourceTemplate.EnumerateResources(SearchParameters parameters)     bei Microsoft.ResourceManagement.WebServices.ResourceManager.RetrieveResources()     bei Microsoft.Office.Server.UserProfiles.ConnectionManager.LoadConnections() .    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.50     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     a3xu    High        ConnectionManager.LoadConnections(): Could not find MOSS MA despite being marked as fully configured, was it deleted?    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.51     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     1y13    Medium      Microsoft.Office.Server.UserProfiles.ProfileTypeProperty: Profile property updated: PictureURL    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.60     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     d3b3    High        LoadConnections failed trying to fill the connections list. Most likely during RetriveResources because of permissions --- {1}.  Available parameters: Microsoft.ResourceManagement.WebServices.Client.PermissionDeniedException: Access to the requested resource(s) is denied     bei Microsoft.ResourceManagement.WebServices.Client.ResourceTemplate.EnumerateResources(SearchParameters parameters)     bei Microsoft.ResourceManagement.WebServices.ResourceManager.RetrieveResources()     bei Microsoft.Office.Server.UserProfiles.ConnectionManager.LoadConnections() .    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.60     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     a3xu    High        ConnectionManager.LoadConnections(): Could not find MOSS MA despite being marked as fully configured, was it deleted?    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.68     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     1y13    Medium      Microsoft.Office.Server.UserProfiles.ProfileSubtypeProperty: Profile property updated: PictureURL    15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.72     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     d0la    Medium      EditProperty::_CommitMapping  - Call _EnsureConfigObjects     15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.72     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     d0lb    Medium      EditProperty::_CommitMapping  - Now iterating through the mappings     15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.72     w3wp.exe (0x1118)                           0x0B78    SharePoint Portal Server          User Profiles                     d0lc    Medium      EditProperty::_CommitMapping  - Found teh connection to use     15841d0e-c26a-4f8b-a23f-05d232b220cc
    07/22/2011 11:52:41.81     OWSTIMER.EXE (0x0D00)                       0x1050    SharePoint Foundation             Monitoring                        nasq    Medium      Entering monitored scope (Timer Job Search Health Monitoring - Trace Events)    5001cfdd-8bae-4bc6-aa34-792f996db2f7
    07/22/2011 11:52:41.81     OWSTIMER.EXE (0x0D00)                       0x1050    SharePoint Foundation             Monitoring                        b4ly    Medium      Leaving Monitored Scope (Timer Job Search Health Monitoring - Trace Events). Ausführungszeit=5,822384    5001cfdd-8bae-4bc6-aa34-792f996db2f7
    0

     

    Dienste laufen beide, der user (spups) ist Mitglied von dbowner für Sync und Profile Datenbanken, spfarm (Dienstbenutzer) ist dbo auf beiden

    Freitag, 22. Juli 2011 10:18
  • OK sieht so aus als gäbe es hier ein zweigeteiltes Problem - das eine dachte ich bereits behoben zu haben und bezieht sich auf einen alten bekannten: http://www.cleverworkarounds.com/2010/08/15/more-user-profile-sync-in-sp2010-certificate-provisioning-issues/ . Ich habe die connection nochmals angelegt und siehe da, wenn man das Log genau im Auge behält tritt der Fehler auch auf - hatte ich zwar schon mal behoben, war hier aber Teil des Problems.

    Der 2te Teil desProblems bezieht sich darauf das der im SP2010 enthaltene FIM wohl bis zum June 2011 Update Rollup nicht mit Named Instances SQL klarkommt, teilweise wohl schon denn das anlegen usw klappt, ein Teil des Datenbankzugriffs dann aber wohl nicht.

    Ich glaube mich auch zu erinnern das meine Lab-Installation vor der eigentlichen Installation auf der Standardinstanz des SQL Servers lief. Dort war Import/Export ohne Probleme möglich.

    Wie sagt man so schön: Go Figure.

     

    Ich schiebe jetzt grade in der Farm die Rollups auf und werde später nochmal berichten ob sich das Problem damit erledigt hat.

    Samstag, 23. Juli 2011 16:03
  • OK sieht so aus als gäbe es hier ein zweigeteiltes Problem - das eine dachte ich bereits behoben zu haben und bezieht sich auf einen alten bekannten: http://www.cleverworkarounds.com/2010/08/15/more-user-profile-sync-in-sp2010-certificate-provisioning-issues/ . Ich habe die connection nochmals angelegt und siehe da, wenn man das Log genau im Auge behält tritt der Fehler auch auf - hatte ich zwar schon mal behoben, war hier aber Teil des Problems.

    Der 2te Teil desProblems bezieht sich darauf das der im SP2010 enthaltene FIM wohl bis zum June 2011 Update Rollup nicht mit Named Instances SQL klarkommt, teilweise wohl schon denn das anlegen usw klappt, ein Teil des Datenbankzugriffs dann aber wohl nicht.

    Ich glaube mich auch zu erinnern das meine Lab-Installation vor der eigentlichen Installation auf der Standardinstanz des SQL Servers lief. Dort war Import/Export ohne Probleme möglich.

    Wie sagt man so schön: Go Figure.

     

    Ich schiebe jetzt grade in der Farm die Rollups auf und werde später nochmal berichten ob sich das Problem damit erledigt hat.


    BTW: Das FIM ein Problem mit Named Instances hat und dieses seit dem June update rollup gelöst sein müsste findet man wo? - Richtig, bei Harbar. 

    Hatte das auch gelesen aber beim Umzug wohl verdrängt - es findet sich im Blog-Beitrag "Stuck on starting":

    The SharePoint Configuration Wizard (PSConfig) supports named instances (e.g. SQLServerName\InstanceName), but UPS does not. Therefore if we wish to use named instances and UPS we must configure an Alias, and we must do this before we run PSConfig to create the farm. Note: this issue is fixed in the June 2010 Cumulative Update for SharePoint Server. Thus if we are running the June CU or later, we do not need to configure an alias. However, I strongly recommend you use an alias, as it is a best practice for addressing SQL named instances regardless of this issue.

     


    Samstag, 23. Juli 2011 16:04
  • Ok ich hatte im Zusammenhang hiermit Tatsache ein "Stuck on starting" über den Bootvorgang hinaus.

    im Log findet sich folgender Eintrag:

    Updating SPPersistedObject ProfileSynchronizationSetupJob Name=ProfileSynchronizationSetupJob. Version: -1 Ensure: False, HashCode: 54760447, Id: 0f231b20-240d-4b47-aac6-cc19919cc53e, Stack:    bei Microsoft.SharePoint.Administration.SPPersistedObject.BaseUpdate()     bei Microsoft.SharePoint.Administration.SPJobDefinition.Update()     bei Microsoft.Office.Server.Administration.UserProfileApplication.StartSynchronizationServiceSetupTimer(String strSyncMachineAddress)     bei Microsoft.Office.Server.Administration.UserProfileApplication.SynchronizeMIIS()     bei Microsoft.Office.Server.Administration.ILMProfileSynchronizationJob.Execute()     bei Microsoft.SharePoint.Administration.SPTimerJobInvokeInternal.Invoke(SPJobDefinition jd, Guid targetInstanceId, Boolean isTimerService, Int32& resu...    8d1e08a2-4302-4e2e-bc80-8081199e31eb
    07/24/2011 15:39:16.27*    OWSTIMER.EXE (0x07F0)                       0x0C90    SharePoint Foundation             Topology                          8xqz    Medium      ...lt)     bei Microsoft.SharePoint.Administration.SPTimerJobInvoke.Invoke(TimerJobExecuteData& data, Int32& result)      8d1e08a2-4302-4e2e-bc80-8081199e31eb
    07/24/2011 15:39:16.27     w3wp.exe (0x13BC)                           0x0130    SharePoint Foundation             Topology                          e5mc    Medium     

     

    Nur um anderen zu helfen die dieses "Freak" Problem haben:

     

    unter den Timer Job-Definitionen fand sich auch nach dem Löschen des Dienstes der oben beschriebene "ProfileSynchronizationSetupJob" der hier nochmals erstellt werden sollte. Löschen löst das Problem.

    Sonntag, 24. Juli 2011 13:55