none
https | Umleitung auf andere Webanwendung RRS feed

  • Frage

  • Hallo zusammen,

    ich habe ein Problem, welched mich schon längere Zeit vor Rätsel stellt.
    Wir nutzen zwei Webanwendungen (W1 und W2). W2 kann sowohl über https als auch über http aufgerufen werden (was auch so gewünscht ist).
    W1 soll nur über http angesprochen werden (https ist im IIS "ausgeschaltet"). In SharePoint existiert kein Redirect. Soweit so gut.. Jetzt das merkwürdige:

    Rufe ich W1 mit https auf, erscheint die Meldung "Certificate Error: Navigation Blocked", gelange jedoch mit der Auswahl "Continue to this website (not recommended)." dann auf die Startseite von W2 (aber mit der URL von W1, welche Rot-Hinterlegt ist da ein Certificate Error existiert). Prüfe ich das Zertifikat, sehe ich das es noch bis 2012 gültig ist.

    Ich freue mich auf zahlreiche Ideen und Anmerkungen.

    Danke und Gruß

    Donnerstag, 9. Dezember 2010 13:40

Antworten

  • Hallo,

    leider nicht. Dies liegt jedoch daran, das das Entscheidungsboard noch nicht getagt hat. Bis dahin könnten wir das Thread schließen, oder?

    Danke und Gruß

    Donnerstag, 23. Dezember 2010 08:14

Alle Antworten

  • Hallo,

    sind die beiden Host Names im DNS mit der selben IP-Adresse eingetragen?

    Gruß,
    Andrei

    Montag, 13. Dezember 2010 09:45
  • Hallo,

    tatsächlich sind die Host Names im DNS mit der selben IP-Adresse erreichbar.

    Was heißt das für mein Problem?

    Danke und Gruß,

    Montag, 13. Dezember 2010 15:45
  • Hallo,

    das Problem liegt dabei, dass IIS HTTPS Seiten den Host Header nicht auswerten können. Der Request wird also nur nach IP-Adresse und Port (443) ausgewertet und dieser landet somit auf der vorhandenen HTTPS Seite.

    Um das Problem loszuwerden, erteile eine zusätzlice IP-Adresse für W1. Aktualisiere anschließend den DNS Eintrag für W1 und dann stelle in IIS sicher, dass die W2 SSL verschlüsselte IIS Seite auf die richtige IP Adresse und Port 443 gebunden ist.

    Beispiel für die IIS Bindungen:

    W2: IIS Seite1 10.0.0.20:80
           IIS Seite2 10.0.0.20:443

    W1: IIS Seite1 10.0.0.21:80

    Gruß,
    Andrei

    Dienstag, 14. Dezember 2010 07:13
  • Hallo,

    seit Ihr hier weitergekommen?

    Gruß,
    Andrei

    Montag, 20. Dezember 2010 11:02
  • Hallo,

    leider nicht. Dies liegt jedoch daran, das das Entscheidungsboard noch nicht getagt hat. Bis dahin könnten wir das Thread schließen, oder?

    Danke und Gruß

    Donnerstag, 23. Dezember 2010 08:14