none
Sharepoint 2010 SP1 Rollup Installation RRS feed

  • Frage

  • Hallo,

    wir haben eine aktuelle Sharepoint 2010 Installation mit SP1. Um kleinere Probleme zu lösen wollen wir nun die letzten Rollups installieren. Dazu habe ich drei Fragen:

    1) Wo finde ich die letzten Rollups

    2) Enthält der letzte Patch / Rollup alle vergehenden Patche / Rollups wie bei Exchange

    3) Muss Sharepoint dafür komplett heruntergefahren werden und nach der Installation auch die DB geupdatet werden?

    Danke für Eure Antworten

    Freitag, 4. Januar 2013 13:42

Antworten

  • "Woran erkenne ich ob die Foundation oder nur der Server installiert ist?"

    Schau mal in der Systemsteuerung unter "Programme hinzufügen oder entfernen" nach. Dort sollte das stehen.

    "Für Server ist das letzte CU  dann KB 2596955, richtig?"

    Richtig.

    "muss  die DB auch noch seperat geupdatet werden."

    Nein. Das geschieht automatisch. 

    Gruß
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort markiert Thomas Al Montag, 7. Januar 2013 11:28
    Montag, 7. Januar 2013 10:33
  • Hallo!

    Auf jedem SP-Server separat installieren! Danach MUSS auf jedem Server der "SharePoint Products and Configuration Wizard" ausgeführt werden. Anschließend sollte die Buildnummer korrekt gesetzt sein.

    Gruß

    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort markiert Thomas Al Donnerstag, 10. Januar 2013 09:56
    Donnerstag, 10. Januar 2013 09:27
  • Hallo!

    Hier findest Du immer die letzten Updates:

    http://technet.microsoft.com/en-us/sharepoint/ff800847.aspx

    "Rollups" sind die "Cumulative Updates" (kurz: CU) ??

    Alle nach einem Service Pack veröffentlichten "CUs" enthalten immer alle vorhergehenden. Nur bei einem Service Pack muss dieses auf jeden Fall installiert werden um die darauffolgenden CUs installieren zu können.

    Der SharePoint muss nicht heruntergefahren werden. Allerdings sollte während des Updates niemand mit dem System arbeiten. Am besten wäre es, den Zugriff auf die URLs zu sperren, auf geeignete Weise: es darf *nicht* vorkommen, dass die SharePoint Farm Server selbst irgendwelche Netzwerk-Probleme bekommen. - In meinen Kundenszenarien haben wir das über Firewall und/oder DNS gelöst.

    Grüße
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort vorgeschlagen Alex Pitulice Montag, 7. Januar 2013 09:00
    • Als Antwort markiert Thomas Al Montag, 7. Januar 2013 11:28
    Freitag, 4. Januar 2013 14:03
  • Bin spät mit der Antowrt. Sorry... - Ja: Du *solltest* alle Knoten erst installieren und dann den Config Wizard laufen lassen. - Du musst sicherstellen, dass der SharePoint während des Updates nicht benutzt wird. Im Zweifelsfall solltest Du erst ein paar Web Frontend Server aktualisieren und diese dann online nehmen, so dass andere Nutzer wieder arbeiten können. Danach kannst Du die verbleibenden Server aktualisieren, solange diese noch offline sind. 

    Gruß
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort markiert Thomas Al Montag, 4. Februar 2013 16:28
    Montag, 4. Februar 2013 16:22

Alle Antworten

  • Hallo!

    Hier findest Du immer die letzten Updates:

    http://technet.microsoft.com/en-us/sharepoint/ff800847.aspx

    "Rollups" sind die "Cumulative Updates" (kurz: CU) ??

    Alle nach einem Service Pack veröffentlichten "CUs" enthalten immer alle vorhergehenden. Nur bei einem Service Pack muss dieses auf jeden Fall installiert werden um die darauffolgenden CUs installieren zu können.

    Der SharePoint muss nicht heruntergefahren werden. Allerdings sollte während des Updates niemand mit dem System arbeiten. Am besten wäre es, den Zugriff auf die URLs zu sperren, auf geeignete Weise: es darf *nicht* vorkommen, dass die SharePoint Farm Server selbst irgendwelche Netzwerk-Probleme bekommen. - In meinen Kundenszenarien haben wir das über Firewall und/oder DNS gelöst.

    Grüße
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort vorgeschlagen Alex Pitulice Montag, 7. Januar 2013 09:00
    • Als Antwort markiert Thomas Al Montag, 7. Januar 2013 11:28
    Freitag, 4. Januar 2013 14:03
  • Guten Morgen,

    danke für Deine promte Antwort. Das ist sehr hilfreich.

    Dann noch zwei kurze Fragen:

    1)Woran erkenne ich ob die Foundation oder nur der Server installiert ist?

    2) Für Server ist das letzte CU  dann KB 2596955, richtig?

    Danke noch einemal

    Montag, 7. Januar 2013 09:08
  • hallo,

    muss  die DB auch noch seperat geupdatet werden.

    Danke

    Montag, 7. Januar 2013 09:09
  • "Woran erkenne ich ob die Foundation oder nur der Server installiert ist?"

    Schau mal in der Systemsteuerung unter "Programme hinzufügen oder entfernen" nach. Dort sollte das stehen.

    "Für Server ist das letzte CU  dann KB 2596955, richtig?"

    Richtig.

    "muss  die DB auch noch seperat geupdatet werden."

    Nein. Das geschieht automatisch. 

    Gruß
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort markiert Thomas Al Montag, 7. Januar 2013 11:28
    Montag, 7. Januar 2013 10:33
  • Guten Morgen,

    ist das letzte Upgrade serverübergreifend oder muss es auf jedem Server seperat installiert werden (auf dem SQL wird es nicht installiert).

    Danke

    Donnerstag, 10. Januar 2013 08:37
  • Nach dem Update bleibt get-spfarm auf der selben Build number. Wie kann ich die aktuelle Build nummer sehen.

    Danke

    Donnerstag, 10. Januar 2013 09:07
  • Hallo!

    Auf jedem SP-Server separat installieren! Danach MUSS auf jedem Server der "SharePoint Products and Configuration Wizard" ausgeführt werden. Anschließend sollte die Buildnummer korrekt gesetzt sein.

    Gruß

    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort markiert Thomas Al Donnerstag, 10. Januar 2013 09:56
    Donnerstag, 10. Januar 2013 09:27
  • Super, danke.

    Ist der Konfigurationsassisten für alle SP Server oder pro Server zu verwenden?

    danke

    Donnerstag, 10. Januar 2013 09:34
  • Super es hat alles geklappt,

    danke noch mal

    Donnerstag, 10. Januar 2013 09:56
  • Hallo,

    die Office Web App  Update finde ich unter http://support.microsoft.com/kb/2789671

    Muss ich diese einzel einspielen oder gibt es dafür auch ein Paket? Muss danach der Konfigassisten laufen?

    Danke


    Donnerstag, 10. Januar 2013 10:24
  • Hallo Thomas!

    Du musst das Office Web Apps Paket separat einspielen. Auf jedem Server, auf dem die Office Web Apps installiert sind. Danach den "Products and Configuration Wizard" wieder auf jedem Server laufen lassen. Dieser letzte Schritt muss immer getan werden, wenn ein SharePoint Update (irgend eines) installiert wurde. ABER man kann mehrere Updates hintereinander installieren und erst nach dem letzten Update den Wizard laufen lassen. Trotzdem: AUF JEDEM SERVER!

    Während des Updates der Farm sollte die Farm nicht benutzt werden!!! Zumindest nicht diejenigen Server, die noch auf dem alten Stand sind. Diese Server sollten per Config aus dem Betrieb genommen werden, z.B. über Änderung des Load Balancing.

    Gruß
    Ingo


    Microsoft Certified Master - SharePoint 2010

    Donnerstag, 10. Januar 2013 11:14
  • Müssen denn nur die Office oder aber auch die anderen (Excel, etc ) CU installiert werden.

    Vorallem müssen alle dort stehenden Update eingespielt werden. (Es ist keine lokale Office Version installiert nur die Web Apps)

    Danke noch  und sorry es ist für mich nicht einfach dort durchzusehen.

    Donnerstag, 10. Januar 2013 11:26
  • Es gibt ein Office Web Apps Hotfix Paket (http://support.microsoft.com/kb/2726912) Die Client-Updates musst Du nicht auf dem Server installieren!! 

    Microsoft Certified Master - SharePoint 2010

    Donnerstag, 10. Januar 2013 12:00
  • Letzte Frage ;-)

    sind diese Patche auch CU?

    Danke

    Donnerstag, 10. Januar 2013 12:12
  • Ich finde das auch verwirrend! Oben steht "cumulative update" und das gibts jede Menge Links zu einzelnen Paketen. "Normalerweise" ist ein "CU" eine Art Zusammenfassung mehrerer einzelner Updates zu einem Paket. Im Falle des Office Web Apps Hotfix (wie der Name sagt) würde ich nicht von einem "CU" sprechen, denn hier werden nicht verschiedene Updatepakete zusammengefasst. Aber auch das ist "relativ", denn lt. KB besteht ja das Hotfix auch aus zwei Dateien ;-) Sehr verwirrend, wie gesagt! 

    Microsoft Certified Master - SharePoint 2010

    Donnerstag, 10. Januar 2013 12:26
  • Gut, dann liege ichnicht so falsch mit meiner Einschätzung.

    Ich habe jetzt die Fixes für Dez, Okt, Jun und Feb 2012 (nach SP1 hoffe ich alle zu haben) heruntergeladen und werde Sie bei gegebener Zeit installieren

    Danke für die Hilfe

    Donnerstag, 10. Januar 2013 12:36
  • Nochmal zur Sicherheit: NACH einem Service Pack (z.B. SP1) muss nur das LETZTE CU installiert werden. Die CUs zwischen dem Service Pack und dem letzten CU Sind im letzten CU enthalten. Also: SP1 -> Dezember 2012 CU enthält Juni 2011, August 2011, Dezember 2011, Feb. 2012, etc. (nicht korrekt, nur Beispiel). 

    Microsoft Certified Master - SharePoint 2010

    Donnerstag, 10. Januar 2013 13:13
  • Hallo Ingo,

    bei einem SP Cluster muss ich da erst die CU auf allen Nodes installiert haben, bevor ich den Konfigassistenten laufen lasse, da ich sonst Änderungen in der DB vornehme, die einer der Knoten nicht kennt (der das CU noch nicht hat)

    Danke

    Donnerstag, 31. Januar 2013 09:03
  • Bin spät mit der Antowrt. Sorry... - Ja: Du *solltest* alle Knoten erst installieren und dann den Config Wizard laufen lassen. - Du musst sicherstellen, dass der SharePoint während des Updates nicht benutzt wird. Im Zweifelsfall solltest Du erst ein paar Web Frontend Server aktualisieren und diese dann online nehmen, so dass andere Nutzer wieder arbeiten können. Danach kannst Du die verbleibenden Server aktualisieren, solange diese noch offline sind. 

    Gruß
    Ingo


    Microsoft Certified Master - SharePoint 2010

    • Als Antwort markiert Thomas Al Montag, 4. Februar 2013 16:28
    Montag, 4. Februar 2013 16:22
  • Hi

    Danke für die Antwort, habe es auch geau so gemacht. Interessanter Weise musste ich bei einem Server den Wizzard zweimal laufen lassen.

    danke

    Montag, 4. Februar 2013 16:28