none
wbadmin Server2008R2 sehr langsam RRS feed

  • Frage

  • Hallo zusammen,

    ich habe bei der Benutzung von wbadmin unter Server2008R2 in einem speziellen Szenario unterirdische Performance und sehe nicht warum das so ist. Ich hoffe mir kann hier jemand einen nützlichen Tip hierzu geben

    Im Netzwerk gibt es hier einen Server unter Server2008R2 und ein QNAP NAS. Das NAS ist mittels Porttrunking (802.3ad) mit dem Netzwerk verbunden (2Gbit) und stellt ein iSCSI-Target und SMB 2.1-basierte Freigaben im Netzwerk bereit. Der Server ist mit dem iSCSI-Target verbunden. Die Performance auf dem LUN ist gut (~100MB/s). Der SMB-basierte Zugriff auf das NAS ist ebenfalls gut (~85MB/s). Im NAS sind 4 Festplatten im RAID5-Verbund verbaut.

    Neben anderen Sicherungen soll der Server zusätzlich eine Kopiesicherung aller Laufwerke (inkl. dem iSCSI-LUN) auf eine SMB-Freigabe auf dem NAS durchführen. Das iSCSI-LUN wird also vom Server ebenfalls wieder auf das NAS geschrieben. Hintergrund ist hier eine weitere Verarbeitung.

    Bei der Sicherung kommt es jetzt zu einer unterirdischen Performance bei der Verwendung von wbadmin (~8-10MB/s). Hierbei dauert die Sicherung natürlich ewig. Alle Leistungsparameter auf dem Server und dem NAS sind unauffällig. (CPU, IOPs, Bandbreite etc.). Ich würde zumindest mit einem Durchsatz von 30-40MB/s rechnen. Kann mir hier vielleicht jemand einen Denkanstoß geben?

    LG,

    Tom


    • Bearbeitet Tommey82 Samstag, 3. Januar 2015 11:03
    Samstag, 3. Januar 2015 10:58

Antworten

  • Evtl. sind die Platten im NAS ausgelastet, wenn gleichzeitig gelesen und geschrieben wird (da wird ja viel hin und her gesprungen)? Teste mal Lesen/Schreiben gleichzeitig mit vielen Dateien.

    Anti-Virus? Ist häufig ein großes Problem beim Backup.

    • Als Antwort markiert Tommey82 Mittwoch, 14. Januar 2015 17:51
    Samstag, 3. Januar 2015 12:20

Alle Antworten

  • Evtl. sind die Platten im NAS ausgelastet, wenn gleichzeitig gelesen und geschrieben wird (da wird ja viel hin und her gesprungen)? Teste mal Lesen/Schreiben gleichzeitig mit vielen Dateien.

    Anti-Virus? Ist häufig ein großes Problem beim Backup.

    • Als Antwort markiert Tommey82 Mittwoch, 14. Januar 2015 17:51
    Samstag, 3. Januar 2015 12:20
  • Am 03.01.2015 schrieb Tommey82:

    Im Netzwerk gibt es hier einen Server unter Server2008R2 und ein QNAP NAS. Das

    Ist die Firmware des NAS aktuell? Unbedingt manuell überprüfen.

    Bei der Sicherung kommt es jetzt zu einer unterirdischen Performance bei der Verwendung von wbadmin (~8-10MB/s). Hierbei dauert die Sicherung natürlich ewig. Alle Leistungsparameter auf dem Server und dem NAS sind unauffällig. (CPU, IOPs, Bandbreite etc.). Ich würde zumindest mit einem Durchsatz von 30-40MB/s rechnen. Kann mir hier vielleicht jemand einen Denkanstoß geben?

    Du kannst das SMB-Signing gem. BestPraxis konfigurieren:
    http://www.gruppenrichtlinien.de/artikel/smb-signing-kommunikation-digital-signieren/
    Nicht einfach blind abschalten, sonder wie im Artikel beschrieben
    einstellen. Anschließend alle beteiligten Geräte neu starten.


    Servus
    Winfried

    Gruppenrichtlinien
    HowTos zum WSUS Package Publisher
    WSUS Package Publisher
    HowTos zum Local Update Publisher
    NNTP-Bridge für MS-Foren

    Samstag, 3. Januar 2015 13:40
  • Hallo,

    vielen Dank an alle für Ihre Beiträge!

    @Teoomey82, haben die Tipps weitergeholfen? Wenn ja, markieren Sie bitte die richtige Lösung als Antwort.

    Wenn Sie eine andere Lösung gefunden haben, teilen Sie sie der Community mit, sodass auch andere Benutzer als der Fragesteller davon profitieren können.

    Danke und viele Grüße,

    Michaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Freitag, 9. Januar 2015 08:54
    Moderator
  • In diesem Falle scheint das NAS wohl an die Grenzen der möglichen IOPS gestoßen zu sein. Dass SMB-Signing hier verantwortlich war, ergibt sich nicht aus dem Verhalten. Die Übertragung über das Netzwerk ist mit 100MB/s möglich. Ich habe einen Workaround mit weiteren Festplatten im Netzwerk erstellt. Danke für die Beitrage.
    Mittwoch, 14. Januar 2015 17:53