none
stundenangabe über 10000 in excel RRS feed

  • Frage

  • Wie kann ich die stundenberechnung bzw. anzeige im diagramm über 10000 in excel realisieren ?
    Donnerstag, 9. Dezember 2010 15:32

Alle Antworten

  • Hi stundenangabe über 10000 in excel,

    Wie kann ich die stundenberechnung bzw. anzeige im diagramm über 10000 in excel realisieren ?

    wo soll das Problem liegen? ...für die Y-Achse sollte das kein Problem sein...

    Hier eine kurze Anleitung:
    http://webcyclus.de/excel-2010-diagramm-erstellen/
    Viele Grüße
    Christian

    Freitag, 10. Dezember 2010 07:50
  • Danke Christian,

    aber da habe ich nicht deutlich genug formuliert

    wir haben eine Stundenliste mit mehrjährigen Einträgen

    z.B.  9700:35:21

           8400:21:56

         12024:15:48

    usw.

    wenn diese werte einem Diagramm mit linien zugewiesen werden,

    liegt die LINIE bei den über 10.000 Stunden, sprichwörtlich am boden :-)

    ich bin ja nicht alleine in der firma aber keiner hat ne Lösung bzw ALTERNATIVE.

    PS dies ist auch mein erster Foren eintrag, das internet gab diesbezüglich leidr nichts her.

    internette grüße

     

    Freitag, 10. Dezember 2010 18:26
  • Hallo,

    wir haben eine Stundenliste mit mehrjährigen Einträgen
    z.B.  9700:35:21
           8400:21:56
         12024:15:48
    wenn diese werte einem Diagramm mit linien zugewiesen werden, liegt die LINIE bei den über 10.000 Stunden, sprichwörtlich am boden :-)

    hm, wird der letzte Eintrag wirklich als Wert behandelt oder doch eher als Text? Ein Lösungsansatz: Du könntest in einer Hilfsspalte (als Zahl formatiert) die Einträge in Dezimalzahlen umwandeln, müsstest vorher auf Zahl oder Text prüfen:
    =Wenn(Istzahl(A1);A1*24;(*****)). Falls es sich um eine Datumsangabe bzw. Zahl handelt, wird sie entsprechend als Dezimalzahl ausgegeben. Handelt es sich um Text, muss aus diesem mit Hilfe einer verschachtelten Funktion (statt der Sternchen) der Wert zusammengesetzt werden:
    Die Anzahl der Stunden ergibt sich aus dem linken Teil vor dem ersten Doppelpunkt: =WERT(LINKS(A1;SUCHEN(":";A1)-1)).
    Minuten und Sekunden ergeben sich aus dem verbleibenden rechten Teil nach dem ersten Doppelpunkt: =RECHTS(A1;LÄNGE(A1)-SUCHEN(":";A1)).
    Dieser ließe sich z. B. so in eine Dezimalzahl umwandeln: =ZEITWERT("00:"&[Hilfszelle oder Formel])*24.
    Die jeweils in Dezimalzahlen umgewandelten Stunden und Minuten/Sekunden müssen schließlich addiert werden. Möglicherweise gibt es eine einfachere Lösung. Sinnvoll kann auch sein, mit zwei oder drei separaten Hilfsspalten zu arbeiten.
    Die Umwandlung der Texteinträge sähe also folgendermaßen aus: =WERT(LINKS(A1;SUCHEN(":";A1)-1))+ZEITWERT("00:"&RECHTS(A1;LÄNGE(A1)-SUCHEN(":";A1)))*24.
    Mag sein, dass sich irgendwo noch ein Denkfehler verbirgt. Und sicher geht es auch einfacher - darüber mögen sich andere den Kopf zerbrechen ;-). Immerhin hast du nun einen Lösungsvorschlag:
    =WENN(ISTZAHL(A1);A1*24;WERT(LINKS(A1;SUCHEN(":";A1)-1))+ZEITWERT("00:"&RECHTS(A1;LÄNGE(A1)-SUCHEN(":";A1)))*24)


    Ein schönes Wochenende wünscht
    Lisa [MS MVP Word]
    Microsoft Excel - Die Expertentipps http://tinyurl.com/cmned

    Samstag, 11. Dezember 2010 14:35