none
Zertifikatsproblem RRS feed

  • Frage

  • Hallo Community

    ich habe hier einen Exchange, welcher seit von SBS 2003 auf mittlerweile 2019 immer wieder mal migriert wurde. Soweit auch nie Probleme gehabt. Allerdings wurden früher die Domains ja noch mit .local standardmäßig benannt, da damals noch keine Internetanbindung bestand. Es wurde dann mal ein Split-DNS eingeführt und später auch auf SSL umgestellt.

    Obwohl eigentlich alle URLs im Exchange Server angepasst wurden (sofern es dafür UI-Felder oder Powershell-Befehle gibt), habe ich irgendwo noch eine alte Bezeichnung im AD und finde diese nicht! *grrr*

    Das Problem ist nämlich, dass bei einem Outlookstart immer das Zertifikat angekreidet wird. Klar könnte man alternativ auch ein multisite Zertifikat beschaffen, was aber deutlich teurer ist.

    Hier die Fehlermeldung:

    Wenn man auf Zertifikat anzeigen klickt sieht man, dass schon das richtige Zertifikat (also für die externe Adresse) verwendet wird, jedoch verständlicherweise angekreidet wird, da die URL nicht zueinander passen:

    Die Frage ist jetzt, wo bekommt Outlook noch die (alte) interne Adresse her (Autodiscover? - wobei ich hier auch nichts gefunden habe), also SERVER3.xxx.local und nicht die hh.xxx.de??

    Hat jemand noch eine Idee was man prüfen könnte?

    Danke Euch!


    Donnerstag, 18. März 2021 13:34

Alle Antworten

  • Moin,

    ist SERVER3 denn der richtige Name des jetzigen Exchange oder ist es einer seiner Vorgänger? Du sprichst ja von "alt"...


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Donnerstag, 18. März 2021 16:36
  • Hallo Evgenij

    SERVER3 ist schon der aktuelle interne Computername. Sonst würde er ja auch gar nicht so weit kommen das Zertifikat zu laden und zu überprüfen ;) 

    Freitag, 19. März 2021 00:25
  • Spontane Idee, passt die Einstellungen im Split-DNS zu dem extern ausgestellten Zertifikat?

    ;)


    Gruß Norbert

    Freitag, 19. März 2021 05:25
    Moderator
  • Hallo Evgenij

    SERVER3 ist schon der aktuelle interne Computername. Sonst würde er ja auch gar nicht so weit kommen das Zertifikat zu laden und zu überprüfen ;) 

    Namen von alten Servern als Aliase auf neue Server habe ich durchaus schon erlebt ;-)

    Dann musst Du mal zwei Dinge überprüfen: 

    1. Autodiscover (nimm die AutodiscoverTest.exe von Kip Ng, nicht Outlook)

    2. Autodiscover-Einstellungen im Outlook (Gruppenrichtlinien: Ist eine der Methoden deaktiviert, wird evtl. auf eine lokale XML zurückgegriffen etc.)

    Ansonsten: Es muss der zum Zertifikat passende FQDN in sämtlichen vDirs sowohl als interner als auch als externer Name stehen!


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Freitag, 19. März 2021 10:46
  • Passt der SCP im AD? 

    Grüße
    Jörg
    Freitag, 19. März 2021 13:15
  • 1. Autodiscover (nimm die AutodiscoverTest.exe von Kip Ng, nicht Outlook)

    Das Tool funktioniert bei mir irgendwie nicht. Hätte ja mal die Ausgabe gepostet. Doch irgendwie lässt die fu.. Plattform es nicht mehr zu ein Foto hochzuladen. Der upload verbleibt in einer Dauerschleife.

    Das Foto mit der Ausgabe von Outlook kann ich somit auch nicht zeigen. Toll!

    Sonntag, 21. März 2021 21:17