none
Storage Pool in Hyper-V VM von Host übernommen RRS feed

  • Frage

  • Hallo liebe Community,

    ich habe einen Hyper-V Host auf Basis Windows 2012 und mehrere VMs, ebenfalls Windows 2012. Eine der VMs war ein Fileserver mit Storagepools.

    Ich habe mehrere Physische platten direkt an die VM zugewiesen und auf dem Fileserver einen Storagepool (Parity) erstellt.

    Nach einem unerwarteten reboot des Hosts hat dieser seltsamerweise auch den Storagepool übernommen.

    D.H. Auf dem Host habe ich nun den Pool "FS_POOL_1", welcher eigentlich in der VM erstellt wurde.

    Außerdem ist ein gelbes Dreieck vor dem Pool und der Status ist "Unbekannt"

    Wie bekomme ich nun diesen Pool wieder in meine VM, sodass dieser wie anfangs konfiguriert in der VM betrieben wird?

    Da noch daten in diesem Pool liegen, sollte dies ohne Datenverlust geschehen.

    Und wie kann es überhaupt passieren, dass der Pool auf einmal vom Host übernommen wurde?

    Ich hoffe ihr könnt mir helfen.


    Dienstag, 25. März 2014 14:00

Antworten

  • Hi,

    ich gehe mal davon aus das der Hyper-V Server die Datenträger online geschalten hat. (Das kann passieren wenn Automount nicht deaktiviert wurde!)
    somit konnte die VM natürlich die Datenträger nicht mehr mounten weil diese schon im Zugriff waren.

    Zunächst würde ich auf dem Hyper-V Server das Automount deaktivieren:
    http://technet.microsoft.com/de-de/library/cc766465(v=ws.10).aspx

    Dann die physischen Datenträger auf dem Hyper-V Server offline schalten und danach in der VM wieder online schalten.

    Aber mal ganz davon abgesehen ist das ganze nicht Supported!!!
    http://www.aidanfinn.com/?p=14489

    Gruß

    Sebastian


    • Bearbeitet SebVe Dienstag, 25. März 2014 14:24
    • Als Antwort markiert Luke-F Dienstag, 25. März 2014 14:59
    Dienstag, 25. März 2014 14:09

Alle Antworten

  • Hi,

    ich gehe mal davon aus das der Hyper-V Server die Datenträger online geschalten hat. (Das kann passieren wenn Automount nicht deaktiviert wurde!)
    somit konnte die VM natürlich die Datenträger nicht mehr mounten weil diese schon im Zugriff waren.

    Zunächst würde ich auf dem Hyper-V Server das Automount deaktivieren:
    http://technet.microsoft.com/de-de/library/cc766465(v=ws.10).aspx

    Dann die physischen Datenträger auf dem Hyper-V Server offline schalten und danach in der VM wieder online schalten.

    Aber mal ganz davon abgesehen ist das ganze nicht Supported!!!
    http://www.aidanfinn.com/?p=14489

    Gruß

    Sebastian


    • Bearbeitet SebVe Dienstag, 25. März 2014 14:24
    • Als Antwort markiert Luke-F Dienstag, 25. März 2014 14:59
    Dienstag, 25. März 2014 14:09
  • Hi Sebastian,

    vielen Dank schon mal für Deinen Tipp mit dem Automount! Damit wäre die Ursache schon mal geklärt.

    Leider kann ich die Datenträger nicht offline schalten, da diese noch dem Storagepool zugewiesen sind und daher nicht in der Datenträgerverwaltung auftauchen.

    Den Pool möchte ich auch nicht einfach löschen, da dort wie gesagt noch Daten liegen.

    Gibt es hier eine möglichkeit, diese Datenträger wieder der VM zuzuweisen?Als Notlösung wäre auch möglich die Daten vom Host zu sichern, wenn ich Zugriff darauf hätte. Leider wird mir im Servermanager zwar das Volume angezeigt, aber Zugriff habe ich trotzdem nicht.

    Dienstag, 25. März 2014 14:21
  • Schau dir das mal an, vielleicht hilft das:

    Recovering a storage space
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/a675609e-28d5-4b1a-844b-38b76899c681/recovering-a-storage-space

    Server2012 steals pass through Storage Space used disks from Guest
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/263c5ed6-2753-4f86-9804-da134ebb8a57/server2012-steals-pass-through-storage-space-used-disks-from-guest

    Aber wie gesagt, Storage Pools in VMs sind nicht Supportet!

    Für testzwecke ist das ok und funktioniert eventuell auch. Aber falls das eine Produktivumgebung ist würde ich dringend nach alternativen suchen!


    • Bearbeitet SebVe Dienstag, 25. März 2014 14:34
    Dienstag, 25. März 2014 14:33
  • OK, habe die Problematik nun verstanden. Mir war vorher auch nicht bewusst, dass der Betrieb von Storage Spaces in einer VM nicht supportet wird.

    Habe nun auch wieder zugriff auf meine Daten. Musste hierfür zuerst auf dem Pool den "Schreibzugriff" aktivieren und dann den virtuellen Datenträger an den Host "Anhängen".

    Ich denke ich werde nun die Storage Spaces auf dem Host konfigurieren und dann die VHD an die VM durchreichen.

    Danke für deine Unterstützung!

    Dienstag, 25. März 2014 14:58