none
Couldn't find the Enterprise Organization container (Exchange 2016) RRS feed

  • Frage

  • Hallo Allerseits,

    ich habe hier ein Problem mit der Installation eines MS Exchange Servers 2016.

     

    Ich hoffe sie können mir weiterhelfen, da ich momentan nicht weiter weiss.

     

    Das System besteht aus einem DC und einem Server auf dem der Exchange Server 2016 installiert werden soll. Vor einiger Zeit hatte ich mal zu Testzwecken einen Exchange 2013 dort installiert. Diesen jedoch nach Anleitung wieder deinstalliert.  Das hat auch soweit problemlos funktioniert.

    Nun möchte der Kunde die Version 2016 installiert haben. Da scheitert es jedoch schon bei der AD Schema Erweiterung. Auch die Schema Erweiterung des EXch1013 lässt sich nicht mehr ausführen. Hier wird dann gesagt, dass das installierte Schema Neuer wäre als das was ich installieren möchte. Bei Exchange 2016 tauchen die ersten Fehler auf, wenn ich das Schema erweitern möchte:

     

    Setup erfasst nun zusätzliche für die Installation erforderliche Informationen.

     

    [11.16.2015 08:28:29.0644] [0] Assembly dll file location is C:\Windows\Temp\ExchangeSetup\Microsoft.Exchange.Setup.Console.dll

    [11.16.2015 08:28:37.0894] [0] Setup is choosing the domain controller to use

    [11.16.2015 08:28:46.0051] [0] Setup is choosing a local domain controller...

    [11.16.2015 08:28:50.0567] [0] Setup has chosen the local domain controller RAPODC01.rapodom.loc for initial queries

    [11.16.2015 08:28:51.0833] [0] [ERROR] Setup encountered a problem while validating the state of Active Directory: Der Organisationscontainer für das Unternehmen wurde nicht gefunden.  See the Exchange setup log for more information on this error.

    [11.16.2015 08:28:51.0989] [0] [ERROR] Couldn't find the Enterprise Organization container.

    [11.16.2015 08:28:51.0989] [0] Setup will use the domain controller ''.

    [11.16.2015 08:28:51.0989] [0] Setup will use the global catalog ''.

    [11.16.2015 08:28:52.0020] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=rapodom,DC=loc'.

    [11.16.2015 08:28:52.0020] [0] No Exchange organization container was found for the organization. Message: 'Der Organisationscontainer für das Unternehmen wurde nicht gefunden.'.

    [11.16.2015 08:28:52.0020] [0] For more information refer to http://go.microsoft.com/fwlink/p/?LinkId=257397.

    [11.16.2015 08:28:52.0020] [0] Setup will search for an Exchange Server object for the local machine with name 'RAPOCOM01'.

    [11.16.2015 08:28:52.0130] [0] No Exchange Server with identity 'RAPOCOM01' was found.

     

    Es scheint so zu sein, dass trotz erfolgreicher Deinstallation des EX2013 , noch Reste (die sind auch im AD Sichtbar) übrig bleiben und die mir nun Ärger verursachen. Ich weiss nur nicht was ich jetzt tun kann.

     

    Bitte können sie mir weiterhelfen?

     

    Vielen Dank und Grüße

     

    OIaf Dannath

    Montag, 16. November 2015 15:48

Antworten

  • Moin,

    so wie es scheint, wurden da irgendwelche manuellen Löschaktionen im AD gemacht.

    Wenn Du Dir einen Low-Level-Eingriff nicht zutraust (es droht ein Totalverliust von AD!!), dann hol Dir einen Fachmann ins Haus.

    Ansonsten kann man so die Exchange-Organisation komplett aus AD killen:

    https://kx.cloudingenium.com/microsoft/servers/exchange/exchange-2013/exchange-2013-completely-remove-settings-active-directory/

    Dabei siehst Du dann auch, welche Reste Du noch hast und was vorher schon mal gelöscht wurde.

    Danach hast Du bis auf die Schema-Änderungen nichts mehr von Exchange in Deinem AD. Die Schema-Änderungen kannst Du aber nicht rückgängig machen, die sollten dann aber auch nicht mehr stören, weil 2016 eh neue Änderungen hinzufügt.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Dienstag, 17. November 2015 11:01

Alle Antworten

  • Moin,

    welches OS soll unter dem Exchange laufen, welchen AD Level hat die Domäne?

    Mal mittels ADSI Edit schauen, ob nicht doch noch Reste von der alten 2013er Inst da sind.

    Wo kommt die 2016 her?

    ;)


    Gruß Norbert

    Dienstag, 17. November 2015 06:16
    Moderator
  • Moin,

    so wie es scheint, wurden da irgendwelche manuellen Löschaktionen im AD gemacht.

    Wenn Du Dir einen Low-Level-Eingriff nicht zutraust (es droht ein Totalverliust von AD!!), dann hol Dir einen Fachmann ins Haus.

    Ansonsten kann man so die Exchange-Organisation komplett aus AD killen:

    https://kx.cloudingenium.com/microsoft/servers/exchange/exchange-2013/exchange-2013-completely-remove-settings-active-directory/

    Dabei siehst Du dann auch, welche Reste Du noch hast und was vorher schon mal gelöscht wurde.

    Danach hast Du bis auf die Schema-Änderungen nichts mehr von Exchange in Deinem AD. Die Schema-Änderungen kannst Du aber nicht rückgängig machen, die sollten dann aber auch nicht mehr stören, weil 2016 eh neue Änderungen hinzufügt.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Dienstag, 17. November 2015 11:01