none
App-v 5 - Start Process Script RRS feed

  • Frage

  • Guten Tag,

    Ich habe begonnen mit App-v 5 Applikationen zu virtualisieren. Einige benötigen nun ein Startup Script.

    Zu Testzwecken habe ich nun Firefox paketiert und in der UserConfig.xml folgende Anpassung gemacht

    <UserScripts> <StartProcess RunInVirtualEnvironment="true"> <Path>%SYSTEMROOT%\System32\CMD.EXE</Path> <Arguments>/K "\\Server2\Share\map.bat</Arguments> <Wait RollbackOnError="true" Timeout="120"/> <ApplicationId>[{ProgramFilesX86}]\Mozilla Firefox\firefox.exe</ApplicationId> </StartProcess> </UserScripts>

    Der Batch (map.bat) verbindet nur zu Testzwecken ein Laufwerk

    @echo off
    net use x: \\Server\tAppV /persistent:no
    exit

    Wenn ich nun Firefox starte erhalte ich sofort folgende Fehlermeldung:

    Der Eventvwr.exe sagt folgendes aus:

    Ereignis-ID 4001 The App-V client failed to create a process for user script event StartProcess with command line: '%SYSTEMROOT%\System32\CMD.EXE /K "\\Server2\Share\map.bat"

    /appvrunningve:D8E2D1B5-8C59-448F-A76E-9DB2A3EE4F5F_086CF719-E75F-49CC-8DF0-8DAED4925226'.

    Windows error: Das System kann die angegebene Datei nicht finden.. The path must be a Windows application (.exe file).

    Ich schaffe es einfach nicht ein Startup-Script einzubinden.

    Wo liegt genau der Fehler?

    Öffne ich den Pfad, welcher laut dem Eventviewer nicht gefunden werden kann, start sich die Bate-Datei erfolgreich...

    Vielen Dank bereits jetzt für eure Hilfe!

    Freundlich Grüsse

    Schmidi


    Freundliche Grüsse

    Montag, 13. April 2015 07:41

Antworten

Alle Antworten