none
Windows Phone 8.1 (WinRT) App enrollment funktioniert nicht RRS feed

  • Frage

  • Hallo

    Wir haben bis anhin über SCCM (mit intune) ein windows phone 8.0 app verteilt. Dies funktionierte wunderbar. Jetzt haben wir das App auf Windows Phone 8.1 (WinRT) portiert und versuchen nun das .appx package über die SCCM Konsole auf die Geräte zu verteilen. Leider funktioniert die Installation des Apps nicht.

    Was wir gemacht haben:

    1) Wir haben eine mit einem gültigen Symantec Zertifikat zertifizierte .appx Datei

    2) Die .appx Datei wurde erfolgreich in SCCM hochgeladen und für Benutzer bereitgestellt

    3) Die Intune Extension "Windows Phone 8.1" ist ebenfalls aktiviert

    Was nicht funktioniert:

    - Wenn wir versuchen das App über das Unternehmens-Portal App zu installieren kommt die Meldung "Die App wurde nicht hinzugefügt. Sie können die Installation wiederholen"

    Ich weiss nicht was falsch läuft, hat jemand eine Idee? Ist was mit der Zertifizierung falsch oder muss man allenfalls die Geräte nochmals in SCCM registrieren?

    Mit einer 8.0 .xap Datei funktioniert alles einwandfrei, ich weiss nicht was an einem .appx anders ist.

    Besten Dank

    Dienstag, 22. Juli 2014 11:48

Antworten

  • Hallo

    Wir sind ein bisschen weitergekommen, aber funktionieren tut es so noch nicht.

    Wir versuchten bis jetzt das App auf drei verschiedene Arten zu installieren:

    1) Silent installation (automatisch als "Required") --> Funktioniert nicht "Unknown Error" als Deployment Status in sccm Monitoring node

    2) Über das Company Portal --> "Die App wurde nicht hinzugefügt. Sie können die Installation wiederholen"

    3) Manuelle Installation (appx manuell auf den phone storage kopiert und dann angeklickt) --> Die Meldung kommt zwar "Wollen sie das unternehmens app installieren?" und wenn man "Installieren" klick, passiert gar nichts, kein Fehler und das App ist auch nicht installiert.

    Jetzt habe ich aber gerade von jemanden erfahren, dass wenn er dass appx ohne Intune/sccm zusammen mit einem AET (App enrollment token, welches man generieen muss) per email versendet, und dann zuerst das aetx installiert, konnte er das appx auch installieren. Ich probiere dass auch noch aus und werde es hier updaten.

    Gemäss Doku werden die AETX Files von Intune automatisch generiert und installiert. Vielleicht liegt dort der Fehler.

    Aber ich habe keine Ahnung warum es mit den ersten 3 Varianten nicht geht, vielleicht muss MS dies zuerst noch freischalten oder irgendein update aufschalten...

    Update

    Nach langem hin und her scheint die Lösung des Problems gefunden zu sein. Bei manchen Geräten war die Firmware einfach zu alt, allerdings ist auch kein Handyupdate vorhanden gewesen.

    Der grösste Fehler war aber, dass das appx mit dem Powershell Script erstellt wurde welches das appx Pre-Compiled hat. Das Pre-Compiling war der Fehler. Ich habe somit das appx separat mit Signtool.exe signiert und siehe da es lief auf allen Geräten mit der neuesten Firmware.

    Es ist ein bisschen ärgerlich wegen eigentlich etwas kleinem so viel Zeit zu verlieren. Und ich verstehe auch nicht wieso MS ein Pre-Compiling macht, obwohl dies die appx unbrauchbar macht...

    S.Peter



    Donnerstag, 31. Juli 2014 13:58

Alle Antworten

  • Was sagt denn die Monitoring Node (Deployment Status)?

    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 22. Juli 2014 12:13
    Beantworter
  • Halllo

    Da steht deployment failed.

    Type: Error

    Error Description: Error Unknown

    Error Code: 0x87D103E8 (-2016345112)

    Habe gerade erfahren dass das OS des Phones noch die Entwickler Version 8.1 hat. Könnte das eventuell ein Problem sein?

    Über den Error-Code habe ich nicht viel gefunden im Internet

    Besten Dank

    Dienstag, 22. Juli 2014 13:11
  • Hallo

    Wir sind ein bisschen weitergekommen, aber funktionieren tut es so noch nicht.

    Wir versuchten bis jetzt das App auf drei verschiedene Arten zu installieren:

    1) Silent installation (automatisch als "Required") --> Funktioniert nicht "Unknown Error" als Deployment Status in sccm Monitoring node

    2) Über das Company Portal --> "Die App wurde nicht hinzugefügt. Sie können die Installation wiederholen"

    3) Manuelle Installation (appx manuell auf den phone storage kopiert und dann angeklickt) --> Die Meldung kommt zwar "Wollen sie das unternehmens app installieren?" und wenn man "Installieren" klick, passiert gar nichts, kein Fehler und das App ist auch nicht installiert.

    Jetzt habe ich aber gerade von jemanden erfahren, dass wenn er dass appx ohne Intune/sccm zusammen mit einem AET (App enrollment token, welches man generieen muss) per email versendet, und dann zuerst das aetx installiert, konnte er das appx auch installieren. Ich probiere dass auch noch aus und werde es hier updaten.

    Gemäss Doku werden die AETX Files von Intune automatisch generiert und installiert. Vielleicht liegt dort der Fehler.

    Aber ich habe keine Ahnung warum es mit den ersten 3 Varianten nicht geht, vielleicht muss MS dies zuerst noch freischalten oder irgendein update aufschalten...

    Update

    Nach langem hin und her scheint die Lösung des Problems gefunden zu sein. Bei manchen Geräten war die Firmware einfach zu alt, allerdings ist auch kein Handyupdate vorhanden gewesen.

    Der grösste Fehler war aber, dass das appx mit dem Powershell Script erstellt wurde welches das appx Pre-Compiled hat. Das Pre-Compiling war der Fehler. Ich habe somit das appx separat mit Signtool.exe signiert und siehe da es lief auf allen Geräten mit der neuesten Firmware.

    Es ist ein bisschen ärgerlich wegen eigentlich etwas kleinem so viel Zeit zu verlieren. Und ich verstehe auch nicht wieso MS ein Pre-Compiling macht, obwohl dies die appx unbrauchbar macht...

    S.Peter



    Donnerstag, 31. Juli 2014 13:58