none
IE11 lädt nicht vollständig bei Zugriff über SquidProxy-Server RRS feed

  • Allgemeine Diskussion

  • Folgende Konfiguration:

    Windows 2008 R2 Server mit SquidProxy-Server für Seitenfilterung

    Zugriff mit Windows 7 Ent. Clients und IE11 über den SquidProxy

    Generell funktioniert der Internetzugriff über den Proxy-Server.

    Während der Seitenaufruf mit dem IE10 keine Probleme bereitete, führt der Seitenaufruf mit dem IE11 zu reproduzierbaren Fehlern.

    Wenn z.B. das Google-Suchergebnis "Cosinus Sinus" bei Wikipedia aufgerufen wird, so werden bei Zugriff von normalen Netzwerkbenutzern

    Bilderlinks (Formeln) nicht oder nur unvollständig heruntergeladen. Bei Zugriff von Usern mit administrativen Rechten funktioniert der Seitenaufbau vollständig.

    Nach unserer Problemeingrenzung handelt es sich hier um ein Rechte- oder Benutzerproblem!

    Die Nutzung des IE11 ohne SquidProxy funktioniert hingegen normal für User und Administratoren.

    mfg

    re

    Mittwoch, 9. Juli 2014 12:23

Alle Antworten

  • Hi,

    Am 09.07.2014 14:23, schrieb Jenny Frank:

    Die Nutzung des IE11 ohne SquidProxy funktioniert hingegen normal für User und Administratoren.

    Dann ist es der Squid.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Mittwoch, 9. Juli 2014 15:18
  • Hallo Mark,

    Entschuldigung, wenn ich Dir widerspreche!

    Mit IE10 und der gleichen Konfiguration gibt es keinerlei Probleme, mit IE11 schon!

    Also da liegt der Fehler eindeutig beim Internet Explorer 11. Scheinbar wurde eine Einstellung verändert, die jetzt in Verbindung mit dem Squid das Problem verursacht. Diese Einstellung suche ich verzweifelt!

    Ich denke, da sind wir uns einig! Oder?

    mfg

    re

    Donnerstag, 10. Juli 2014 12:13
  • Am 10.07.2014 14:13, schrieb Jenny Frank:

    Mit IE10 und der gleichen Konfiguration gibt es keinerlei Probleme, mit IE11 schon!

    Aber mit IE11 ohne Squid gibt es auch keine Probleme, also ist der Fehler in der Kommunikation des IE mit dem Proxy.

    Warum sollte der Schalter also nicht im Squid verborgen sein?
    Setz die Squidconfig auf "default", was passiert jetzt?

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Donnerstag, 10. Juli 2014 13:07
  • Horrido!

    Das haben wir bereits ausprobiert und sagen deshalb ganz klar: der Fehler liegt im IE11, irgendein Detail das geändert wurde.

    Ich hatte bereits 2012/2013 einen ähnlichen Fehler beim TMG in Verbindung mit IE9/IE10.

    Nach Monaten kam ein Update von MS (4/2013), dann lief alles.

    Wir haben die Squid-Implementierung wirklich komplett zerlegt! Auch der Firefox macht keine Probleme in Verbindung mit dem Squid und bestimmten Seiteninhalten.

    Bei der Seite "cosinus sinus" von Wikipedia machen Bilderlinks

    wie hier

    http://upload.wikimedia.org/math/8/4/2/842e45d0d175d9a76d29e68b37b73f44.png

    die Probleme.

    Es wird alles geladen, nur die png´s bleiben unvollständig.

    Könnte hier evtl. ein DNS-Antwortproblem eine Rolle spielen?

    mfg

    re

    Donnerstag, 10. Juli 2014 13:38
  • Ich hab auch mit jeder neuen IE-Version Spass - aber im SAP-Umfeld.

    Folgendes kann ich dir zum Versuch empfehlen:

    • Einstellungen der Kompatibilitätsansicht
    • Dokumentenmodus (F12, links ganz nach unten scrollen)
    • Zoneneinstellungen

    Da muss man mal ein bisschen herumprobieren und auch offensichtlich unlogische Dinge ausprobieren. (Ich kann zum Beispiel auf bestimmte lokale HTML-Dateien nur über einen UNC-Namen in der Form \\localhost\D$\... erfolgreich zugreifen, sonst wird nichts angezeigt. Aber das hat nichts mit deinem Problem zu tun.)


    • Bearbeitet mslux Donnerstag, 10. Juli 2014 15:16
    Donnerstag, 10. Juli 2014 15:16
  • hm ...

    Am 10.07.2014 15:38, schrieb Jenny Frank:

    Das haben wir bereits ausprobiert und sagen deshalb ganz klar: der Fehler liegt im IE11,

    Kann es am Trackingschutz liegen? Dann werden schon im IE10 div. Seiten "hässlich" dargestellt, zB. Amazon

    What's New in Internet Explorer 11
    http://technet.microsoft.com/en-us/ie/dn269977.aspx
    -> Do Not Track (DNT) exceptions ...

    Internet Explorer 11: Handbuch für Entwickler
    http://msdn.microsoft.com/library/ie/bg182636(v=vs.85)


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Donnerstag, 10. Juli 2014 18:27
  • Hallo Mark,

    danke für deine Bemühungen.

    Nach dem Entwicklerhandbuch könnte ich spekulieren, dass der unvollständige "Bilderaufbau" etwas mit neuen Features zu tun hat.

    Aber wie soll ich das prüfen? Wäre es seitens MS nicht besser und fair, einfach zu sagen: Wer IE11 unter Win 7 nutzt, der soll zum Erzielen bestmöglicher Kompatibilität den Win7-Kompatibiltätsmodus einschalten, wer noch geringere Ansprüche hat, noch eine Stufe niedriger wählen. Wenn gar nichts geht, kann ich dann ja auf den FF wechseln oder noch tagelang mit dem IE herumbasteln.

    Gibt es ein To-Do um den IE11 möglichst umfassend und sicher dem IE10 kompatibel zu machen?

    mfg

    re

    Freitag, 11. Juli 2014 12:10
  • Am 11.07.2014 14:10, schrieb Jenny Frank:

    Gibt es ein To-Do um den IE11 möglichst umfassend und sicher dem IE10
    kompatibel zu machen?

    Was soll ich sagen? Ich habe schon diverse IE11 hinter Proxy Servern gehabt, die können das alle. Vielleicht ist der Squid ja einfach in der Entwicklung hinterher?

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Freitag, 11. Juli 2014 18:26