none
Exchange 2010 externer Autodiscover RRS feed

  • Frage

  • Hallo zusammen, ich habe aktuelle ein Problem mit dem Autodiscover.

    Im Einsatz ist ein Exchange 2010. Seit kurzem kann Outlook 2013 von extern nicht mehr via Autodiscover konfiguriert werden.
    Die interne und externe URL für den Autodiscover sind korrekt gesetzt.
    Outlook Web App läuft auch ohne Fehler.

    Als externen host verwenden wir remote.xyz.eu
    Für diesen Host ist auch eine SSL Zertifikat vorhanden und beim Aufruf von Outlook Web App erscheint auch keine SSL Fehlermeldung.

    Wenn ich nun die Verbindung mit dem Microsoft Remote Connectivity Analyzer teste fällt mir folgendes auf.
    Das Tool prüft nicht gegen die korrekte URL remote.xyz.eu sondern gegen xyz.eu/autodiscover/autodiscover.xml.

    Der Hosteintrag ist korrekt beim Provider gesetzt und zeigt auch auf die öffentlich IP.

    Wenn ich zum Test den Hosteintrag autodiscover.xyz.eu anlegen und auf die öffentlich IP zeigen lassen, dann lässt sich Outlook einrichten. Da es für diesen host einen SSL Zertifikat gibt, kommt dann natürlich ständig ein Zertifikatsfehler im Outlook.

    Hat jemand eine Idee, warum hier nicht mehr gegen den ursprünglichen Hostnahmen geprüft wird, der als externe Autodiscover URL hinterlegt ist.

    Freitag, 29. Januar 2016 15:37

Antworten

  • Moin,

    du brauchst in der Regel 2 Namen im Zertifikat, autodiscover.domain.tld und bei dir noch zusätzlich remote.domain.tld.

    Wenn du intern auch noch Split-DNS eingerichtet hast, sollten interne und externe URL gleich sein.

    Ist das Zertifikat von extern signiert?

    Ist das ein SBS, welchen Stand hat der Exchange?
    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    ;)


    Gruß Norbert

    Samstag, 30. Januar 2016 15:19
    Moderator
  • Moin,

    und um noch mal die eigentlich Frage zu beantworten:

    > Hat jemand eine Idee, warum hier nicht mehr gegen den ursprünglichen Hostnahmen geprüft wird, der als externe Autodiscover URL hinterlegt ist.

    Die Einstellung hatte noch nie eine Wirkung. Die Interne und die Externe URL im Autodiscover-VDir werden nirgendwo verwendet und müssen daher auch nicht konfiguriert werden.

    Interne Clients (AD-Client im internen Netz) nehmen den sog. "Service Connection Point", den sich aus AD mitgeteilt bekommen.

    Bei Nachdenken ist es auch logisch, denn vorher soll irgendein Client, der nur die Mail-Adresse kennt, darauf kommne "remote.*" auszuprobieren.

    Stattdessen probieren alle anderen Clients beim Autodiscover-Vorgang eine der Adresse "maildomain.xxx/...." und "autodiscover.maildomain.xxx/". Das ist fest hinterlegt.

    Entweder nimmst Du Autodiscover mit ins Zertifikat auf oder Du legst einen SRV-Eintrag im DNS dafür an, das mögen aber manche Smartphones nicht.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Sonntag, 31. Januar 2016 11:55

Alle Antworten

  • Moin,

    du brauchst in der Regel 2 Namen im Zertifikat, autodiscover.domain.tld und bei dir noch zusätzlich remote.domain.tld.

    Wenn du intern auch noch Split-DNS eingerichtet hast, sollten interne und externe URL gleich sein.

    Ist das Zertifikat von extern signiert?

    Ist das ein SBS, welchen Stand hat der Exchange?
    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    ;)


    Gruß Norbert

    Samstag, 30. Januar 2016 15:19
    Moderator
  • Moin,

    und um noch mal die eigentlich Frage zu beantworten:

    > Hat jemand eine Idee, warum hier nicht mehr gegen den ursprünglichen Hostnahmen geprüft wird, der als externe Autodiscover URL hinterlegt ist.

    Die Einstellung hatte noch nie eine Wirkung. Die Interne und die Externe URL im Autodiscover-VDir werden nirgendwo verwendet und müssen daher auch nicht konfiguriert werden.

    Interne Clients (AD-Client im internen Netz) nehmen den sog. "Service Connection Point", den sich aus AD mitgeteilt bekommen.

    Bei Nachdenken ist es auch logisch, denn vorher soll irgendein Client, der nur die Mail-Adresse kennt, darauf kommne "remote.*" auszuprobieren.

    Stattdessen probieren alle anderen Clients beim Autodiscover-Vorgang eine der Adresse "maildomain.xxx/...." und "autodiscover.maildomain.xxx/". Das ist fest hinterlegt.

    Entweder nimmst Du Autodiscover mit ins Zertifikat auf oder Du legst einen SRV-Eintrag im DNS dafür an, das mögen aber manche Smartphones nicht.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Sonntag, 31. Januar 2016 11:55