none
E2k10 defekte Mailbox RRS feed

  • Frage

  • Hallo,

    ich hatte heute Nacht das Problem, das der virtuelle Speicher auf dem Mailboxserver voll lief (Verursacht durch eine hängende Exchangesicherung), was zur Folge hatte, das die O2k10 Clients sich nicht mehr zur DB connecten konnten. Nach einem Neustart des Mailboxservers funktionierten die Outlook Connects wieder.

    Allerdings habe ich einen User, der keine Verbindung mehr zu seinem Postfach herstellen kann. Mailboxmove schlug direkt mit Fehler auf (trotz das ich angegeben hatte, das 50Fehler ignoriert werden sollen).
    Dann kam ich auf die Idee, das Postfach des Users zu disablen um es dann wieder einzubinden, doch leider erscheint es nicht unter "Disconnected Mailboxes" um es wieder verbinden zu können.

    Hat jemand eine Idee wie man das Postfach wieder einbindet, bzw. reparieren kann?

    Leider kann ich die Fehlermeldungen nicht mehr generieren, da ich ja das Postfach disabled habe und mir zuvor keine Screenshots gemacht habe!

    Danke!

    Montag, 22. April 2013 10:40

Alle Antworten

  • Eine Fehlermeldung war:

    exchange 2010 mapiexceptionlogonfailed unable to open message store

    Montag, 22. April 2013 10:44
  • Hallo,

    Use the Clean-MailboxDatabase cmdlet to scan Active Directory for disconnected mailboxes that aren't yet marked as disconnected in the Microsoft Exchange store and update the status of those mailboxes in the Exchange store. This cmdlet isn't able to update the Exchange store unless the Microsoft Exchange Information Store service is running and the database is mounted.

    Viele Grüße


    Philipp Halbedel

    MCP 2003,MCITP EA Server 2008,MCITP EA Windows 7,MCSA2008,MCSA2012 

    Meine Antwort war hilfreich? ich freu mich über eine Bewertung. If my answer was helpful, I'm glad about a rating! 

    I do not represent the organisation I work for, all the opinions expressed here are my own.

    Montag, 22. April 2013 10:46
  • Danke,

    jetzt habe ich sie erstmal wieder einbinden können, aber man kann sich nicht darauf connecten und ein move schlägt mit folgendem Fehler fehl:

    Hat jemand eine Idee wie man das wieder reparieren kann?

    Danke!


    Montag, 22. April 2013 14:03

  • Montag, 22. April 2013 14:03
  • Hi Paulchen Panther,

    <http://social.technet.microsoft.com/Forums/getfile/275182>

    es wäre mal ganz interessant zu wissen, welche Version du genau einsetzt:
    http://support.microsoft.com/kb/2682047

    Was zeigen dir die EventLog für Fehler - da gibt es bestimmt einige.

    Ist der User auch wirklich aktiviert und nicht ausversehen deaktiviert?

    Sind die Datenbanken wirklich alle gemountet oder ist vielleicht doch ein Offline? Get-MailboxDatabase -status


    Viele Grüße
    Christian

    Montag, 22. April 2013 17:41
    Moderator
  • Hallo Christian,

    danke für deine Antwort!

    User ist nicht gesperrt und die DBs sind online, habe ich kontrolliert und außerdem hätten dann ca. 120 andere User auch das Problem, was sie aber z.Z. nicht haben!

    Version ist 14.02.0328.009 GUI  14.02.247.5 Systemsteuerung

    Ich bin der Meinung das wir SP2 RU3 installiert haben. Kann ich das genau herausbekommen? Powershell?

    Im Eventlog finde ich keinen Hinweis, auch nicht über den BPA.

    Wenn ich in dem Postfacheigenschaften auf das Register Calendar Settings klicke erhalte ich folgenden Fehler:

    Cannot open Mailbox .../cn=serverMBX/cn=Microsoft System Attendant. It was running the command get-calendar processing -identity ..../Users/Test.bauer -ReadFromDomainController.

    Montag, 22. April 2013 19:48
  • Hi Paulchen Panther,

    User ist nicht gesperrt und die DBs sind online, habe ich kontrolliert und außerdem hätten dann ca. 120 andere User auch das Problem, was sie aber z.Z. nicht haben!

    iO.

    Version ist 14.02.0328.009 GUI  14.02.247.5 Systemsteuerung

    Du bist irgendwo bei SP2: http://www.blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    Ich bin der Meinung das wir SP2 RU3 installiert haben. Kann ich das genau herausbekommen? Powershell?

    siehe Link.

    Im Eventlog finde ich keinen Hinweis, auch nicht über den BPA.

    Wenn ich in dem Postfacheigenschaften auf das Register Calendar Settings klicke erhalte ich folgenden Fehler:

    Cannot open Mailbox .../cn=serverMBX/cn=Microsoft System Attendant. It was running the command get-calendar processing -identity ..../Users/Test.bauer -ReadFromDomainController.

    Du könntest noch einen New-MailboxRepairRequest starten, aber dann wird es eng.

    Kannst du die Mailbox exportieren? Du könntest Sie wieder trennen, den User emailaktivieren, sodass er eine neue bekommt und schauen, ob diese läuft. Wenn ja, dann importrequest und laufen lassen. LegacyDN dabei noch prüfen.

    Hast du dir mal die Eigenschaften des Accounts angeschaut und mit anderen verglichen. Vielleicht deaktivierst du den Account einmal und aktivierst ihn wieder:
    Get-MailboxStatistics -Database MBD01 | Where { $_.DisconnectReason -eq "Disabled" } | Format-List LegacyDN, DisplayName, MailboxGUID,

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/b8c55f32-eebb-4c85-80b4-03b40d53db1d


    Viele Grüße
    Christian

    Dienstag, 23. April 2013 05:35
    Moderator
  • Hallo Christian,

    danke für die Antwort!

    Version ist 14.2.328.10 und laut deiner Liste SP5 RUP5. Somit sollte dein Artikel nicht passen, trotz das das Verhalten passt.

    Heute Morgen konnte ich wieder auf das Postfach zugreifen, das ich gestern einem anderen User zugewiesen hatte, da ich dem ursprünglichen User ein funktionsfähiges Postfach geben musste. Zu verdanken habe ich das wohl dem Maintenancejob, der Nachts läuft. (Keine Ahnung welcher Teil der Maintenance dafür zuständig ist)

    Dann war ich so schlau und habe das alte und neue Postfach getrennt und wollte das alte wieder dem ursprünglichen User zuweisen und prompt habe ich wieder die Fehlermeldungen. Sowohl beim alten als auch beim neuen temp. Postfach. Also heißt es wieder auf den Maintenancejob warten. Dann werde ich morgen (wenn es wieder funktionieren sollte) den Postfachinhalt exportieren und in das nun wieder neu erstellte Postfach kopieren.

    Mir stellt sich nun die Frage,warum ich getrennte Postfächer nicht mehr einbinden kann, ohne das die nächtliche Wartung drüber gelaufen ist. Irgendwas scheint an der DB nicht mehr zu stimmen! Nur was und wie kann ich das beheben? Ob die Installation von SP3 etwas bringt, welche noch aussteht?

    zu:
    Kannst du die Mailbox exportieren? Du könntest Sie wieder trennen, den User emailaktivieren, sodass er eine neue bekommt und schauen, ob diese läuft. Wenn ja, dann importrequest und laufen lassen. LegacyDN dabei noch prüfen.
    Habe ich im Prinzip gemacht, nur das Importieren wollte ich mir sparen und die Mailboxen kreuz tauschen, nur seit deren Trennung gehen beide nicht mehr.
    Wenn denn die Wartung hoffentlich den Fehler wieder beheben sollte, wie exportiere ich die dann? (importrequest?) Ich hätte mir beide Postfächer verbunden und händisch verschoben!

    zu:
    Hast du dir mal die Eigenschaften des Accounts angeschaut und mit anderen verglichen. Vielleicht deaktivierst du den Account einmal und aktivierst ihn wieder:

    Ich habe die Rechte verglichen, da ich das Problem aber nach dem Kreuztausch auch mit dem Testaccount habe dürfte es nicht am Userobjekt liegen! Evtl. liegt es nur an dieser DB? Ich teste es mal mit einer anderen.

    Get-MailboxStatistics -Database MBD01 | Where { $_.DisconnectReason -eq "Disabled" } | Format-List LegacyDN, DisplayName, MailboxGUID, Disconnectreason zeigt an das es disabled wurde.

    Dienstag, 23. April 2013 10:42
  • Hi Paulchen Panther,

    Wenn denn die Wartung hoffentlich den Fehler wieder beheben sollte, wie exportiere ich die dann? (importrequest?) Ich hätte mir beide Postfächer verbunden und händisch verschoben!

    New-MailboxExportRequest
    New-MailboxImportRequest

    Mit dem einen schiebst du es in eine PST und mit dem anderen holst du es wieder rein:
    http://technet.microsoft.com/de-de/library/ff459227(v=exchg.141).aspx

    Get-MailboxStatistics -Database MBD01 | Where { $_.DisconnectReason -eq "Disabled" } | Format-List LegacyDN, DisplayName, MailboxGUID, Disconnectreason zeigt an das es disabled wurde.

    Kannst du nochmal Clean-MailboxDatabase laufen lassen und die Mailbox-Permission prüfen:
    Get-MailboxPermission USER| fl Identity,User,AccessRights,Isinherited,Deny

    Schau dir auch einen anderen User an und poste mal die anonymen Ergebnisse.


    Viele Grüße
    Christian

    Dienstag, 23. April 2013 16:45
    Moderator
  • Hallo Christian,

    danke für die Unterstützung. Im Vergleich mit anderen Usern kann ich keinen Unterschied feststellen. Anbei die Ausgabe: 

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : NT AUTHORITY\SELF
    AccessRights : {FullAccess, ReadPermission}
    IsInherited  : False
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Service.UMS
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Service.BESAdmin
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Domain Admins
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : True

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Enterprise Admins
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : True

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Organization Management
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : True

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\x.Master
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : True

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Exchange Servers
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Exchange Domain Servers
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Organization Management
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Public Folder Management
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Service.Faxination
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\System.FaxinationXY
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\MRE-7F3BB9C312C3
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : NT AUTHORITY\SYSTEM
    AccessRights : {FullAccess}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : NT AUTHORITY\NETWORK SERVICE
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Exchange Domain Servers
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Exchange Servers
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Service.BESAdmin
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Delegated Setup
    AccessRights : {ReadPermission}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Exchange Services
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Organization Management
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Exchange Trusted Subsystem
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\x.Master
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Enterprise Admins
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Identity     : XYZ.LOCAL/ORG/XY/Users/ Melanie
    User         : XYZ\Domain Admins
    AccessRights : {FullAccess, DeleteItem, ReadPermission, ChangePermission, ChangeOwner}
    IsInherited  : True
    Deny         : False

    Mittlerweile konnte ich wieder auf die Postfächer zugreifen und die Dateien manuell verschieben, von daher kann die Kollegin wieder wie gewohnt arbeiten.

    Nun habe ich mal ein Postfach eines Users aus einem anderen Store gelöscht und wieder reconnected und das geht auch nicht. Wenn ich mich dann nämlich mit Outlook verbinden will, dann bekomme ich folgenden Fehler:" Diese Ordnergruppe kann nicht geöffnet werden. Fehler bei der Anmeldung bei MS Exchange"

    Wenn ich auf das Register Calendar Settings klicke bekomme ich auch hier den Fehler:

    Cannot open Mailbox .../cn=serverMBX/cn=Microsoft System Attendant. It was running the command get-calendar processing -identity ..../Users/Test.bauer -ReadFromDomainController.

    Kann es sein, das es gar nicht an den DBs und einem notwendigen Integritätscheck liegt sondern einfach daran, das dass AD es noch nicht mitbekommen hat, das das Postfach wieder verbunden wurde?  Es muss also irgendwie an der Kommunikation ActiveDirectoryDriver und ADAccess liegen.
    Kann ich das manuell antriggern?

    Danke!

     

    Mittwoch, 24. April 2013 08:59
  • Hi Paulchen Panther,

    du bist nicht ganz aktuell und SP3 ist stabil.

    Kann es sein, das es gar nicht an den DBs und einem notwendigen Integritätscheck liegt sondern einfach daran, das dass AD es noch nicht mitbekommen hat, das das Postfach wieder verbunden wurde?  Es muss also irgendwie an der Kommunikation ActiveDirectoryDriver und ADAccess liegen.
    Kann ich das manuell antriggern?

    Welche DC bekommst du Get-DomainController und was steht im Event MSExchangeADAccess 2080?


    Viele Grüße
    Christian

    Mittwoch, 24. April 2013 19:59
    Moderator
  • Hallo Christian,

    alle Domaincontroller werden angezeigt.

    MSExchangeADAccess 2080:

    Process MAD.EXE (PID=2964). Exchange Active Directory Provider has discovered the following servers with the following characteristics:
    (Server name | Roles | Enabled | Reachability | Synchronized | GC capable | PDC | SACL right | Critical Data | Netlogon | OS Version)

    In-site:

    ADC000002.ADS.LOCAL CDG 1 7 7 1 0 1 1 7 1

    ADC000001.ADS.LOCAL CDG 1 7 7 1 0 1 1 7 1

    Out-of-site:

    ZADC000001.ADS.LOCAL CDG 1 7 7 1 0 1 1 7 1

    ZADC000002.ADS.LOCAL CDG 1 7 7 1 0 1 1 7 1

    Donnerstag, 25. April 2013 10:35