none
Exchange 2010 - Add-MailboxDatabaseCopy - Error: The network path was not found" RRS feed

  • Frage

  • Hello,

    I'm having two Exchange 2010 SP1 RUP2 Servers with Mailbox role installed. Both are members of a DAG. They are in two VLANs, one is a physical machine, one is virtualized with VMWare ESX 4.

    I can create DBs with both servers, but while adding a database copy from the virtual machine I'm getting the error: "The network path was not found". When doing this from the physical machine I'm having no problems with creating the db copy.

    There is absolutely nothing in the eventlog, even while setting diagnostic logging to expert on all services I think it could have something to do while adding a mailbox database copy.

    Right now I'm out of ideas, because we had no issues within the test network.

    Kind regards

    L1683

    Montag, 3. Januar 2011 09:05

Antworten

  • Hallo,

    das Problem hat sich gelöst. Der physikalische Server hatte ein RAM Problem. Jetzt ist die Kiste wieder fit, Windows und Exchange sind neu und siehe da es geht.

    Vielen Dank für die Antworten.

    L1683

    Donnerstag, 6. Januar 2011 10:09

Alle Antworten

  • Hi L1683,

    schau dir mal die Netzwerkkonfiguration etwas genauer an und poste einmal
    ipconfig /all von allen Exchange Servern:

    ...vor allem die NIC-Vorraussetzungen:
    http://technet.microsoft.com/en-us/library/dd638104.aspx

    Ich vermute, dass das Problem da begraben liegt. Hier gibt es auch einen
    ähnlichen Fall:
    http://social.technet.microsoft.com/Forums/en/exchange2010/thread/e72d0403-6be7-44a1-9935-40c4aee47734

    Viele Grüße
    Christian

    Montag, 3. Januar 2011 09:24
    Moderator
  • Hi Christian,

    ich habe nur eine NIC aber die Config sieht richtig aus. Auch die Netwerk Dienste sind so wie von MS gefordert. Unten dann noch die DAG.

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : physical Server
       Primary Dns Suffix  . . . . . . . : a.b.c
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : a.b.c


    Ethernet adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Failover Cluster Virtual Adapter
       Physical Address. . . . . . . . . : 02-1A-64-99-C4-64
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::4d3:4e6c:9180:8c75%15(Preferred)
       IPv4 Address. . . . . . . . . . . : 169.254.2.87(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 369236580
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-AC-E0-9B-00-1A-64-99-C4-64
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection 2:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE (NDIS VBD Client) #2
       Physical Address. . . . . . . . . : 00-1A-64-99-C4-66
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : a.b.c
       Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE (NDIS VBD Client)
       Physical Address. . . . . . . . . : 00-1A-64-99-C4-64
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 172.28.4.15(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.252.0
       IPv4 Address. . . . . . . . . . . : 172.28.4.10(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.252.0
       Default Gateway . . . . . . . . . : 172.28.4.1
       DNS Servers . . . . . . . . . . . : 172.28.24.12
                                           172.28.24.11
       NetBIOS over Tcpip. . . . . . . . : Enabled
      
      
      
      
    Windows IP Configuration

       Host Name . . . . . . . . . . . . : virtual Server
       Primary Dns Suffix  . . . . . . . : a.b.c
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : a.b.c


    Ethernet adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Failover Cluster Virtual Adapter
       Physical Address. . . . . . . . . : 02-50-56-B7-40-FE
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::74d7:9fb1:efb9:ee6%13(Preferred)
       IPv4 Address. . . . . . . . . . . : 169.254.1.145(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 302141526
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-49-AF-1A-00-50-56-B7-40-FE
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : a.b.c
       Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
       Physical Address. . . . . . . . . : 00-50-56-B7-40-FE
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 172.28.24.15(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.252.0
       Default Gateway . . . . . . . . . : 172.28.24.1
       DNS Servers . . . . . . . . . . . : 172.28.24.12
                                           172.28.24.11
       NetBIOS over Tcpip. . . . . . . . : Enabled
     
     
      
    Get-DatabaseAvailabilityGroup | fl

    Name                                   : B-DAG-001

    NetworkCompression                     : InterSubnetOnly
    NetworkEncryption                      : InterSubnetOnly
    DatabaseAvailabilityGroupIpv4Addresses : {172.28.24.10, 172.28.4.10}
    DatabaseAvailabilityGroupIpAddresses   : {172.28.24.10, 172.28.4.10}
    AllowCrossSiteRpcClientAccess          : False
    OperationalServers                     :
    PrimaryActiveManager                   :
    ServersInMaintenance                   :
    ThirdPartyReplication                  : Disabled
    ReplicationPort                        : 0
    NetworkNames                           : {}
    WitnessShareInUse                      :
    AdminDisplayName                       :
    ExchangeVersion                        : 0.10 (14.0.100.0)
    IsValid                                : True

     

    Montag, 3. Januar 2011 10:31
  • HI,

    der Failover-Cluster - Adapter hat keine richtige IP. Entferne das Netz mal aus der Konfig (Powershell / EMC) und disable die Adapter. Funktioniert das dann? Exchange 2010 kann auch über nur eine Netzwerkkarte betrieben werden (Was ich den meisten Kunden die keinen Engpass beim Netzwerk haben empfehlen würde. Kiss, wie Keep it simple stupid).

    funktioniert es dann?


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Montag, 3. Januar 2011 10:37
    Moderator
  • Hallo,

    sowie ich den Failover Cluster Virtual Adapter disable dismounted die Datenbank auf dem Server. Und die anderen lassen sich nicht mehr aktivieren, werden aber als healthy angezeigt. Die Funktionen sind erst wieder da, wenn sich der Adapter wieder eine APIPA Adresse verpasst hat.

    Aber hier könnte der Hase im Pfeffer liegen, wenn ich die Cluster MMC öffne und auf den Cluster verbinden will, soll ich die Remote Registry starten. Allerdings läuft der Dienst... Das verhalten ist auf beiden Systemen gleich. Nur in der Testumgebung gehts, da ist aber alles auch in einem Netz.

    Viele Grüße

    L1683

     

    Montag, 3. Januar 2011 11:12
  • Hi,

    ja, du mußt das Netz erst "wegkonfigurieren" bevor du den Adapter disablest. Hatte ich aber so geschrieben.

     


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Montag, 3. Januar 2011 12:00
    Moderator
  • Hi,

    irgendwie stehe ich gerade auf dem Schlauch, im Exchange sind nur die real existierenden Netze konfiguriert, wie konfiguriere ich den den Failoveradapter im Exchange weg?

    Gruß

    L1683

    Montag, 3. Januar 2011 12:55
  • Hi,

    mit der Powershell: get-databaseavailabilitygroupnetwork ....

    dann remove-databaseavailabilitygroupnetwork...

    Sollte klappen.


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Montag, 3. Januar 2011 13:41
    Moderator
  • Hi,

    ist das Problem noch existent?


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Dienstag, 4. Januar 2011 08:32
    Moderator
  • Hi,

    schon, aber ich habe gerade herausgefunden, das RUP2 nicht sauber auf dem physikalischen Server installiert wurde. Eventlog und Update History behauptenten zwar das Gegenteil aber ein anderes Setup hat angezeigt, dass das RUP2 Setup suspendet ist.

    Also erstmal diese Baustelle machen, sonst hat das ja weiter keinen Sinn.

    Vielen Dank

    L1683

    Dienstag, 4. Januar 2011 10:53
  • Hallo,

    das Problem hat sich gelöst. Der physikalische Server hatte ein RAM Problem. Jetzt ist die Kiste wieder fit, Windows und Exchange sind neu und siehe da es geht.

    Vielen Dank für die Antworten.

    L1683

    Donnerstag, 6. Januar 2011 10:09
  • Hi L1683,

    das Problem hat sich gelöst. Der physikalische Server hatte ein RAM Problem. Jetzt ist die Kiste wieder fit, Windows und Exchange sind neu und siehe da es geht.

    der eigentliche Fehler vom Exchange wird wohl durch die Neuinstallation von BS
    und Exchange behoben worden sein.

    Viele Grüße
    Christian

    Freitag, 7. Januar 2011 05:42
    Moderator