none
RemoteApp mit Com-Port funktioniert nicht, in Remotedesktopsitzung funktioniert es RRS feed

  • Frage

  • Hallo zusammen,

    wie der Titel schon sagt, habe ich Probleme mit der Nutzung von RemoteApp.

    Seit Server 2003 habe ich die Anwendung in W2k und WXP über die Remotedesktopverbindung gestartet und in den Clientoptionen den Programmpfad angegeben, sodass nur die ensprechende Anwendung startete. Den ComPort kann man nach wie vor in "Lokale Resourcen -> Wetere..." anhaken. Dieser funktioniert auch auf diesem Weg.

    In den neuen Clients ist der Tab für den Programmpfad nicht mehr vorhanden, da seit Server 2008 das RemoteApp Feature existiert, das auch  dank RemoteFX in Server 2012 ganz toll läuft.

    Leider funktioniert hier aber die Weterleitung des ComPorts nicht.

    Im RemotedesktopGateway-Manager auf dem Server 2012 R2 ist in den Richtlinien die "Geräteumleitung für alle Clientgeräte aktiviert". Auch ein umstellen auf die Auswahlmöglichkeit nur die Ports weiterzuleiten funktioniert nicht.

    Lassen sich die Client Programmname(Work Resources).rdp Dateien irgendwie editieren?

    Bei mir öffnet sich da nur ein Fenster in dem ich außer Abbrechen und Hilfe nichts eingeben oder anklicken kann...

    Achja,da fehlt noch was:

    Client Betriebssystem ist Windows 10 Pro Build 1511; mstsc.exe Version 10.0.10586.0

    Danke für Eure Bemühungen

    Gruß Christian


    • Bearbeitet Fjury85 Samstag, 12. Dezember 2015 09:45 Angabe zum Client BS
    Samstag, 12. Dezember 2015 09:34

Antworten

  • Lösung gefunden!

    In den folgenden zwei Schlüsseln die Zeichenfolge in RDPFileContents anpassen, sodass jeweils redirectcomports:i:1 statt :0 enthalten ist:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedResources\PublishedFarms\QuickSessionCollection\DeploymentSettings

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedResources\PublishedFarms\QuickSessionCollection\RemoteDesktops\QuickSessionCollection

    Danach evtl. bereits veröffentlichte RemoteApp Programme im Server-Manager aufheben und direkt wieder neu erstellen.

    Dann wird die Signatur entsprechend der Vorgaben in der Registry (DeploymentSettings) erstellt und die RemoteApp kommuniziert mit eurem ComPort

    Ihr müsst danach auf dem Client PC in der Systemsteuerung die RemoteApp- und Desktopverbindungen -> "Work Resources" Eigenschadften -> Aktualisieren anklicken

    Wäre schön, wenn Microsoft den einen Haken dem Server-Manager wieder hinzufügen könnte, denn im RemoteGateway-Manager ist auch noch ein Haken für Comports vorhanden, der mir aber ohne Haken im Server-Manager als sinnlos erscheint....

    Schönes Wochenende

    • Als Antwort markiert Fjury85 Samstag, 12. Dezember 2015 11:32
    Samstag, 12. Dezember 2015 11:32

Alle Antworten

  • Da läuft doch irgendetwas schief bei der Bereitstellung, oder?

    Die .rdp Files lassen sich im Editor öffnen, jedoch nach dem speichern nicht mehr öffnen, da die Datei dann angeblich beschädigt ist.  Irgendeine Art Checksumme die nach dem Editieren neu generiert werden muss?

    PROBLEM: Alle redirects sind bei den "Work Resources" aktiv, jedoch nicht die einzig und allein benötigten comports!!!!!!!

    redirectclipboard:i:1
    redirectprinters:i:1
    redirectcomports:i:0
    redirectsmartcards:i:1
    devicestoredirect:s:*
    drivestoredirect:s:*
    redirectdrives:i:1



    • Bearbeitet Fjury85 Samstag, 12. Dezember 2015 09:53
    Samstag, 12. Dezember 2015 09:52
  • Wenn ich auf dem Server 2012 R2 die RDPFileContents in der registry öffne und dort redirectcomports:i:0 in :1  ändere, bekomme ich ebenfalls die Meldung, dass die RDP-Datei beschädift ist.

    Lösche ich in der RDP-Datei den Parameter signature:....... mus sich zwar die Echtheit bestätigen, aber redirectcomports:i:1 funktioniert und der comport wird auch in der RemoteApp bereitgestellt.

    Wie kann ich die Signatur neu erstellen?

    Ich denke im Server-Manager fehlt einfach ein Haken, den Microsoft (absichtlich???) vergessen hat

    Server-Manager -> Remotedesktop-Dienste -> Sammlungen -> (QuickSessionCollection) Eigenschaften -> Clienteinstellungen

    In Server 2008 scheint es diesem Beitrag nach noch funktioniert zu haben....

    https://social.technet.microsoft.com/Forums/en-US/312d26c8-0d42-4dbe-8099-252df26c8493/remoteapp-will-not-redirect-com-port-4?forum=winserverTS

    Gibt es eine Möglichkeit diese Anfrage an Microsoft zu senden?

    Samstag, 12. Dezember 2015 10:58
  • Lösung gefunden!

    In den folgenden zwei Schlüsseln die Zeichenfolge in RDPFileContents anpassen, sodass jeweils redirectcomports:i:1 statt :0 enthalten ist:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedResources\PublishedFarms\QuickSessionCollection\DeploymentSettings

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedResources\PublishedFarms\QuickSessionCollection\RemoteDesktops\QuickSessionCollection

    Danach evtl. bereits veröffentlichte RemoteApp Programme im Server-Manager aufheben und direkt wieder neu erstellen.

    Dann wird die Signatur entsprechend der Vorgaben in der Registry (DeploymentSettings) erstellt und die RemoteApp kommuniziert mit eurem ComPort

    Ihr müsst danach auf dem Client PC in der Systemsteuerung die RemoteApp- und Desktopverbindungen -> "Work Resources" Eigenschadften -> Aktualisieren anklicken

    Wäre schön, wenn Microsoft den einen Haken dem Server-Manager wieder hinzufügen könnte, denn im RemoteGateway-Manager ist auch noch ein Haken für Comports vorhanden, der mir aber ohne Haken im Server-Manager als sinnlos erscheint....

    Schönes Wochenende

    • Als Antwort markiert Fjury85 Samstag, 12. Dezember 2015 11:32
    Samstag, 12. Dezember 2015 11:32