none
Autodiscovery funktioniert -Testtool von Microsoft findet lauter Fehler RRS feed

  • Frage

  • Hallo - ich bin dabei Tests mit der Autodiscovery Funktion von Exchange 2010 zu machen -

    Wenn ich einen externen Mail Client benutze - z.B. Apple Mail findet er inzwischen alle Serverdaten automatisch -ausser den Benutzernamen -der ist falsch - den muss man abkuerzen damit ein Login möglich ist

    Teste ich mit der Microsoft Webseite - 

    https://www.testexchangeconnectivity.com/

    und dem Test

    Exchange ActiveSync-AutoErmittlung

    lautet im Ergebniss der erste Fehlerhafte Eintrag

    Es wird versucht, die mögliche AutoErmittlungs-URL https://contoso.com/AutoDiscover/AutoDiscover.xml zu testen

    Dann versucht er

    Es wird versucht, die mögliche AutoErmittlungs-URL https://autodiscover.contoso.com/AutoDiscover.xml zu testen

    das klappt

    port 443 klappt

    auch ssl ist auch valide

    iis Clientzertifikatsauthentifizierung klappt auch

    doch dieser Schritt schlägt fehl

    Es wird versucht, dem AutoErmittlungsdienst eine Post-Anforderung zu senden, damit er URLs ggf. automatisch erkennen kann.

    Beim Senden der Post-Anforderungen für die Autoermittlung konnten keine Autoermittlungseinstellungen abgerufen werden

    ExRCA versucht, eine XML-Antwort des AutoErmittlungsdiensts von URL https://autodiscover.contoso.com/autodiscover(Autodiscover.xml für Benutzer xyz@contoso.com abzurufen

    Warum klappt das mit dem Client - aber der Remote Connectivity Analyzer meldet fast nur Fehler

    Viele Grüße Martin

    


    • Bearbeitet Martin2012 Mittwoch, 1. August 2012 14:00
    Mittwoch, 1. August 2012 13:12

Antworten

  • Ich verstehe es nicht - jetzt funktioniert sogar die Autoermittlung plötzlich(getestet mit dem Microsoft Remote Connectivity Analayzer) - das einzige was ich heute geändert habe war das ich folgenden Hotfix auf EX2003 eingespielt habe und den EX2003 neugestartet habe

    http://support.microsoft.com/kb/937031/en-us

    Ich habe noch nicht einmal die dann im KB Artikel notwendigen Veränderungen duchgeführt

    Da ich fast alles probiert habe - und in einem anderen Forum auf den Tip mit dem Hotfix gestossen bin -dachte ich einfach mal - schlimmer ganz nicht werden -und ich installiere trotz möglicher Probleme den Hotfix auf 2003

    Seltsam - wuesste nur gerne ob wirklich der Hotfix das Problem irgendwie gelöst hat- oder ob es doch an irgend etwas anderem gelegen hat


    • Bearbeitet Martin2012 Montag, 6. August 2012 08:09
    • Als Antwort vorgeschlagen Alex Pitulice Dienstag, 7. August 2012 14:20
    • Als Antwort markiert Alex Pitulice Mittwoch, 8. August 2012 07:58
    Montag, 6. August 2012 08:04

Alle Antworten

  • Hi Martin2012,

    falsche Benutzerdaten? Was sagt das IIS-Log zur Anfrage,

    Gibt es noch ein paar mehr Fehlerdetails?


    Viele Grüße
    Christian

    Donnerstag, 2. August 2012 06:35
    Moderator
  • Hallo - die Benuterdaten stimmen eigentlich - habe den Test 3 -4 mal laufen lassen - mit der Aussage Autodiscovery funktioniert war ich wohl ein wenig voreilig bzw. habe ich inzwischen Änderungen gemacht und kann im Nachhinein nicht feststellen welche Änderung zum jetzt von extern nicht mehr funktionierendem Autodiscovery geführt haben

    Evt waren wahrscheinlich diese Befehle

    remove-autodiscovervirtualdirectory -identity "EX2010\autodiscover (default web site)"
    new-autodiscovervirtualdirectory
    set-clientaccessserver -identity EX2010 -autodiscoverserviceinternaluri https://mail.meinedomaene.com/Autodiscover/Autodiscover.xml

    Port 80 ist von aussen nicht erreichbar (Firewall) nur Port 443

    IIS Log

    2012-08-02 07:42:42 meineip OPTIONS /AutoDiscover/AutoDiscover.xml - 443 - 207.46.14.52 Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 200 0 0 14009

    2012-08-02 07:42:42 meineIP POST /AutoDiscover/AutoDiscover.xml - 443 - 207.46.14.52 Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 401 0 0 535

    2012-08-02 07:42:42 meineIP POST /AutoDiscover/AutoDiscover.xml - 443 - 207.46.14.52 Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 401 1 2148074254 126

    2012-08-02 07:42:45 meineIP POST /AutoDiscover/AutoDiscover.xml - 443 meinedomaene\testbenutzer 207.46.14.52 Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 200 0 0 2851

    Viele Grüße Martin




    • Bearbeitet Martin2012 Donnerstag, 2. August 2012 08:10
    Donnerstag, 2. August 2012 08:00
  • Hi Martin2012,

    es ist jetzt der obere 1. Fehler und klappt es jetzt am Client oder nicht?

    Port 80 ist von aussen nicht erreichbar (Firewall) nur Port 443

    IIS Log

    POST /AutoDiscover/AutoDiscover.xml - 443 contoso\testbenutzer 207.46.14.63 Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 200 0 0 384

    Das sieht gut aus...


    Viele Grüße
    Christian

    Donnerstag, 2. August 2012 08:17
    Moderator
  • ach um den IIS neu zu starten um evt. Änderungen zu übernehmen benutzte ich immer

    IISRESET /NOFORCE

    Leider gibts dann immer eine Fehlermeldung

    IISReset.exe fails to stop the IIS services in a timely fashion

    usw.

    Lösung ist anscheinend

    NET STOP w3svc

    NET START w3svc

    Donnerstag, 2. August 2012 08:23
  • ach um den IIS neu zu starten um evt. Änderungen zu übernehmen benutzte ich immer

    IISRESET /NOFORCE

    Leider gibts dann immer eine Fehlermeldung

    IISReset.exe fails to stop the IIS services in a timely fashion

    usw.

    Lösung ist anscheinend

    NET STOP w3svc

    NET START w3svc

    Ja, weil IISRESET in Wahrheit nichts anderes macht, als die Dienste neuzustarten, aber nicht lange genug wartet. Du kannst auch über Dienste denn WWW-Dienst neustarten, ist am Ende das gleiche Resultat.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Donnerstag, 2. August 2012 08:58
  • Also unter OSX klappt die Autokonfiguration sowohl mit Apple Mail als auch mit Outlook 2011

    Ein Android Handy mit Moxier findet den richtigen Server leider nicht (alles von extern)

    Outlook anywhere habe ich nicht konfiguriert/aktiviert - Benutzt Outlook 2011 auf OSX evt. auch Active Sync ? Kann Outlook 2010 unter Windows das auch ?

    Donnerstag, 2. August 2012 09:26
  • Also ich habe den Fehler etwas eingrenzen  können - Problem ist evt. das ich 2 Adressdomänen habe

    eine EMail Domäne entspricht dem Domänennamen und eine EMail - Domäne hat einen komplett anderen Namen

    Nennen wir die

    Domäne 1 = Contoso.com

    Domäne 2 = andereDomäne

    Die Remoteverbindungsuntersuchung habe ich immer mit der 2. Domäne gemacht

    Autodiscover ist komplett konfiguriert auf email.contoso.com

    Falls ich Dann folgenden Link aufrufe für Domäne 1 erscheint ein login Fenster (ganz schlicht - nur Benutzername + Passwort)

    https://autodiscover.contoso.com/AutoDiscover/AutoDiscover.xml

    rufe ich hingegen

    https://autodiscover.anderedomane.777/AutoDiscover/AutoDiscover.xml

    auf erscheint das Webapp Login Fenster von Outlook

    Wie kann ich das umkonfigurieren ?

    PS: die 777 habe ich drangehängt damit der Thread nicht irgendwann mal auf eine echte Domäne verweist

    Donnerstag, 2. August 2012 12:07
  • Hallo, habe den Test mit der Remoteverbinungsuntersuchung auch mit einem User aus Domäne 1 gemacht - leider erhalte ich das gleich Ergbnis -die Test's laufen nicht Fehlerfrei durch - es ist das gleiche Bild wie bei Domäne 2


    • Bearbeitet Martin2012 Donnerstag, 2. August 2012 16:57
    Donnerstag, 2. August 2012 12:53
  • Hallo Martin,

    Hoert sich an als hast Du nun die Ursache gefunden. Sehr gut! Wie Du das nun aenderst liegt jetzt daran, wie Deine Server zum Internet veroeffentlicht sind. Hast Du einen TMG oder anderen Reverse-Proxy davor? Zeigt autodiscover.contoso.com und autodiscover.anderedomane.777 auf dieselbe externe IP Adresse?

    VG, Timo

    Donnerstag, 2. August 2012 19:58
    Moderator
  • Leider habe ich den Fehler immer noch nicht gefunden -aber ich kann noch ein paar Details beisteuern

    Ich habe als Benutzernamen auch den UPN probiert - leider hat das nichts gebracht

    Ich habe den Autodiscover Eintrag im DNS nicht mehr auf einen Cname verweisen lassen

    Weiterhin habe ich das komplette Autodisvery Verzeichnis auf dem IIS resettet

    ohne Erfolg

    Der Remote Connectivty Analayzer schreibt übrigens beim Fehler

    ExRCA versucht, eine XML-Antwort des AutoErmittlungsdiensts von URL usw.

    noch folgendes

    Von ExRCA konnte keine XML-Antwort von der AutoErmittlung abgerufen werden

    Das Antwortelement in der Nutzlast hatte den Wert NULL.
    <?xml version="1.0"?>

    autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006" /

    

    Freitag, 3. August 2012 06:45
  • Interssant ist übrigens noch folgendes

    Wenn ich den Active Sync Test online durchführe (nicht den Autodiscovery Test)- kommt ganz am Ende folgende

    Fehlermeldung

    Es wird versucht, eine ActiveSync-Sitzung mit dem Server zu starten

    Fehler beim Testen des OPTIONS-Befehls. Weitere Informationen finden Sie in den zusätzlichen Angaben

    Eine Antwort "HTTP 401 Nicht autorisiert" wurde vom IIS7-Remoteserver empfangen. Dies ist in der Regel die Folge eines falschen Benutzernamens oder Kennworts. Wenn Sie sich bei einem Office

    365-Dienst anmelden möchten, stellen Sie sicher, dass Sie Ihren vollständigen Benutzerprinzipalnamen verwendenDas gibt es doch nicht - mein Handy kann sich per Active Sync synchronisieren - Apple Mail und Outlook 2011 auch

    PS: die Serverdaten habe ich manuell eingegeben bei diesem Test

    • Bearbeitet Martin2012 Freitag, 3. August 2012 07:10
    Freitag, 3. August 2012 07:08
  • Hallo Martin,

    verrate uns doch bitte wie Deine Exchange Server ans Internet angebunden sind. Hast Du einen Reverse-Proxy davor, oder vielleicht eine Firewall die nur weiterleitet, oder oder oder. Du schreibst da irgendwas von CNAME geaendert... Bitte liefer uns doch vollstaendige Informationen, dann koennen wir Dir sicherlich schneller helfen.

    VG, Timo

    Freitag, 3. August 2012 07:23
    Moderator
  • Hallo - kein reverse Proxy + direkte Standleitung - PS: Ich kann es nicht glauben bei einem Benutzer ging zumindest der active sync Test erfolgreich durch -mit manueller Serverangabe im Benutzernamen war ein wiederholter Tipfehler

    Autoermittlung geht leider noch nicht

    Das tool ActiveSync Tester Diagnostic von accessmyLan sagt - Diagnosis - Failed to detect ActiveSync on the server specified

    Das mit dem cname ist so - ich hatte bisher einen autodiscover Eintrag mittels cname - welcher einfach auf den Host A Eintrag des Servers verwiesen hat

    Jetzt habe ich den Cname Eintrag gelöscht und einen A Record mit direkter IPAngabe erstellt

    Viele Grüße Martin

    Freitag, 3. August 2012 07:44
  • Habe jetzt extra port 80 freigeschaltet -dort  sieht die Fehlermeldung dann so aus wenn ich mit dem Remote Connectivity Analyzer teste

    rotes X

    AutoErmittlung von Host anderedomane.777 von ExRCA für HTTP-Umleitung zum AutoErmittlungsdienst überprüft

    Weitere Details

    Eine Antwort "HTTP 401 Nicht autorisiert" wurde vom Unknown-Remoteserver empfangen. Dies ist in der Regel die Folge eines falschen Benutzernamens oder Kennworts. Wenn Sie sich bei einem Office 365-Dienst anmelden möchten, stellen Sie sicher, dass Sie Ihren vollständigen Benutzerprinzipalnamen verwendenGrüße Martin

    Freitag, 3. August 2012 07:59
  • Wenn ich

    get-AutodiscoveryVirtualDirectory | fl eingebe erscheint beim Server welcher nicht funktioniert bei internal + external authenticationmethods

    basic, NTlm, windowsIntegrated

    bei einem Testserver

    Basic, NTLM, WindowsIntergrated, WSSecurity

    Könnte da der Fehler liegen ?

    Internal und external url sind dort nicht konfiguriert
    • Bearbeitet Martin2012 Freitag, 3. August 2012 08:58
    Freitag, 3. August 2012 08:55
  • hallo,

    wir hatte vor kurzem ein ähnliches Problem mit Outlook Anywhere.

    habe ich es richtig verstanden, dass du eine Mail Domäne hast, die dem externen DNS Namen deines MX entspricht und eine Mail Domäne lautet anders!?

    -gibt es auch die Autodiscover Hosts im externen DNS ?

    -sind die  autodiscover Namen auch im Zertifikat enthalten?

    -https Port 443 auf die externen autodiscover Hosts wird intern auf den Exchange geleitet?


    • Bearbeitet spectraler Freitag, 3. August 2012 09:13
    Freitag, 3. August 2012 09:11
  • habe ich es richtig verstanden, dass du eine Mail Domäne hast, die dem externen DNS Namen deines MX entspricht und eine Mail Domäne lautet anders!?

    Ja genau -
    Freitag, 3. August 2012 10:44
  • -gibt es auch die Autodiscover Hosts im externen DNS ?

    -sind die  autodiscover Namen auch im Zertifikat enthalten?

    -https Port 443 auf die externen autodiscover Hosts wird intern auf den Exchange geleitet?


    3 mal Ja
    Freitag, 3. August 2012 10:44
  • Seltsamerweise klappt es unter OSX Problemos -d.h. Autodiscovery funktioniert von extern einwandfrei

    Ein Android Handy mit Touchdown findet keine Konfiguration - Moxier auch nicht

    Freitag, 3. August 2012 10:47
  • hast du beim OSx Gerät und beim Android eine Mail Adresse verwendet, die einem  externen Host entspricht?

    Wenn du auf einem Mobiltelefon deine mail adresse angibst, sucht das Gerät natürlich nach einem Autodicover mit der Mail Domäne. Manche Geräte haben ein Problem mit bestimmten Zertifikaten.

    Ist dein Zertifikat selbst erstellt (vom eigenen Exchange oder eigene CA)?

    Hast du ein Zertifikat mit internen und externen Server-/Hostnamen?

    Freitag, 3. August 2012 12:12
  • euer OWA funktioniert?

    ich habe mal mit dem Remote analyzer unser Active Sync Autodiscover getestet und es funktioniert.

    bei uns ist es so, z.B. EMail Adresse user@email.com wobei der MX für email.com auf den host externer-firmenname.de verweist welcher auch ein Zertifikat (von einer externen öffentlichen CA hat) mit beiden Namen hat. Also u.a. email.com und externer-firmenname.de

    Auf dem Exchange unter Serverkonfig -> Clientzugriff sind bei der AS Einstellung beide URLs extern eingetragen https://externer-firmenname.de/Microsoft-Server-ActiveSync

    Freitag, 3. August 2012 12:31
  • Ist dein Zertifikat selbst erstellt (vom eigenen Exchange oder eigene CA)?

    Hast du ein Zertifikat mit internen und externen Server-/Hostnamen?

    Nein das Zerifikat ist ein Kaufzertifikat - beinhaltet beide Domänen jeweils auch mit autodiscover -kein Wildcard Zertifikat
    Freitag, 3. August 2012 13:33
  • euer OWA funktioniert?

    Owa funktioniert einwandfrei
    Freitag, 3. August 2012 13:34
  • Ich habe jetzt auch eine externe Url für activesync eingegeben und den iis neugestartet - keine Veränderung

    Wenn ich mich jetzt übrigens einlogge bei

    https://autodiscover.anderedomane.777/AutoDiscover/AutoDiscover.xml

    erscheint

    ErrorCode>600</ErrorCode><Message>Invalid Request

    auch bei der Hauptdomäne

    Das sollte richtig sein ? oder

    Freitag, 3. August 2012 13:59
  • Jetzt habe ich mal Ersatzweise die Outlook-AutoErmittlung probiert -die geht sofort - nur die Exchange ActiveSync-AutoErmittlung klappt weiterhin  nicht

    was allerdings klappt ist der Test

    Exchange ActiveSync

    Wie geht das denn ? dazu muss er doch auch die Auto ermittlung bemühen??

    sogar dieser Test klappt

    Synchronisierung, Benachrichtigung, Verfügbarkeit und automatische Antworten (Abwesenheitsnachrichten)

    ?? ich bin echt Ratlos

    • Bearbeitet Martin2012 Freitag, 3. August 2012 14:32
    Freitag, 3. August 2012 14:15
  • wenn ich unseren autodiscover URL eingebe, werde ich nach Benutzername und Kennwort gefragt!

    https://domainmx/AutoDiscover/AutoDiscover.xml

    Freitag, 3. August 2012 14:50
  • wenn ich unseren autodiscover URL eingebe, werde ich nach Benutzername und Kennwort gefragt!

    https://domainmx/AutoDiscover/AutoDiscover.xml

    ja klar -ich auch -danach kommt die Meldung
    Freitag, 3. August 2012 15:08
  • Hallo Martin,

    kannst Du bitte mal den Output von "Get-ActiveSyncVirtualDirectory | FL" hier posten. Lass auch mal den ExBPA laufen, vielleicht haengt da ja irgendwas ganz anderes quer.

    VG, Timo

    Samstag, 4. August 2012 19:46
    Moderator
  • Hallo Martin,

    kannst Du bitte mal den Output von "Get-ActiveSyncVirtualDirectory | FL" hier posten. Lass auch mal den ExBPA laufen, vielleicht haengt da ja irgendwas ganz anderes quer.

    VG, Timo

    Hallo - ja klar -hier der Output - (Eigene Domän und Servernamen wurden ersetzt-rundspaceid  + guid auch)



    RunspaceId                                 : 5b40600d-1dce-3473-8784-c7412347862f
    MobileClientFlags                          : BadItemReportingEnabled, SendWatsonReport
    MobileClientCertificateProvisioningEnabled : False
    BadItemReportingEnabled                    : True
    SendWatsonReport                           : True
    MobileClientCertificateAuthorityURL        :
    MobileClientCertTemplateName               :
    ActiveSyncServer                           : https://mail.contoso.com/Microsoft-Server-ActiveSync
    RemoteDocumentsActionForUnknownServers     : Allow
    RemoteDocumentsAllowedServers              : {}
    RemoteDocumentsBlockedServers              : {}
    RemoteDocumentsInternalDomainSuffixList    : {}
    MetabasePath                               : IIS://EX2010.contoso.com/W3SVC/1/ROOT/Microsoft-Server-ActiveSync
    BasicAuthEnabled                           : True
    WindowsAuthEnabled                         : False
    CompressionEnabled                         : True
    ClientCertAuth                             : Ignore
    WebsiteName                                : Default Web Site
    WebSiteSSLEnabled                          : True
    VirtualDirectoryName                       : Microsoft-Server-ActiveSync
    Path                                       :
    ExtendedProtectionTokenChecking            : None
    ExtendedProtectionFlags                    : {}
    ExtendedProtectionSPNList                  : {}
    Server                                     : EX2010
    InternalUrl                                : https://mail.contoso.com/Microsoft-Server-ActiveSync
    InternalAuthenticationMethods              : {}
    ExternalUrl                                : https://mail.contoso.com/Microsoft-Server-ActiveSync
    ExternalAuthenticationMethods              : {}
    AdminDisplayName                           :
    ExchangeVersion                            : 0.10 (14.0.100.0)
    Name                                       : Microsoft-Server-ActiveSync (Default Web Site)
    DistinguishedName                          : CN=Microsoft-Server-ActiveSync (Default Web Site),CN=HTTP,CN=Protocols,CN=
                                                 EX2010,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=
                                                 Administrative Groups,CN=MPG,CN=Microsoft Exchange,CN=Services,CN=Configur
                                                 ation
    Identity                                   : EX2010\Microsoft-Server-ActiveSync (Default Web Site)
    Guid                                       : da02643f-3a2e-4081-8b6f-d4809a15a741
    ObjectCategory                             : contoso.com/Configuration/Schema/ms-Exch-Mobile-Virtual-Directory
    ObjectClass                                : {top, msExchVirtualDirectory, msExchMobileVirtualDirectory}
    WhenChanged                                : 03.08.2012 15:35:31
    WhenCreated                                : 13.01.2012 16:02:23
    WhenChangedUTC                             : 03.08.2012 13:35:31
    WhenCreatedUTC                             : 13.01.2012 15:02:23
    OrganizationId                             :
    OriginatingServer                          : adserver2.contoso.com
    IsValid                                    : True



    • Bearbeitet Martin2012 Mittwoch, 26. April 2017 11:45
    Montag, 6. August 2012 07:18
  • Ich verstehe es nicht - jetzt funktioniert sogar die Autoermittlung plötzlich(getestet mit dem Microsoft Remote Connectivity Analayzer) - das einzige was ich heute geändert habe war das ich folgenden Hotfix auf EX2003 eingespielt habe und den EX2003 neugestartet habe

    http://support.microsoft.com/kb/937031/en-us

    Ich habe noch nicht einmal die dann im KB Artikel notwendigen Veränderungen duchgeführt

    Da ich fast alles probiert habe - und in einem anderen Forum auf den Tip mit dem Hotfix gestossen bin -dachte ich einfach mal - schlimmer ganz nicht werden -und ich installiere trotz möglicher Probleme den Hotfix auf 2003

    Seltsam - wuesste nur gerne ob wirklich der Hotfix das Problem irgendwie gelöst hat- oder ob es doch an irgend etwas anderem gelegen hat


    • Bearbeitet Martin2012 Montag, 6. August 2012 08:09
    • Als Antwort vorgeschlagen Alex Pitulice Dienstag, 7. August 2012 14:20
    • Als Antwort markiert Alex Pitulice Mittwoch, 8. August 2012 07:58
    Montag, 6. August 2012 08:04