none
Automatischer Workflow bricht ab nachdem ein Dokument erstellt wurde RRS feed

  • Frage

  • Guten Tag,

    ich habe einen Workflow, über SPD2010, erstellt. Dieser wird automatisch gestartet sobald ein Anwender ein Dokument in einer Bibliothek angelegt hat.

    Der Workflow wartet im Hintergrund darauf, dass das Dokument freigegeben wird und den Status "Approved" erhält. Danach erfolgt die Konvertierung in ein PDF und dieses wird in einem Unterordner gespeichert.

    Jetzt mein Problem:

    Sobald ein Dokument erstellt worden ist, startet der Workflow bleibt aber direkt danach hängen. Einzige Fehlermeldung - "Error Occurred".

    Dies betrifft aber nicht alle Anwender.

    Anwender aus Standort A können den Workflow ohne Probleme automatisch starten aber Anwender aus Standort B nicht.

    Auch können Anwender aus Standort B, diesen Workflow manuel starten.

    Vielen Dank im Voraus für jegliche Unterstützung.

    • Typ geändert Alex Pitulice Dienstag, 10. Dezember 2013 18:27 Warten auf Feedback
    • Typ geändert Alex Pitulice Dienstag, 4. Februar 2014 15:30 Noch Aktiv
    Freitag, 6. Dezember 2013 13:22

Antworten

  • Wir haben in der Zwischenzeit die Ursache für den Fehler identifizieren können. Bei den GPOs gab es ein Problem. Nachdem diese angeglichen wurden funktioniert der Workflow wie erwartet.

    • Als Antwort markiert Alex Pitulice Dienstag, 4. Februar 2014 15:30
    Dienstag, 4. Februar 2014 14:26

Alle Antworten

  • Hallo frweb,

    leider sind zu wenige Informationen um die Ursache des Problems festzustellen.

    Folge mal bitte die folgenden Troubleshooting Schritte um mehrere Infos über die Ursache des Problems zu entdecken.

    Troubleshoot workflow errors (SharePoint Server 2010

    In addition to the Completed status, a final status that you might see in this column is Error Occurred, Stopped, Failed on start (retrying), or Failed on start()

    Troubleshooting and investigations

    1- What are the most errors for SPD workflow ?
    • Access Denied
    • List Item Not Found
    • Error updating a list item
    • Failed on Start (retrying)
    • Document must be checked out

     

    2- How to find the root cause for workflow issues? 

    1. Check the workflow history list URL: http://[servername]/[sitename]/lists/Workflow%20History. to see all the associated logs on each workflow instance
    2. Enable the Logging on ULS :
             • Open the Central Admin > Monitoring >  Under Reporting > "Configure diagnostic logging"
             • Expand SharePoint Foundation and check on the option "Workflow Infrastructure" 
             • select Least critical event to report to the event log to be verbose.(for temporary period).
             • Perform a test triggering the workflow by add new item.
             • Open the last log file under the 14 hive (…\Microsoft Shared\Web Server Extensions\14\LOGS)

    Es könnte etwas mit dem Timeout Value zu tun haben: How to - Increase timeout value of a SharePoint workflow . Alternativ, siehe bitte auch diesen Thread: Workflow "Error Occurred" Message Antwort von motionpotion

    Gruss,

    Alex


    Alex Pitulice, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Montag, 9. Dezember 2013 12:30
  • Hallo,

    ich habe dann jetzt die folgende Meldungen im Log-File finden können wenn ein Anwender eine neue Datei anlegt.

    01/14/2014 08:17:39.18 w3wp.exe (0x1220) 0x26E8 SharePoint Foundation Workflow Infrastructure 72et Unexpected Object reference not set to an instance of an object. 

    01/14/2014 08:17:39.66 w3wp.exe (0x1220) 0x26E8 SharePoint Foundation Workflow Infrastructure 88xr Unexpected WinWF Internal Error, terminating workflow Id# 40d51f85-5a7d-4ffb-acef-808bc5f750ad 

    01/14/2014 08:17:39.66 w3wp.exe (0x1220) 0x26E8 SharePoint Foundation Workflow Infrastructure 98d4 Unexpected System.NullReferenceException: Object reference not set to an instance of an object.     at Microsoft.SharePoint.Workflow.SPWinOEWSSService.CreateSubscription(MessageEventSubscription sub)     at Microsoft.SharePoint.Workflow.SPWinOESubscriptionService.CreateSubscription(MessageEventSubscription sub)     at System.Workflow.Activities.CorrelationTokenInvalidatedHandler.CreateSubscription(Guid instanceId, ActivityExecutionContext context, ICollection`1 correlationValues)     at System.Workflow.Activities.CorrelationTokenInvalidatedHandler.System.Workflow.ComponentModel.IActivityEventListener<System.Workflow.Runtime.CorrelationTokenEventArgs>.OnEvent(Object sender, CorrelationTokenEventArgs dataChangeEventArgs)     at System.Workflow.ComponentModel.ActivityExecutorDelegateInfo`1.ActivityExecutorDelegateOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)     at System.Workflow.ComponentModel.ActivityExecutorDelegateInfo`1.InvokeDelegate(Activity currentContextActivity, Activity targetContextActivity, T e, Boolean sync, Boolean transacted)     at System.Workflow.ComponentModel.ActivityExecutorDelegateInfo`1.InvokeDelegate(Activity currentContextActivity, T e, Boolean sync, Boolean transacted)     at System.Workflow.Runtime.CorrelationToken.Initialize(Activity activity, ICollection`1 propertyValues)     at System.Workflow.Activities.CorrelationService.InvalidateCorrelationToken(Activity activity, Type interfaceType, String methodName, Object[] messageArgs)     at System.Workflow.Activities.CallExternalMethodActivity.Execute(ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)     at System.Workflow.Runtime.Scheduler.Run() 

    Der Anwender selber verfügt über die Berechtigung "FullControl". Wie gesagt sitzt der Kollege in einem anderen Werk. Das bedeutet andere Domain, Proxy und Firewall.

    Ich hatte auch eine komplet neue Bibliothek angelegt und den Workflow hier neu erstellt. Es bleibt aber beim gleichen Ergebnis.

    Gruss,

    Frank

    Dienstag, 14. Januar 2014 09:16
  • Wir haben in der Zwischenzeit die Ursache für den Fehler identifizieren können. Bei den GPOs gab es ein Problem. Nachdem diese angeglichen wurden funktioniert der Workflow wie erwartet.

    • Als Antwort markiert Alex Pitulice Dienstag, 4. Februar 2014 15:30
    Dienstag, 4. Februar 2014 14:26