none
RDP Zugriff auf Windows Server 2012 mit älteren Client Versionen RRS feed

  • Frage

  • Wie kann ich im Windows Server 2012 (10 aktuelle User Cal Pro Benutzer, keine Domäne) einstellen, dass sich ältere Clients z.B. Remotedesktop 5.2 oder ThinClients mit RDP auf dem Server anmelden können? Der Server lehnt die RDP Sitzung ab - nur neuere Versionen können sich anmelden.

    Donnerstag, 28. März 2013 16:52

Antworten

  • Das war die Lösung, die ich selber gefunden habe:

    http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/thread/6dfe0743-c220-49c0-a33c-0aa95066f967/

    VIELEN HERZLICHEN DANK!!!

    DANKE ANDREE MARQUARDT - DU WARST MEINE RETTUNG!

    VIELEN HERZLICHEN DANK!!!


    Montag, 1. April 2013 05:17

Alle Antworten

  • Am 28.03.2013 17:52, schrieb Sebastian Storb:

    Wie kann ich im Windows Server 2012 (10 aktuelle User Cal Pro
    Benutzer, keine Domäne) einstellen, dass sich ältere Clients z.B.
    Remotedesktop 5.2 oder ThinClients mit RDP auf dem Server anmelden
    können? Der Server lehnt die RDP Sitzung ab - nur neuere Versionen
    können sich anmelden.

    uncheck/deaktiviere
    Verbindung nur von Computern zulassen, auf denen Remotedesktop mit Authentifizierung auf Netzwerebene ausgeführt wird.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Donnerstag, 28. März 2013 18:44
  • Leider gibt es den Punkt Verwalten/Remotdesktopdienste in Server 2012 nicht mehr!

    Diese Anleitung bezieht sich nur auf Server 2008 R2: http://technet.microsoft.com/de-de/library/cc732713.aspx

    Änderungen unter der Gruppenrichtlinieneinstellung Computerkonfiguration\Richtlinien\Administrative Vorlagen\Windows-Komponenten\Remotedesktopdienste\Remotedesktop-Sitzungshost\Sicherheit

    ändert das Verhalten des Server 2012 leider nicht!


    Gibt es eine andere Lösung?
    Donnerstag, 28. März 2013 20:10
  • Ja gibt es!

    Start -> Computer -> hier einen Rechtsklick -> Eigenschaften -> Erweiterte Systemeinstellungen -> Remote -> Jetzt den Haken bei "Verbindungen nur von Computern zulassen, auf denen Remotedesktop mit Authentifizierung auf Netzwerkebene ausgeführt wird" RAUS machen.


    Das ist das, was Marc dir auch sagen wollte (denke ich)
    Freitag, 29. März 2013 08:59
  • Moin,

    Am 29.03.2013 09:59, schrieb Robert Ullrich:

    Das ist das, was Marc dir auch sagen wollte (denke ich)

    Volltreffer, verdammt ich bin so leicht zu durchschauen :-)

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Freitag, 29. März 2013 09:48
  • Am 28.03.2013 19:44, schrieb Mark Heitbrink [MVP]:

    uncheck/deaktiviere
    Verbindung nur von Computern zulassen, auf denen Remotedesktop mit Authentifizierung auf Netzwerebene ausgeführt wird.

    Zusatz:
    http://social.technet.microsoft.com/Forums/de-DE/windowsserver8de/thread/a0e44973-2bea-4600-8767-741e9d34c85d

    Evtl. fordert er jetzt ne Smartcard oder /public.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Freitag, 29. März 2013 09:49
  • Moin,

    Am 29.03.2013 09:59, schrieb Robert Ullrich:

    Das ist das, was Marc dir auch sagen wollte (denke ich)

    Volltreffer, verdammt ich bin so leicht zu durchschauen :-)

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Sorry für das falsch schreiben deines Namens :-( Ich hoffe du kannst mir verzeihen ;)
    Freitag, 29. März 2013 10:01
  • Vielen Dank für die freundlichen Antworten!

    1.) Mit RDP Clients, die Netzwerkauthetifizierung auf Netzewerkebene unterstützen  (z.B. ab Verision 6), gab und gibt es keine Probleme. Nachdem ich allerdings den Remote Lizensierungs-Modus (Per User) festlegen musste, konnten sich ältere RDP Clienten nicht mehr anmelden.

    Leider können die ThinClients (Fujitsu-Siemens Futro A210) kein /public  und mit der Aktivierung der Smartcard, die möglich wäre geht es leider nicht. (Dienst ist auf dem Server 2012 gestartet)

    2.) Ich bin darauf gestoßen, dass ich in REGEDIT den Pfad 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\GracePeriod

    löschen sollte.

    http://technet.microsoft.com/en-us/library/cc775148(v=ws.10).aspx

    Leider kommt die Meldung

    GracePeriod kann nicht gelöscht werden. Fehler beim Löschen des Schlüssels.

    -Auch die Benutzerrechte kann ich nicht ändern und daher nicht löschen.

    -Auch im abgesicherten Modus nicht und

    -Auch nicht wenn ich alle Einstellungen in der Gruppenrichtlinie zurücksetze und den S

    Server neu gestartet habe.

    zu 1.) Warum geht es nicht mit der Smartcard?

    zu 2.) Wie kann ich den Schlüssel löschen?









    Freitag, 29. März 2013 12:57
  • Kennt denn jemand noch eine Lösung?
    Samstag, 30. März 2013 06:12
  • Am 30.03.2013 07:12, schrieb Sebastian Storb:

    Kennt denn jemand noch eine Lösung?

    Hast du es nun abgeschaltet, wie Robert schrieb, oder nicht?

    Es kommt nur evtl. dann die Smartcard Anforderung, was ich mangels altem Client, nicht verifizieren kann.

    Die Lösung ist einfach: Ersatz der alten Hardware und Nutzung der Netzwerkauthentifizierung ab RDP Version 6.x, oder Installation Server 2008.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    Samstag, 30. März 2013 12:59
  • Leider ist die Lösung nicht so einfach, wie Du denkst: 
    Der Server steht in einer Arztpraxis, und ich muss für meine Operationen über VPN Leitungen vom Krankenhaus darauf zugreifen. Dort kann ich die Hardware nicht austauschen, in der Praxis habe ich daran auch bereits gedacht.

    2008 kommt leider nicht in Frage.

    ANTWORT:

    Fall 1)

    Ich habe es in der Gruppenrichtlinie abgeschaltet (wie Du vorgeschlagen hattest), dadurch ist es unter 

    Start -> Computer -> hier einen Rechtsklick -> Eigenschaften -> Erweiterte Systemeinstellungen -> Remote 

    ausgeblendet.

    Das Verhalten entspricht Fall 3:

    Anmeldung nur mit neueren RDP-Clienten nicht möglich


    Fall 2) In den Gruppenrichtlinien nicht konfiguriert und Häkchen ist gesetzt:

    Anmeldung auch mit neueren RDP-Clienten NICHT möglich

    Fall 3) In den Gruppenrichtlinien nicht konfiguriert und Häckchen herausgenommen:

    Anmeldung mit neueren RDP-Clienten ist möglich
    Anmeldung mit alten Clients schlägt mit Fehlermeldung fehl:

    Fehlermeldung der alten Clienten:
    Der Client konnte keine Verbindung mit dem Remotecomputer herstellen da ein Sicherheitsfehler aufgetreten ist. Stellen Sie sicher, dass Sie auf dem Netzwerk angemeldet sind und wiederhohlen Sie den Vorgang


    Fehlermeldung des Server 2012 in diesem Fall:
    Die Remotedesktopdienste konnten keine Verknüpfung mit dem Verbindungsbroker auf dem Server herstellen.
    Fehler: Die aktuelle asynchrone Nachricht wurde vom asynchronen Verteiler gelöscht, da eine neue Nachricht vorhanden ist, die die aktuelle Nachricht überschreibt.


    Gibt es da eine Lösung?








    Samstag, 30. März 2013 16:29
  • Das war die Lösung, die ich selber gefunden habe:

    http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/thread/6dfe0743-c220-49c0-a33c-0aa95066f967/

    VIELEN HERZLICHEN DANK!!!

    DANKE ANDREE MARQUARDT - DU WARST MEINE RETTUNG!

    VIELEN HERZLICHEN DANK!!!


    Montag, 1. April 2013 05:17