none
zweiten Exchange installiert für p2p

    Frage

  • Hallo,

    Ich habe einen Domain Controller und meinen ersten Exchange 2016 Server neu installiert. Es hat alles funktioniert.

    Um mal die Migration auf einen neuen Server zu testen, habe ich in der gleichen Domain einen zweiten Exchange 2016 installiert. Eigentlich genau wie den ersten. Seit ich den zweiten installiert habe, kann ich das Administrative Center vom ersten nicht mehr aufrufen. Die Management Shell und OWA nicht. Outlook kann sich nicht mehr verbinden. 

    In der Ereignisanzeige erscheinen verschiedene Fehler, vor allem 

    • MSExchange ADAccess 4027 (s.u.).
    • MSExchangeDiagnostics Event ID 1032

    Außerdem ist der Ordner 

    CN=EXBOX1,CN=Autodiscover,CN=Protocols,CN=EXBOX1,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=ExchangeOrganisationName,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=exchange,DC=com

    leer. Ist das richtig?

    Danach hab ich auf dem 1. Exchange nochmal prepareAD vom Setup aufgerufen. Damit hat sich nix geändert.

    Lässt sich der Fehler einfach beheben oder sollte ich besser neu installieren?

    Gruß,
    Christian

    Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          7/8/2018 3:41:44 PM
    Event ID:      4027
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      exbox1.exchange.com
    Description:
    Process w3wp.exe (FE_Autodiscover) (PID=3964). WCF request (Get Servers for exchange.com) to the Microsoft Exchange Active Directory Topology service on server (TopologyClientTcpEndpoint (localhost)) failed. Make sure that the service is running. In addition, make sure that the network ports that are used by Microsoft Exchange Active Directory Topology service are not blocked by a firewall. The WCF call was retried 3 time(s). Error Details 
     System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://localhost:890/Microsoft.Exchange.Directory.TopologyService. The connection attempt lasted for a time span of 00:00:02.0038770. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:890.  ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:890
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       --- End of inner exception stack trace ---

    Server stack trace: 
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
       at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at System.ServiceModel.ICommunicationObject.Open()
       at Microsoft.Exchange.Net.ServiceProxyPool`1.GetClient(Int32 retry, Boolean& doNotReturnProxyAfterRetry, Boolean useCache)
       at Microsoft.Exchange.Net.ServiceProxyPool`1.TryCallServiceWithRetry(Action`1 action, String debugMessage, WCFConnectionStateTuple proxyToUse, Int32 numberOfRetries, Boolean doNotReturnProxyOnSuccess, Exception& exception)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange ADAccess" />
        <EventID Qualifiers="49156">4027</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2018-07-08T22:41:44.502079000Z" />
        <EventRecordID>12626</EventRecordID>
        <Channel>Application</Channel>
        <Computer>exbox1.exchange.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>w3wp.exe (FE_Autodiscover)</Data>
        <Data>3964</Data>
        <Data>Get Servers for exchange.com</Data>
        <Data>TopologyClientTcpEndpoint (localhost)</Data>
        <Data>3</Data>
        <Data>System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://localhost:890/Microsoft.Exchange.Directory.TopologyService. The connection attempt lasted for a time span of 00:00:02.0038770. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:890.  ---&gt; System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:890
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       --- End of inner exception stack trace ---

    Server stack trace: 
       at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
       at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
       at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&amp; msgData, Int32 type)
       at System.ServiceModel.ICommunicationObject.Open()
       at Microsoft.Exchange.Net.ServiceProxyPool`1.GetClient(Int32 retry, Boolean&amp; doNotReturnProxyAfterRetry, Boolean useCache)
       at Microsoft.Exchange.Net.ServiceProxyPool`1.TryCallServiceWithRetry(Action`1 action, String debugMessage, WCFConnectionStateTuple proxyToUse, Int32 numberOfRetries, Boolean doNotReturnProxyOnSuccess, Exception&amp; exception)</Data>
      </EventData>
    </Event>

    Montag, 9. Juli 2018 19:43

Alle Antworten

  • Hier hast du ggf. die Antwort:

    https://social.technet.microsoft.com/Forums/exchange/de-DE/e07de06e-c851-4ff6-83c4-3eb5f9efd86c/exchange-server-parallel-betreiben?forum=exchange_serverde

    Montag, 9. Juli 2018 20:26
  • Nein, leider nicht. Möglicherweise habe ich bei der Installation auch etwas falsch gemacht. Es ist ja nicht nur die Verbindung nach draußen, die nicht mehr geht.
    Montag, 9. Juli 2018 21:05
  • Da steht ja auch nicht die Lösung, sondern das Problem, dass 2 Instanzen nicht funktionieren. Da hat wohl die eine Installation was von der anderen kaputt gemacht.

    Im Zweifel also alles löschen und 1 Instanz neu installieren.

    Eine 2. Instamz macht man dann besser auf einer 2. Maschine (VM).

    Dienstag, 10. Juli 2018 07:18
  • Außerdem ist der Ordner 

    CN=EXBOX1,CN=Autodiscover,CN=Protocols,CN=EXBOX1,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=ExchangeOrganisationName,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=exchange,DC=com

    leer. Ist das richtig? 

    Ja, denn der Payload ist in den Attributen dieses Objektes enthalten.

    Je nachdem, was der Zweck dieser Umgebung ist, würde ich schon versuchen, das zu entstören - lernst auf jeden Fall einiges über Exchange. Ein paar unzusammenhängende Hinweise:

    • ist auf beiden Exchange-Servern der Dienst "NET.TCP Port Sharing" gestartet und auf "Automatic" gestellt?
    • Wieviele Domain Controller gibt es in dem Forest? Falls mehr als 1: Funktioniert die Replikation zwischen ihnen? In jedem Fall: Ist DCDIAG OK?
    • was siehst Du an Fehlermeldungen im Event Log, wenn Du den AD-Topologiedienst von Exchange neu startest (das startet aber auch die meisten anderen Exchange-Dienste neu...)?
    • Mach an beiden Exchange-Boxen einen IISRESET. Was siehst Du danach an Fehlermeldungen im Event Log (abgesehen von den obigen)?

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> https://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com


    In theory, there is no difference between theory and practice. In practice, there is.

    Dienstag, 10. Juli 2018 07:55
  • Da steht ja auch nicht die Lösung, sondern das Problem, dass 2 Instanzen nicht funktionieren. Da hat wohl die eine Installation was von der anderen kaputt gemacht.

    Im Zweifel also alles löschen und 1 Instanz neu installieren.

    Eine 2. Instamz macht man dann besser auf einer 2. Maschine (VM).

    Die 2. Instanz ist in einer zweiten Maschine.
    Dienstag, 10. Juli 2018 15:57
  • Ist das produktiv oder zum üben?

    Gruß Norbert

    Mittwoch, 11. Juli 2018 21:49
    Moderator
    1. ist auf beiden Exchange-Servern der Dienst "NET.TCP Port Sharing" gestartet und auf "Automatic" gestellt?
    2. Wieviele Domain Controller gibt es in dem Forest? Falls mehr als 1: Funktioniert die Replikation zwischen ihnen? In jedem Fall: Ist DCDIAG OK?
    3. was siehst Du an Fehlermeldungen im Event Log, wenn Du den AD-Topologiedienst von Exchange neu startest (das startet aber auch die meisten anderen Exchange-Dienste neu...)?
    4. Mach an beiden Exchange-Boxen einen IISRESET. Was siehst Du danach an Fehlermeldungen im Event Log (abgesehen von den obigen)?


    @Norbert: zum Üben

    @Evgenij: danke für deine ausführliche Antwort. Auch wenn der zweite ausgeschaltet ist, funktioniert der erste nicht.

    zu deinen Fragen:

    1. "NET.TCP Port Sharing" steht bei beiden auf automatisch, ist aber auf keinem gestartet
    2. es gibt einen DC. dcdiag scheint soweit ok zu sein (s.u.)
    3. AD Topologie Dienst stand auf automatisch, war aber nicht gestartet. Wenn ich ihn neu starte, erscheint Error MSExchangeDiagnostics 1032 (s.u.). 
    4. im IIS erscheint HTTP 500 (s.u.)












    dcdiag:

    C:\Users\Administrator>dcdiag
    Directory Server Diagnosis

    Performing initial setup:
       Trying to find home server...
       Home Server = exad1
       * Identified AD Forest.
       Done gathering initial info.

    Doing initial required tests

       Testing server: Default-First-Site-Name\EXAD1
          Starting test: Connectivity
             ......................... EXAD1 passed test Connectivity

    Doing primary tests

       Testing server: Default-First-Site-Name\EXAD1
          Starting test: Advertising
             ......................... EXAD1 passed test Advertising
          Starting test: FrsEvent
             ......................... EXAD1 passed test FrsEvent
          Starting test: DFSREvent
             There are warning or error events within the last 24 hours after the SYSVOL has been shared.  Failing SYSVOL
             replication problems may cause Group Policy problems.
             ......................... EXAD1 failed test DFSREvent
          Starting test: SysVolCheck
             ......................... EXAD1 passed test SysVolCheck
          Starting test: KccEvent
             A warning event occurred.  EventID: 0x80000B46
                Time Generated: 07/10/2018   17:55:01
                Event String:
                The security of this directory server can be significantly enhanced by configuring the server to reject SASL (Negotiate, Kerberos, NTLM, or Digest) LDAP binds that do not request signing (integrity verification) and LDAP simple binds that are performed on a clear text (non-SSL/TLS-encrypted) connection.  Even if no clients are using such binds, configuring the server to reject them will improve the security of this server.
             ......................... EXAD1 passed test KccEvent
          Starting test: KnowsOfRoleHolders
             ......................... EXAD1 passed test KnowsOfRoleHolders
          Starting test: MachineAccount
             ......................... EXAD1 passed test MachineAccount
          Starting test: NCSecDesc
             ......................... EXAD1 passed test NCSecDesc
          Starting test: NetLogons
             ......................... EXAD1 passed test NetLogons
          Starting test: ObjectsReplicated
             ......................... EXAD1 passed test ObjectsReplicated
          Starting test: Replications
             ......................... EXAD1 passed test Replications
          Starting test: RidManager
             ......................... EXAD1 passed test RidManager
          Starting test: Services
             ......................... EXAD1 passed test Services
          Starting test: SystemLog
             A warning event occurred.  EventID: 0x000003F6
                Time Generated: 07/10/2018   17:55:09
                Event String:
                Name resolution for the name _ldap._tcp.dc._msdcs.exchange.com. timed out after none of the configured DNS servers responded.
             A warning event occurred.  EventID: 0x000727AA
                Time Generated: 07/10/2018   17:55:25
                Event String:
                The WinRM service failed to create the following SPNs: WSMAN/exad1.exchange.com; WSMAN/exad1.
             A warning event occurred.  EventID: 0x0000000C
                Time Generated: 07/10/2018   17:55:25
                Event String:
                Time Provider NtpClient: This machine is configured to use the domain hierarchy to determine its time source, but it is the AD PDC emulator for the domain at the root of the forest, so there is no machine above it in the domain hierarchy to use as a time source. It is recommended that you either configure a reliable time service in the root domain, or manually configure the AD PDC to synchronize with an external time source. Otherwise, this machine will function as the authoritative time source in the domain hierarchy. If an external time source is not configured or used for this computer, you may choose to disable the NtpClient.
             A warning event occurred.  EventID: 0x00001796
                Time Generated: 07/10/2018   17:56:02
                Event String:
                Microsoft Windows Server has detected that NTLM authentication is presently being used between clients and this server. This event occurs once per boot of the server on the first time a client uses NTLM with this server.
             An error event occurred.  EventID: 0x00002720
                Time Generated: 07/10/2018   18:00:09
                Event String:
                The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
             ......................... EXAD1 failed test SystemLog
          Starting test: VerifyReferences
             ......................... EXAD1 passed test VerifyReferences


       Running partition tests on : ForestDnsZones
          Starting test: CheckSDRefDom
             ......................... ForestDnsZones passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... ForestDnsZones passed test CrossRefValidation

       Running partition tests on : DomainDnsZones
          Starting test: CheckSDRefDom
             ......................... DomainDnsZones passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... DomainDnsZones passed test CrossRefValidation

       Running partition tests on : Schema
          Starting test: CheckSDRefDom
             ......................... Schema passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... Schema passed test CrossRefValidation

       Running partition tests on : Configuration
          Starting test: CheckSDRefDom
             ......................... Configuration passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... Configuration passed test CrossRefValidation

       Running partition tests on : exchange
          Starting test: CheckSDRefDom
             ......................... exchange passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... exchange passed test CrossRefValidation

       Running enterprise tests on : exchange.com
          Starting test: LocatorCheck
             ......................... exchange.com passed test LocatorCheck
          Starting test: Intersite
             ......................... exchange.com passed test Intersite
             

    Error 1032:
    Log Name:      Application
    Source:        MSExchangeDiagnostics
    Date:          7/11/2018 9:55:26 PM
    Event ID:      1032
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      exbox1.exchange.com
    Description:
    The EDS Job manager failed to start the following jobs: 
    Job: 'PFAssistantLog' creation failed.
    Job: 'OwaClientLog' creation failed.
    Job: 'OwaClientLocation' creation failed.
    Job: 'OAuthCafeLog' creation failed.
    Job: 'OABDownloadLog' creation failed.
    Job: 'MRSAvailabilityLog' creation failed.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchangeDiagnostics" />
        <EventID Qualifiers="49156">1032</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2018-07-12T04:55:26.036707800Z" />
        <EventRecordID>15062</EventRecordID>
        <Channel>Application</Channel>
        <Computer>exbox1.exchange.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>
    Job: 'PFAssistantLog' creation failed.
    Job: 'OwaClientLog' creation failed.
    Job: 'OwaClientLocation' creation failed.
    Job: 'OAuthCafeLog' creation failed.
    Job: 'OABDownloadLog' creation failed.
    Job: 'MRSAvailabilityLog' creation failed.</Data>
      </EventData>
    </Event>




    IIS Fehler:
    2018-07-11 05:04:37 ::1 GET /owa/auth/logon.aspx replaceCurrent=1&url=https%3a%2f%2flocalhost%2fowa&CorrelationID=<empty>;&cafeReqId=75f3c85b-538e-4a7b-be61-ea9af1c517b7;&encoding=; 443 - ::1 Mozilla/5.0+(Windows+NT+10.0;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 200 0 0 4
    2018-07-11 05:04:45 ::1 POST /owa/auth.owa &CorrelationID=<empty>;&cafeReqId=4d056b3b-6b4a-4db7-97a3-32965aaaf0f1;&encoding=; 443 EXCHANGE\Administrator ::1 Mozilla/5.0+(Windows+NT+10.0;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://localhost/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2flocalhost%2fowa 500 0 0 2179



    Donnerstag, 12. Juli 2018 16:56
  • nur der Vollständigkeit halber: es kommen noch die gleichen Fehlermeldungen in der Ereignisanzeige, aber die Konsole und Weboberfläche für Admin und OWA funktionieren wieder, nachdem ich die VMs auf schnellere Festplatten verschoben haben.

    Gruß,

    Christian

    Samstag, 28. Juli 2018 15:50