none
Softwareverteilung unter XP geht, unter W7 nicht RRS feed

  • Frage

  • Hallo Forengemeinde!

    Ich verteile schon seit geraumer Zeit die "üblichen Verdächtigen" (Flash Player, Adobe Reader, Java) per GPO auf meine Clients. Das hat in der Vergangenheit mit XP Pro Clients auch immer wunderbar funktioniert.

    Vor kurzem habe ich nun alles auf Win7 umgestellt und nun klappt es leider nicht mehr. Ich wollte heute den neuen Flash-Player per GPO verteilen, habe eine Richtlinie erstellt und meinen Test-Client laufen lassen. Der zieht sich die Richtlinie zwar (gpresult /r), installiert dann aber nicht (im Ereignisprotokoll MSI-Fehler 1612, was ja so viel bedeutet wie "Quelle nicht verfügbar").

    - Aus dem selben Share kann ich von Hand problemlos instalieren
    - GPO-Faq, Punkt 36: Einstellungen sind durch die allg. Richtlinie gesetzt
    - Im Share haben sowohl die Gruppe "Jeder" als auch die Gruppe "Auth. Benutzer" Leserechte

    Ich habe mir dann noch einen alten XP-Client wieder aus dem Regal gezogen. Auf dem klappt die Installation via GPO sofort und einwandfrei.

    Es ist aus meiner Sicht also das selbe Softwarepaket aus dem selben Share mit der selben Richtlinie und es klappt unter XP, unter Win7 aber nicht.

    Gibt es bei Win7 noch etwas, dass ich zusätzlich berücksichtigen muss?

    Vielen Dank im voraus!

    TJ Hooker

    Donnerstag, 25. August 2011 08:07

Antworten

  • Hi!

    Habe in der Zwischenzeit auch mal etwas herumprobiert und SCHEINBAR funktioniert es nun.

    Was ich gemacht habe:
    VORHER war das MSI-Paket im Pfad 

    '\\srv01-w2k8r2\Daten\Mitarbeiter-Systemverwaltung\Deploy\FPL10.3.183.7\'

    untergerbacht. Die Freigabe am Server war dabei das Verzeichnis "Daten", der Rest dann der Pfad bis hinunter zur MSI.

    Ich habe nun das Verzeichnis "Deploy" direkt freigegeben, so dass jetzt aus dem Pfad

    '\\srv01-w2k8r2\Deploy\FPL10.3.183.7\'

    installiert wird. Und schoin gehts´s mit der selben MSI-Datei.

    Ich habe das bisher nur auf einem PC getestet und werde Morgen mal einige weitere testen.


    TJ Hooker

    • Als Antwort markiert T.J. Hooker Dienstag, 6. September 2011 06:36
    Donnerstag, 25. August 2011 13:52

Alle Antworten

  • Hallo,

    >Ich verteile schon seit geraumer Zeit die "üblichen Verdächtigen"
    Das heißt es handelt sich um eine Zuweisung auf Computerebene?

    Die Installationsdateien liegen auf einem normalen Share oder im Sysvol eines DCs?


    Aktiviere doch bitte einmal das Logging des MSI Installers auf einem Rechner um genauere Fehlercodes zu erhalten:

    http://support.microsoft.com/kb/223300/de

    Verwendest du im UNC Pfade den FQDN des Servers oder einen Alias?

    Welche Berechtigungen hast du auf NTFS Ebene eingestellt (Lesen + Ausführen)?

    Kenns du diesen Threads bereits?
    http://social.technet.microsoft.com/Forums/de-DE/gruppenrichtliniende/thread/c0c5d691-40af-478c-8ae0-8d96be55d4ad/

    http://support.microsoft.com/kb/278472/en-us

    http://social.technet.microsoft.com/Forums/en-IE/winserverGP/thread/55a31301-345f-4c74-b7b4-3f01ed6f606b

     


    Donnerstag, 25. August 2011 08:53
    Beantworter
  • Hi!

    Danke für Deine Rückmeldung!

    - Zuweisung auf Computerbene, yepp...
    - Inst.-Dateien liegen in einem normale Share
    - Im UNC-Pfad steht "quasi" der FQDN, also ohne das "Domäne.TLD"
    - Zugriffsrechte am Beispiel der FlashPlayer-MSI wie folgt:
       - Administratoren: Vollzugriff
       - Ath. Benutzer: Lesen/Ausführen und Lesen
       - Jeder: Lesen/Ausführen und Lesen (ist doppelt, ich weiß)
       - lokale Benutergruppe ("Alle IT´ler"): Vollzugriff

    Die Links kannte ich alle schon, habe da aber m.E. nichts für mich relevantes entdeckt.
    Oder habe ich was übersehen?

    Hier noch der MSI-Log von der Flash-Player-Installation. Ich kann dem aber auch "nur" entnehmen, dass das Paket "missing" ist. Es ist aber da.

    TJ Hooker

    *******************************************************************************

    === Verbose logging started: 25.08.2011  11:11:04  Build type: SHIP UNICODE 5.00.7601.00  Calling process: C:\Windows\system32\svchost.exe ===
    MSI (c) (18:78) [11:11:04:296]: Resetting cached policy values
    MSI (c) (18:78) [11:11:04:296]: Machine policy value 'Debug' is 0
    MSI (c) (18:78) [11:11:04:296]: ******* RunEngine:
               ******* Product: {db093e0b-0934-4183-ba60-5c1adc9f6424}
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (18:78) [11:11:04:296]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (18:78) [11:11:04:296]: Grabbed execution mutex.
    MSI (c) (18:78) [11:11:04:296]: Cloaking enabled.
    MSI (c) (18:78) [11:11:04:296]: Attempting to enable all disabled privileges before calling Install on Server
    MSI (c) (18:78) [11:11:04:296]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (C8:D4) [11:11:04:296]: Running installation inside multi-package transaction {db093e0b-0934-4183-ba60-5c1adc9f6424}
    MSI (s) (C8:D4) [11:11:04:296]: Grabbed execution mutex.
    MSI (s) (C8:7C) [11:11:04:296]: Resetting cached policy values
    MSI (s) (C8:7C) [11:11:04:296]: Machine policy value 'Debug' is 0
    MSI (s) (C8:7C) [11:11:04:296]: ******* RunEngine:
               ******* Product: {db093e0b-0934-4183-ba60-5c1adc9f6424}
               ******* Action:
               ******* CommandLine: **********
    MSI (s) (C8:7C) [11:11:04:296]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (C8:7C) [11:11:04:296]: Setting cached product context: machine assigned for product: b0e390bd43903814ab06c5a1cdf94642
    MSI (s) (C8:7C) [11:11:04:296]: Using cached product context: machine assigned for product: b0e390bd43903814ab06c5a1cdf94642
    MSI (s) (C8:7C) [11:11:04:296]: Using cached product context: machine assigned for product: b0e390bd43903814ab06c5a1cdf94642
    MSI (s) (C8:7C) [11:11:04:296]: Using cached product context: machine assigned for product: b0e390bd43903814ab06c5a1cdf94642
    MSI (s) (C8:7C) [11:11:04:296]: Attempting to recache package via ProductCode. Beginning source resolution.
    MSI (s) (C8:7C) [11:11:04:296]: User policy value 'SearchOrder' is 'nmu'
    MSI (s) (C8:7C) [11:11:04:296]: User policy value 'DisableMedia' is 0
    MSI (s) (C8:7C) [11:11:04:296]: Machine policy value 'AllowLockdownMedia' is 0
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Media enabled only if package is safe.
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Looking for sourcelist for product {db093e0b-0934-4183-ba60-5c1adc9f6424}
    MSI (s) (C8:7C) [11:11:04:296]: Using cached product context: machine assigned for product: b0e390bd43903814ab06c5a1cdf94642
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Adding {db093e0b-0934-4183-ba60-5c1adc9f6424}; to potential sourcelist list (pcode;disk;relpath).
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Ignoring last used source.
    MSI (s) (C8:7C) [11:11:04:296]: Using cached product context: machine assigned for product: b0e390bd43903814ab06c5a1cdf94642
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Now checking product {db093e0b-0934-4183-ba60-5c1adc9f6424}
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Media is enabled for product.
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Processing net source list.
    MSI (s) (C8:7C) [11:11:04:296]: SOURCEMGMT: Trying source \\srv01-w2k8r2\Daten\Mitarbeiter-Systemverwaltung\Deploy\FPL10.3.183.7\.
    MSI (s) (C8:7C) [11:11:04:296]: Note: 1: 1402 2: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 3: 2
    MSI (s) (C8:7C) [11:11:04:312]: Note: 1: 2303 2: 5 3: \\srv01-w2k8r2\Daten\
    MSI (s) (C8:7C) [11:11:04:312]: Note: 1: 1325 2: Mitarbeiter-Systemverwaltung
    MSI (s) (C8:7C) [11:11:04:312]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1325 -2147483648
    MSI (s) (C8:7C) [11:11:04:312]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
    MSI (s) (C8:7C) [11:11:04:312]: SOURCEMGMT: net source '\\srv01-w2k8r2\Daten\Mitarbeiter-Systemverwaltung\Deploy\FPL10.3.183.7\' is invalid.
    MSI (s) (C8:7C) [11:11:04:312]: Note: 1: 1706 2: -2147483647 3: install_flash_player_10_active_x.msi
    MSI (s) (C8:7C) [11:11:04:312]: SOURCEMGMT: Processing media source list.
    MSI (s) (C8:7C) [11:11:04:390]: Note: 1: 2203 2:  3: -2147287037
    MSI (s) (C8:7C) [11:11:04:390]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
    MSI (s) (C8:7C) [11:11:04:390]: Note: 1: 1706 2: -2147483647 3: install_flash_player_10_active_x.msi
    MSI (s) (C8:7C) [11:11:04:390]: SOURCEMGMT: Processing URL source list.
    MSI (s) (C8:7C) [11:11:04:390]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
    MSI (s) (C8:7C) [11:11:04:390]: Note: 1: 1706 2: -2147483647 3: install_flash_player_10_active_x.msi
    MSI (s) (C8:7C) [11:11:04:390]: Note: 1: 1706 2:  3: install_flash_player_10_active_x.msi
    MSI (s) (C8:7C) [11:11:04:390]: SOURCEMGMT: Failed to resolve source
    MSI (s) (C8:7C) [11:11:04:390]: MainEngineThread is returning 1612
    MSI (s) (C8:D4) [11:11:04:390]: User policy value 'DisableRollback' is 0
    MSI (s) (C8:D4) [11:11:04:390]: Machine policy value 'DisableRollback' is 0
    MSI (s) (C8:D4) [11:11:04:390]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (C8:D4) [11:11:04:390]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (C8:D4) [11:11:04:390]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (C8:D4) [11:11:04:390]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (C8:D4) [11:11:04:390]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (C8:D4) [11:11:04:390]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (s) (C8:D4) [11:11:04:390]: Restoring environment variables
    MSI (c) (18:78) [11:11:04:390]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (18:78) [11:11:04:390]: MainEngineThread is returning 1612
    === Verbose logging stopped: 25.08.2011  11:11:04 ===




    Donnerstag, 25. August 2011 09:28
  • >SOURCEMGMT: net source '\\srv01-w2k8r2\Daten\Mitarbeiter-Systemverwaltung\Deploy\FPL10.3.183.7\' is invalid

    Dieses Verzeichnis gibt es ebenfalls und die Berechtigungen darauf stimmen?
    Mit welcher Software wurden die MSI Files erzeugt?

    Sind alle Daten in die MSI Files gepackt oder werden zusätzlich CAB Dateien verwendet?


    Leider scheint der Fehler öfter aufzutreten:

    http://social.technet.microsoft.com/Forums/de-DE/gruppenrichtliniende/thread/0beff8e8-5ad8-4404-a24b-d208cb5d7cda/

    http://www.appdeploy.com/messageboards/printable.asp?m=48703

     

    Donnerstag, 25. August 2011 10:53
    Beantworter
  • Hi!

    Ja, den Pfad gibt es. Wenn ich ihn aus dem Text kopiere und im Explorer wieder einfüge lande ich in genau dem Verzeichnis und kann dort auch die MSI-Datei sehen und ausführen.

    Die Berechtigungen auf dieses Verzeichnis sind wie oben beschrieben.

    Es gibt für den Flash-Player nur ein einziges MSI-File und dieses stammt direkt von Adobe, CAB-Dateien gibt es dazu nicht.

    ? ? ? ? ?

    TJ Hooker
    Donnerstag, 25. August 2011 11:45
  •  

    So wie es ausschaut, scheint es eine Eigenheit dieser MSI Pakete zu sein.

    Es gibt einige User mit genau diesem Problem:

    http://social.technet.microsoft.com/Forums/pl-PL/winserverGP/thread/4cba558a-0a8f-4912-86c5-ad48052d76f1

    Evtl. solltest du eine Re-Paketierung vornehmen:

    Mark hat einige MSI Paketierer gelistet.

    http://www.gruppenrichtlinien.de/tools/liste_unsortiert.htm

     

     


    Donnerstag, 25. August 2011 13:02
    Beantworter
  • Hi!

    Habe in der Zwischenzeit auch mal etwas herumprobiert und SCHEINBAR funktioniert es nun.

    Was ich gemacht habe:
    VORHER war das MSI-Paket im Pfad 

    '\\srv01-w2k8r2\Daten\Mitarbeiter-Systemverwaltung\Deploy\FPL10.3.183.7\'

    untergerbacht. Die Freigabe am Server war dabei das Verzeichnis "Daten", der Rest dann der Pfad bis hinunter zur MSI.

    Ich habe nun das Verzeichnis "Deploy" direkt freigegeben, so dass jetzt aus dem Pfad

    '\\srv01-w2k8r2\Deploy\FPL10.3.183.7\'

    installiert wird. Und schoin gehts´s mit der selben MSI-Datei.

    Ich habe das bisher nur auf einem PC getestet und werde Morgen mal einige weitere testen.


    TJ Hooker

    • Als Antwort markiert T.J. Hooker Dienstag, 6. September 2011 06:36
    Donnerstag, 25. August 2011 13:52
  • Schön zu hören das es nun scheinbar funktioniert.

    Ich bin auf die Ergebnisse gespannt ;)
    Donnerstag, 25. August 2011 17:47
    Beantworter
  • Bin hier noch eine Antwort schuldig: Es funktioniert nun, der "Trick" war scheinbar wirklich die o.g. Verkürzung des Pfades...

    TJ Hooker
    Dienstag, 6. September 2011 06:36