none
RemoteDesktop WebAccess RRS feed

  • Frage

  • Hallo,

    ich habe folgende konstellation:

    Server 2008 R" als Host für Hyper-V (192.168.10.10)
    als Gastsysteme SBS2011 (192.168.10.11) und Server2008 R2 (192.168.10.13)

    auf der Gast 2008 sind die Remotedesktop-Rollen installiert, da dieser als Terminalserver dienen soll. Auf dem SBS2011 und dem 2008 ist der IIS installiert. Der IIS auf dem SBS2011 horcht auf dem Port 9443 ud der 2008 auf 7443. Ich habe die Port bei umgestellt, da dies ein Testsystem ist und hinter dem Router noch ein SBS2003 läuft (anderer Netzwerkbereich).

    Beim Router habe ich folgende Ports weitergeleitet:
    3389 => 192.168.10.13
    9443 => 192.168.10.11
    7443 => 192.168.10.13

    Auf dem SBS2011 funktioniert alles wunderbar (OWA). Per RDP komme ich auch direkt auf den Terminalserver. Das einzige was nicht funktioniert ist der RemoteDesktop WebAccess. Wenn ich die Seite https://...dyndns.org:7443/RDWeb aufrufe, kann ich mich auch anmelden. Es werden die RemoteApp-Programme angezeigt. Wenn ich mich dann per Remotedesktop verbinden möchte oder eine App aufrufe, kommt noch mal eine Anmeldemaske und dann die Fehlermeldung "Dieser Computer kann keine Verbindung mit dem Remotecomputer herstellen, da die Gatewayadresse der Terminaldienste nicht erreichbar oder falsch ist. Geben Sie eine gültige Serveradresse ein."
    Ich verstehe nicht warum die Meldung kommt. Alle RemoteDesktop Dienste laufen auf dem selben Server (2008), er müste sich doch dann selber finden.

    Vielen Dank für Hilfe

    Ingo

    Mittwoch, 23. Februar 2011 16:03

Antworten

  • ich evtl. bei der Angabe der Servernamen für Host und /oder Gateway was falsch gemacht? Bei beiden habe ich "Terminal2008.Domaene.local" eingetragen.

    Moin Ingo,

    Wenn ich das auf die Schnelle richtig überblicke: Teste an der Gatewayadresse einen öffentlich auflösbaren Namen. Der Name des Sitzungshosts sollte vom GW-Server auch aufgelöst werden können. Da beide Dienste auf einem Server rennen, würde ich zunächst für den Funktionstest den Gateway weglassen und nur für den Sitzungshost einen öffentlich auflösbaren Namen vergeben. Dann sollte es klappen. Danach noch eine Wildcard Domain für intern einsetzen, damit die LAN-Clients die Apps auch erreichen können.

    Gruß

    Michael


    lernschmiede.de
    Freitag, 25. Februar 2011 22:40

Alle Antworten

  • Hi Ingo
     
    > ich habe folgende konstellation:
    >
    > Server 2008 R" als Host für Hyper-V (192.168.10.10)
    > als Gastsysteme SBS2011 (192.168.10.11) und Server2008 R2 (192.168.10.13)
    >
    > auf der Gast 2008 sind die Remotedesktop-Rollen installiert, da dieser als
    > Terminalserver dienen soll. Auf dem SBS2011 und dem 2008 ist der IIS
    > installiert.
    > Der IIS auf dem SBS2011 horcht auf dem Port 9443 ud der 2008 auf 7443. Ich
    > habe
    > die Port bei umgestellt, da dies ein Testsystem ist und hinter dem Router
    > noch ein
    > SBS2003 läuft (anderer Netzwerkbereich).
    >
    > Beim Router habe ich folgende Ports weitergeleitet:
    > 3389 => 192.168.10.13
    > 9443 => 192.168.10.11
    > 7443 => 192.168.10.13
    >
    > Auf dem SBS2011 funktioniert alles wunderbar (OWA). Per RDP komme ich auch
    > direkt auf den Terminalserver. Das einzige was nicht funktioniert ist der
    > RemoteDesktop
    > WebAccess. Wenn ich die Seite https://...dyndns.org:7443/RDWeb aufrufe,
    > kann ich mich
    > auch anmelden. Es werden die RemoteApp-Programme angezeigt. Wenn ich mich
    > dann
    > per Remotedesktop verbinden möchte oder eine App aufrufe, kommt noch mal
    > eine
    > Anmeldemaske und dann die Fehlermeldung "Dieser Computer kann keine
    > Verbindung
    > mit dem Remotecomputer herstellen, da die Gatewayadresse der
    > Terminaldienste nicht
    > erreichbar oder falsch ist. Geben Sie eine gültige Serveradresse ein."
    > Ich verstehe nicht warum die Meldung kommt. Alle RemoteDesktop Dienste
    > laufen auf
    > dem selben Server (2008), er müste sich doch dann selber finden.
     
    Der Port SSL/443 ist bei einem RDP-Gateway (welches hier für die RemoteApps
    von extern benötigt wird) hardcoded.
     
    Deswegen wird es mit Deinem Konstrukt (benutzen des RDS-Gateway für die
    RemoteApps) nicht funktionieren.
     
    Als Workaround kannst Du im RemoteApp Manager das verwenden des TS-Gateway
    deaktivieren (s. http://technet.microsoft.com/en-us/library/cc772479.aspx)
     
     
    Alles weitere hier:
     
    Remote Desktop Gateway Manager
    http://technet.microsoft.com/en-us/library/cc725706.aspx
     
    RemoteApp Manager
    http://technet.microsoft.com/en-us/library/cc755261.aspx
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    Mittwoch, 23. Februar 2011 18:25
  • Hi Ingo
     
    Der Port SSL/443 ist bei einem RDP-Gateway (welches hier für die RemoteApps
    von extern benötigt wird) hardcoded.
     
    Deswegen wird es mit Deinem Konstrukt (benutzen des RDS-Gateway für die
    RemoteApps) nicht funktionieren.
     
    Als Workaround kannst Du im RemoteApp Manager das verwenden des TS-Gateway
    deaktivieren (s. http://technet.microsoft.com/en-us/library/cc772479.aspx)
     
     
    Alles weitere hier:
     
    Remote Desktop Gateway Manager
    http://technet.microsoft.com/en-us/library/cc725706.aspx
     
    RemoteApp Manager
    http://technet.microsoft.com/en-us/library/cc755261.aspx
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     


    Hi Tobias,

    ich habe nun mal testweise direkt den Port 443 benutzt. Aber auch dann klappt die Verbindung nicht. Es kommt die selbe Meldung.

    Habe ich evtl. bei der Angabe der Servernamen für Host und /oder Gateway was falsch gemacht? Bei beiden habe ich "Terminal2008.Domaene.local" eingetragen.

    Viele Grüße

    Ingo

    Donnerstag, 24. Februar 2011 14:10
  • Hi Ingo,
     
    >> Alles weitere hier:
    >>
    >> Remote Desktop Gateway Manager
    >> http://technet.microsoft.com/en-us/library/cc725706.aspx
    >>
    >> RemoteApp Manager
    >> http://technet.microsoft.com/en-us/library/cc755261.aspx
    [..]
    > ich habe nun mal testweise direkt den Port 443 benutzt. Aber auch dann
    > klappt
    > die Verbindung nicht. Es kommt die selbe Meldung.
    >
    > Habe ich evtl. bei der Angabe der Servernamen für Host und /oder Gateway
    > was falsch gemacht? Bei beiden habe ich "Terminal2008.Domaene.local"
    > eingetragen.
     
    wie schon geschrieben, lies Dir die zugehörigen TechNet Artikel durch und
    versuche zu verstehen.
     
    Ansonsten hol Dir jemands ins Boot, der sich damit auskennt.
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    Donnerstag, 24. Februar 2011 14:53
  • ich evtl. bei der Angabe der Servernamen für Host und /oder Gateway was falsch gemacht? Bei beiden habe ich "Terminal2008.Domaene.local" eingetragen.

    Moin Ingo,

    Wenn ich das auf die Schnelle richtig überblicke: Teste an der Gatewayadresse einen öffentlich auflösbaren Namen. Der Name des Sitzungshosts sollte vom GW-Server auch aufgelöst werden können. Da beide Dienste auf einem Server rennen, würde ich zunächst für den Funktionstest den Gateway weglassen und nur für den Sitzungshost einen öffentlich auflösbaren Namen vergeben. Dann sollte es klappen. Danach noch eine Wildcard Domain für intern einsetzen, damit die LAN-Clients die Apps auch erreichen können.

    Gruß

    Michael


    lernschmiede.de
    Freitag, 25. Februar 2011 22:40