none
Kein RDP auf 2k8 R2 möglich "Security Error" RRS feed

  • Frage

  • Hallo,

    wir haben in einem Netzwerk zwei neue Windows Server 2008 R2 Server eingeführt.
    Auf einem der beiden sind waren die Remote Desktop Dienste installiert.

    Wir versuchen nun von Windows CE (5.00) Clients per RDP auf diese Server zu kommen. Auf den Server der keine RDP Dienste hat funktioniert dies problemlos. Der Server auf dem die RDP Dienste sind bringt die Meldung: "Because of a security error, the client could not connect to the remote computer"

    Auch das deinstallieren der RDP Dienste behebt das Problem nicht.
    Welche Einstellung könnte hier denn noch verbogen sein, damit das nicht klappt?

    Vielen Dank...

    Mittwoch, 11. Juli 2012 09:15

Antworten

  • Hallo,

    ich bin ein Arbeitskollege von Dennis_K5121.

    Wir konnten nun das Problem wie folgt lösen:

    1.Auf dem Server

    1. Make sure that the Remote Desktop server registry has been successfully backed up and the Licensing Server is Deactivated.
    2. Start Registry Editor.
    3. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM
    4. On the Registry menu, click Export Registry File.
    5. Type exported-Certificate in the File name box, and then click Save.

      NOTE: If you have to restore this registry subkey in the future, double-click the Exported-parameters.reg file that you saved in this step.
    6. Right-click each of the following values, click Delete, and then click Yes to confirm the deletion:

      Certificate
      X509 Certificate
      X509 Certificate ID
      X509 Certificate2
    7. Quit Registry Editor, and then restart the server.
    8. Reactivate the Remote Desktop Services Licensing server by using the Telephone connection method in the Licensing Wizard.

    @Quelle: http://support.microsoft.com/kb/2477176

    2. Auf dem Thin Client

    1. Start Registry Editor.
    2. Locate and then click the following registry subkey:

      Schlüssel HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing
    3. On the Registry menu, click Export Registry File.
    4. Type exported-MSLicensing in the File name box, and then click Save.

      NOTE: If you have to restore this registry subkey in the future, double-click the Exported-parameters.reg file that you saved in this step.
    5. Right-click of the Folder, click Delete, and then click Yes.
    6. Restart the Client and try again.

    @Quelle: http://support.microsoft.com/kb/187614

    Mit freundlichen Grüßen aus Darmstadt

    Andree Marquardt

    Opticom IT-Systemhaus GmbH

    Homepage: www.opticom.it


    Freitag, 13. Juli 2012 11:51

Alle Antworten

  • Am 11.07.2012 11:15, schrieb Dennis_K5121:
    > Der Server auf dem die RDP Dienste sind bringt die Meldung: "Because of
    > a security error, the client could not connect to the remote computer"
     
    Suche in den RDS Settings oder den Systemeigenschaften oder den GPOs:
    Verbindung von Computern zulassen auf deinen eine beliebige Version von
    Remotedesktop ausgeführt wird. (weniger Sicherheit)
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm
     
    Mittwoch, 11. Juli 2012 09:21
  • Also wenn du den Punkt in den Systemeigenschaften meinst, der ist bereits aktiviert und auch nicht grau, somit sollte er also auch durch keine GPO gesetzt werden.

    Mittwoch, 11. Juli 2012 09:28
  • Ergänzend hierzu noch ein paar weitere Details:

    - NLA ist deaktiviert

    - Andere Maschinen (mit anderen OS) können problemlos auf den Server zugreifen

    - Der Client kann auf die Freigaben des Servers zugreifen (kein Netzwerkproblem)

    Mittwoch, 11. Juli 2012 13:10
  • Hallo Dennis,

    schau dir mal den generellen Troubleshooting Artikel "Remote Desktop disconnected or can’t connect to remote computer or to Remote Desktop server (Terminal Server) that is running Windows Server 2008 R2" unter [1] an. Hier werden mehrere Möglichkeiten und die zugehörige Lösung beschrieben, die für das Problem verantwortlich sein können.

    Viele Grüße
    Jonathan Bechtle
    TechNet Hotline für TechNet Online Deutschland

    [1] http://support.microsoft.com/kb/2477176 - Remote Desktop disconnected or can’t connect to remote computer or to Remote Desktop server (Terminal Server) that is running Windows Server 2008 R2

    Disclaimer:
    Bitte haben Sie Verständnis dafür, dass wir hier auf Rückfragen gar nicht oder nur sehr zeitverzögert antworten können.
    Bitte nutzen Sie für Rückfragen oder neue Fragen den telefonischen Weg über die TechNet Hotline:

    TechNet Hotline: Schnelle & kompetente Hilfe für IT-Pros: kostenfrei!

    Es gelten für die TechNet Hotline und dieses Posting diese Nutzungsbedingungen, Hinweise zu Markenzeichen sowie die allgemein gültigen Informationen zur Datensicherheit sowie die gesonderten Nutzungsbedingungen für die TechNet Hotline.

    Mittwoch, 11. Juli 2012 14:14
    Moderator
  • Hallo Dennis,

    schau dir mal den generellen Troubleshooting Artikel "Remote Desktop disconnected or can’t connect to remote computer or to Remote Desktop server (Terminal Server) that is running Windows Server 2008 R2" unter [1] an. Hier werden mehrere Möglichkeiten und die zugehörige Lösung beschrieben, die für das Problem verantwortlich sein können.

    Danke, aber den Artikel habe ich auch schon durch:

    1) Zuviele gleichzeitige Verbindungen sind es definitiv nicht. Momentan testen wir nur mit einem User

    2) Port Konflikt schon geprüft, kann ausgeschlossen werden

    3) Verschlüsselungsmethoden habe ich auch schon durchprobiert, aktuell steht das Encryption Level auf Low, Client Compatibel habe ich auch schon getestet

    4) Den Lösungsvorschlag die Zertifikatseinräge in der Registry zu löschen habe ich schon durchgeführt, leider auch ohne Erfolg

    Mittwoch, 11. Juli 2012 14:49
  • Am 11.07.2012 16:49, schrieb Dennis_K5121:
    > Danke, aber den Artikel habe ich auch schon durch:
     
    Hast du einen anderen Alternativen RDP Client, der nicht Version 6.0
    oder höher hat? zB ein altes NT4 in einer VM wäre jetzt nicht schlecht,
    oder eben in 30 Minuten schnell installiert. Mac odre Linux sollte zum
    Test auch reichen.
     
    Ich frage mich gerade: Lässt dein 2008 R2 dieses spezielle CE 5.0 nicht
    durch, oder allen "alten RDP Versionen".
     Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm
     
    Mittwoch, 11. Juli 2012 14:55
  • Hallo,

    ich bin ein Arbeitskollege von Dennis_K5121.

    Wir konnten nun das Problem wie folgt lösen:

    1.Auf dem Server

    1. Make sure that the Remote Desktop server registry has been successfully backed up and the Licensing Server is Deactivated.
    2. Start Registry Editor.
    3. Locate and then click the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM
    4. On the Registry menu, click Export Registry File.
    5. Type exported-Certificate in the File name box, and then click Save.

      NOTE: If you have to restore this registry subkey in the future, double-click the Exported-parameters.reg file that you saved in this step.
    6. Right-click each of the following values, click Delete, and then click Yes to confirm the deletion:

      Certificate
      X509 Certificate
      X509 Certificate ID
      X509 Certificate2
    7. Quit Registry Editor, and then restart the server.
    8. Reactivate the Remote Desktop Services Licensing server by using the Telephone connection method in the Licensing Wizard.

    @Quelle: http://support.microsoft.com/kb/2477176

    2. Auf dem Thin Client

    1. Start Registry Editor.
    2. Locate and then click the following registry subkey:

      Schlüssel HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing
    3. On the Registry menu, click Export Registry File.
    4. Type exported-MSLicensing in the File name box, and then click Save.

      NOTE: If you have to restore this registry subkey in the future, double-click the Exported-parameters.reg file that you saved in this step.
    5. Right-click of the Folder, click Delete, and then click Yes.
    6. Restart the Client and try again.

    @Quelle: http://support.microsoft.com/kb/187614

    Mit freundlichen Grüßen aus Darmstadt

    Andree Marquardt

    Opticom IT-Systemhaus GmbH

    Homepage: www.opticom.it


    Freitag, 13. Juli 2012 11:51