none
Spezialisierung Fehlgeschlagen RRS feed

  • Allgemeine Diskussion

  • Hallo,

    Ich habe ein Windows 7 (Pro 32bit en) Installation auf einem Referenzcomputer erstellt, welche über die Deployment/Reseal Komponente zunächst im Audit-Modus gestartet wird, wo zusätzliche Software eingespielt wurde. Nachdem Sysprep (generalize) ausgeführt wird, tritt beim nächsten Neustart (des Referenzcomputers) offenbar ein Problem im Spezialize-Pass auf, so dass das Setup nach der Geräteinstallation abbricht.

    Die Antwort- und Logdateien: 


    Sysprep-Antwortdatei (oobe.xml):
    <?xml version="1.0" encoding="utf-8"?>
    
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    
      <settings pass="generalize">
    
        <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
          <DoNotCleanUpNonPresentDevices>false</DoNotCleanUpNonPresentDevices>
    
          <PersistAllDeviceInstalls>false</PersistAllDeviceInstalls>
    
        </component>
    
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
          <SkipRearm>1</SkipRearm>
    
        </component>
    
      </settings>
    
      <settings pass="specialize">
    
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
          <ProductKey>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</ProductKey>
    
          <ComputerName>fellow2011-ref</ComputerName>
    
          <RegisteredOrganization>Wissenschaftskolleg zu Berlin</RegisteredOrganization>
    
          <ShowWindowsLive>false</ShowWindowsLive>
    
          <CopyProfile>true</CopyProfile>
    
        </component>
    
    
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
          <Identification>
    
            <Credentials>
    
              <Domain>DOMAIN</Domain>
    
              <Password>PASSWORD</Password>
    
              <Username>administrator</Username>
    
            </Credentials>
    
            <JoinDomain>DOMAIN</JoinDomain>
    
          </Identification>
    
        </component>
    
      </settings>
    
      <settings pass="oobeSystem">
    
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
          <OOBE>
    
            <HideEULAPage>true</HideEULAPage>
    
            <NetworkLocation>Work</NetworkLocation>
    
            <ProtectYourPC>3</ProtectYourPC>
    
            <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
    
          </OOBE>
    
          <UserAccounts>
    
            <AdministratorPassword>
    
              <Value>PASSWORD</Value>
    
              <PlainText>false</PlainText>
    
            </AdministratorPassword>
    
            <LocalAccounts>
    
              <LocalAccount wcm:action="add">
    
                <Password>
    
                  <Value>PASSWORD</Value>
    
                  <PlainText>false</PlainText>
    
                </Password>
    
                <Description>Local Administrator</Description>
    
                <DisplayName>Administrator</DisplayName>
    
                <Name>Administrator</Name>
    
                <Group>Administrators</Group>
    
              </LocalAccount>
    
            </LocalAccounts>
    
          </UserAccounts>
    
          <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
    
          <ShowWindowsLive>false</ShowWindowsLive>
    
          <RegisteredOrganization>Wissenschaftskolleg zu Berlin</RegisteredOrganization>
    
          <Themes>
    
            <DesktopBackground>C:\wikoDesktopBlau.jpg</DesktopBackground>
    
            <BrandIcon>C:\wikoIconBlau.jpg</BrandIcon>
    
            <ThemeName>WikoFellowTheme</ThemeName>
    
          </Themes>
    
          <TimeZone>W. Europe Standard Time</TimeZone>
    
          <AutoLogon>
    
            <Password>
    
              <Value>PASSWORD</Value>
    
              <PlainText>false</PlainText>
    
            </Password>
    
            <Enabled>true</Enabled>
    
            <LogonCount>1</LogonCount>
    
            <Username>administrator</Username>
    
          </AutoLogon>
    
        </component>
    
        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    
          <InputLocale>en-US</InputLocale>
    
          <SystemLocale>en-US</SystemLocale>
    
          <UILanguage>en-US</UILanguage>
    
          <UserLocale>en-US</UserLocale>
    
          <UILanguageFallback>en-US</UILanguageFallback>
    
        </component>
    
      </settings>
    
      <cpi:offlineImage cpi:source="catalog:c:/XXX/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    
    </unattend>
    

    Log C:\Windows\Panther\setuperr.log :

     

    2011-08-10 14:40:32, Error   [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\system32\capisp.dll,CryptoSysPrep_Specialize', returned error code 5[gle=0x000003e5]
    
    2011-08-10 14:40:32, Error   [0x060435] IBS  Callback_Specialize: An error occurred while either deciding if we need to specialize or while specializing; dwRet = 0x5

     


    Log C:\Windows\Panther\setupact.log :

     

    2011-08-10 14:38:40, Info    [0x0601c1] IBS  InstallWindows:Install Path = C:\Windows\system32\oobe
    
    2011-08-10 14:38:40, Info    [0x0601c2] IBS  InstallWindows:Setup Phase = 4
    
    2011-08-10 14:38:40, Info             [setup.exe] OrchestrateUpdateImageState: Updating image state from [IMAGE_STATE_GENERALIZE_RESEAL_TO_OOBE] --> [IMAGE_STATE_UNDEPLOYABLE]
    
    2011-08-10 14:38:40, Info    [0x0601ee] IBS  PrepareSetupForFirstBootPhase:Working directory is [C:\Windows\Panther]; we are starting an installation
    
    2011-08-10 14:38:40, Info         IBS  PrepareSetupForFirstBootPhase:Passed drive-letter assignment sanity check.
    
    2011-08-10 14:38:40, Info    [0x0601cc] IBS  InstallWindows:Performing a new install from first boot phase. Working directory = C:\Windows\Panther
    
    2011-08-10 14:38:40, Info    [0x0601ce] IBS  Setup has started phase 4 at 2011-08-10 14:38:40
    
    2011-08-10 14:38:40, Info    [0x0601cf] IBS  Install source is C:\Windows\system32\oobe
    
    2011-08-10 14:38:40, Info    [0x0601d0] IBS  Build version is 6.1.7600.16385 (win7_rtm.090713-1255)
    
    2011-08-10 14:38:40, Info    [0x064042] IBSLIB CreateSetupBlackboard:Creating new blackboard path is [C:\Windows\Panther\SetupInfo] Setup phase is [4]
    
    2011-08-10 14:38:40, Info    [0x090008] PANTHR CBlackboard::Open: C:\Windows\Panther\SetupInfo succeeded.
    
    2011-08-10 14:38:40, Info    [0x064043] IBSLIB CreateSetupBlackboard:Successfully created/opened Setup black board path is [C:\Windows\Panther\SetupInfo]
    
    2011-08-10 14:38:40, Info         IBS  InstallWindows:No UI language from a previous boot was found on the blackboard. Using selected language [].
    
    2011-08-10 14:38:40, Info         IBS  InstallWindows:Setup architecture is [x86]
    
    2011-08-10 14:38:40, Info    [0x0601d5] IBS  InstallWindows:Starting with Empty Queue. Setup Phase = 4
    
    2011-08-10 14:38:40, Info         PANTHR InitializedCriticalSection for pExecQueue->csLock;
    
    2011-08-10 14:38:40, Info         PANTHR InitializeModule: Initializing ExecQueue->csLock;
    
    2011-08-10 14:38:40, Info         PANTHR InitializeModule: Initializing ExecQueue->csLock;
    
    2011-08-10 14:38:40, Info    [0x0601a4] IBS  LoadWorkerModules:Successfully added worker module ScenarioDetect in winsetup.dll
    
    2011-08-10 14:38:40, Info         PANTHR InitializeModule: Initializing ExecQueue->csLock;
    
    ZEILEN GELOESCHT
    
    
    2011-08-10 14:38:50, Info         SYSPRP Re-checking active status...
    
    
    2011-08-10 14:38:51, Info         SYSPRP SPPNP: Reinstalling devices on the system...
    
    2011-08-10 14:38:51, Info         SYSPRP Status: Starting...
    
    
    2011-08-10 14:38:51, Info         SYSPRP Status: Total = 0,	Complete = 0, 	Progress = 0%	(0%)
    2011-08-10 14:40:30, Info         SYSPRP Status: Active
    
    
    2011-08-10 14:40:30, Info         SYSPRP Status: Total = 285,	Complete = 285, 	Progress = 100%	(100%)
    
    
    2011-08-10 14:40:30, Info         SYSPRP Callback canceled operation, Err = 1223!
    
    
    2011-08-10 14:40:30, Info         SYSPRP DeviceInstallStatusThreadProc failed, Err = 1223
    
    
    2011-08-10 14:40:32, Info         SYSPRP SPPNP: Devices reinstallation completed.
    
    2011-08-10 14:40:32, Info         SYSPRP Waiting for thread to exit
    
    2011-08-10 14:40:32, Info         SYSPRP Thread exited
    
    2011-08-10 14:40:32, Info         SYSPRP SPPNP: Sysprep_Specialize_Pnp: Exit
    
    2011-08-10 14:40:32, Info    [0x0f0081] SYSPRP LaunchDll:Successfully executed 'C:\Windows\System32\sppnp.dll,Sysprep_Specialize_Pnp' without error
    
    2011-08-10 14:40:32, Info    [0x0f008b] SYSPRP RunRegistryDlls:Found entrypoint in registry at SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\SysPrep\Specialize\{2172c981-2c23-e969-b30d-046ffeeb096e}; will try to launch 'C:\Windows\system32\capisp.dll,CryptoSysPrep_Specialize'
    
    2011-08-10 14:40:32, Info    [0x0f0080] SYSPRP LaunchDll:Found 'C:\Windows\system32\capisp.dll,CryptoSysPrep_Specialize'; executing it
    
    2011-08-10 14:40:32, Info             capisp.dll::CheckIFCryptoSysPrepSpecialized: returning 0
    
    2011-08-10 14:40:32, Info             capisp.dll::CryptoSysPrep_Specialize: assigned CAPI machine guid "cf9853bc-160b-40ef-b8c3-0081c56d506c"
    
    2011-08-10 14:40:32, Info             capisp.dll::DisableAdministratorIfApplicable disabled the admin account.
    
    2011-08-10 14:40:32, Info             capisp.dll::CryptoSysPrep_Specialize: returning 5
    
    2011-08-10 14:40:32, Error   [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\system32\capisp.dll,CryptoSysPrep_Specialize', returned error code 5[gle=0x000003e5]
    
    2011-08-10 14:40:32, Info         IBS  Callback_Specialize: Internal Providers Specialized Failed. System can't proceed to handle Internal Providers
    
    2011-08-10 14:40:32, Info         IBS  Callback_Specialize: Specialize return: [5]
    
    2011-08-10 14:40:32, Error   [0x060435] IBS  Callback_Specialize: An error occurred while either deciding if we need to specialize or while specializing; dwRet = 0x5
    
    2011-08-10 14:40:32, Info    [0x0640ae] IBSLIB PublishMessage: Publishing message [Windows Setup could not configure Windows to run on this computer's hardware.]
    
    2011-08-10 14:40:38, Info    [0x070042] DIAG  CallBack_DiagnosticDataSend: Called with notification for Error published by ErrorHandler
    
    2011-08-10 14:40:38, Info         DIAG  CallBack_DiagnosticDataSend: Setup was started from Phase 4. Disabling Diagnostics [DiagnosticDataSend] in this scenario
    
    2011-08-10 14:40:38, Info    [0x090095] PANTHR WdsExitImmediate called! Execution will stop, and the queue won't be saved.
    
    2011-08-10 14:40:38, Info         IBS  Callback_Specialize: Exit.
    
    2011-08-10 14:40:38, Info    [0x09008c] PANTHR SeqExecute -- stopping, since WdsExitImmediate() was called
    
    2011-08-10 14:40:38, Info    [0x090086] PANTHR pWorkerThreadFunc -- Stopping
    
    2011-08-10 14:40:38, Info    [0x090086] PANTHR pWorkerThreadFunc -- Stopping
    
    2011-08-10 14:40:38, Info    [0x090086] PANTHR pWorkerThreadFunc -- Stopping
    
    2011-08-10 14:40:38, Info         PANTHR DeleteCriticalSection for pExecQueue->csLock;
    
    2011-08-10 14:40:38, Info    [0x0605a6] IBS  Requested UI to hide the language and locale selection pages.
    
    2011-08-10 14:40:38, Info    [0x090081] PANTHR Destroying any unreferenced modules! (SEQ6)
    
    2011-08-10 14:40:38, Info    [0x0601d7] IBS  InstallWindows:Error Type = 3211266
    
    2011-08-10 14:40:38, Info    [0x090009] PANTHR CBlackboard::Close: c:\windows\panther\setupinfo.


     

    Mittwoch, 10. August 2011 14:43

Alle Antworten

  • Hallo,

    das Problem wird höchstwahrscheinlich von einem Treiber verursacht. Versuche mal herauszufinden, welcher Treiber dafür verantwortlich ist.

    Im folgenden RegKey kann man sehen, welche möglichen Treibern das Problem verursachen:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\Sysprep\Specialize

    Versuche auch die Image neu zu erstellen und wenn möglich, nur die wichstigsten Treibern mitnehmen.

    Gruss,
    Raul

    Dienstag, 16. August 2011 14:37