none
can't login WDS server with right account

    Frage

  • I encountered a weird issue. There're two same machines. One can install Windows 2008 R2 correctly in PXE mode, but the other machine get error message before selecting OS window displays. Installation program prompts to select locate & keyboard layout, then it need me to entry account name/password to connect to WDS server. But I have set unattended mode and it works on other machine. 
    I search log file and see below message in setuperr.log:

    Callback_WdsClient_ConnectToImageStore: Connect to Image Store failed. Error code [0x80070056].[gle=0x00000056]
    Callback_WdsClient_Unattend: Error processing unattended login. Error [0x80070056][gle=0x00000056]
    Callback_WdsClient_Unattend: Error in wdsclient unattend settings. Error [0x80070056][gle=0x00000056]

    I deploy Windows 2008 R2 under Windows 2003 SP1. The boot image comes from Windows 7 ISO.

    Any advice is appreciated.
    Donnerstag, 20. August 2009 04:04

Alle Antworten

  • I've encountered the same issue.
    More specifically if you deploy Vista or 2008 (R1) you will not get this error. However if you deploy Seven or 2008 (R2) you will encounter this issue.
    I've installed a new 2008 machine in the network, installed WDS on THAT one and then it works fine...

    To solve YOUR issue. instead of using a Domain Account, use a Local Administrator account from the WDS server you are booting from. That will work.. for some strange reason.
    However if you put that account in an answer file it will not work. Don't ask me why this is a pure Windows 7 issue in combination with a 2003 Domain/WDS server.
    • Als Antwort vorgeschlagen Arend Pronk Montag, 16. November 2009 11:06
    Montag, 16. November 2009 11:02
  • 0x80070056 is ERROR_INVALID_PASSWORD. How are you specifying the unattend file to use?
    Dienstag, 17. November 2009 01:33
  • Thanks, Arend, that worked for me! (i was using w2012 server)
    Dienstag, 28. März 2017 09:34