none
SCVMM 2012R2 - Hyper-V Clster - wo ist Knoten 1? RRS feed

  • Frage

  • Hallo

    Ich habe einen hyper-V Cluster (alles 2012R2) auf einem SMB3 Share als Datastore

    Dann einen SCVMM 2012R2 installiert und versucht den Cluster als Ressouce hinzuzufügen. Nach dem ersten Stolperstein (htte das SCVMm Systemkonto für die Hosts versucht) habe ich eine Kopie vom Administrator gemacht, diesen Account unter SCVMM hinzugefügt und einen weiteren Versuch gestartet.

    Jetzt sehr ich Knoten 2, aber nicht Knoten 1. Ein weiterer Scan findet keine entsprechenden Server (was passiert eigentlich, wenn ich den Cluster aus dem SCVMM entferne? Löscht er das AD Objekt?

    Wie bekomme ich den 1 Knoten auch angezeigt (eigentlich da ist er ja)

    siehe Screenshot

    Viele Grüße

    Lutz Rahe

    Donnerstag, 4. Juni 2015 13:27

Antworten

  • Hallo Lutz, 

    wenn du das Cluster aus dem SCVMM löscht bleibt das Cluster erhalten. Er löscht es nur aus der SCVMM Datenbank und du kannst es nicht mehr verwalten. 

    Eine Frage, ist dein SCVMM Service Account lokaler Administrator auf den Clusterknoten? 

    Wäre wichtig, da jede Aktion des VMM in dem Kontext ausgeführt wird. 

    Das kann z.B. ein Grund sein warum dein 2ter Host nicht discovered wird. 

    Wie sieht der Jobstatus um VMM aus? Irgendwelche Fehler? 

    LG 

    Flo 

    Donnerstag, 4. Juni 2015 15:03
  • Hallo, 

    normalerweise sollten die VMs automatisch beim Anfügen des Clusters in VMM importiert werden. 

    Ich kann mir vorstellen, dass du das Storage noch nicht richtig konfiguriert hast. 

    Schau mal bitte ob du SMI-S auf den SOFS Cluster Nodes installiert hast und dein VMM, das Hyper-V Cluster und die Hyper-V Hosts Vollzugriff auf den Share haben. 

    Mehr Infos findest du hier :) 

    https://datatothepeople.wordpress.com/2014/01/19/unmanaged-smb-3-0-shares-in-scvmm2012-r2/

    Was anderes fällt mir gerade auf die schnelle nicht ein. 

    LG 

    Flo 

    Samstag, 6. Juni 2015 15:17

Alle Antworten

  • Hallo Lutz, 

    wenn du das Cluster aus dem SCVMM löscht bleibt das Cluster erhalten. Er löscht es nur aus der SCVMM Datenbank und du kannst es nicht mehr verwalten. 

    Eine Frage, ist dein SCVMM Service Account lokaler Administrator auf den Clusterknoten? 

    Wäre wichtig, da jede Aktion des VMM in dem Kontext ausgeführt wird. 

    Das kann z.B. ein Grund sein warum dein 2ter Host nicht discovered wird. 

    Wie sieht der Jobstatus um VMM aus? Irgendwelche Fehler? 

    LG 

    Flo 

    Donnerstag, 4. Juni 2015 15:03
  • Hallo

    Danke für den Tipp. Ich habe das Clusterobjekt im SCVMM gelöscht und dann neu (unter Fabric) hinzugefügt. Dann wurden jetzt auch beide Knoten ohne Probleme gefunden und mit eingebunden.

    Zusätzlich habe ich auch unter Speicher (Anbieter) meinen "Dateiserver" eingebunden mit den 3 SMB3.0 Freigaben "Hyper-V", "Quorum" und "Mailstore" (mit entsprechenden Klassifizierungen)

    Wenn ich jetzt unter "VMs und Dienste" mir den Cluster anschaue sehe ich die ganzen VMs die dort laufen. Eine (ein DC) läuft auf einem lokalen Storage von einem Knoten, er wird auch dargestellt (incl. Betriebssystem etc)

    alle anderen VMs die auf dem SMB3 Share "Hyper-V" liegen, sind "unbekannt" und haben auch 0 Byte Größe.

    ???

    Wie bekomme ich denn diese VMs jetzt in den SCVMM eingebunden?

    Gruß

    Lutz

    P.S.: Das hat damals auf der Schulung leider auch schon nicht geklappt :-)



    • Bearbeitet Lutz Rahe Freitag, 5. Juni 2015 08:51 Tippfehler
    Freitag, 5. Juni 2015 08:49
  • Hallo, 

    normalerweise sollten die VMs automatisch beim Anfügen des Clusters in VMM importiert werden. 

    Ich kann mir vorstellen, dass du das Storage noch nicht richtig konfiguriert hast. 

    Schau mal bitte ob du SMI-S auf den SOFS Cluster Nodes installiert hast und dein VMM, das Hyper-V Cluster und die Hyper-V Hosts Vollzugriff auf den Share haben. 

    Mehr Infos findest du hier :) 

    https://datatothepeople.wordpress.com/2014/01/19/unmanaged-smb-3-0-shares-in-scvmm2012-r2/

    Was anderes fällt mir gerade auf die schnelle nicht ein. 

    LG 

    Flo 

    Samstag, 6. Juni 2015 15:17