none
Connector-Installation für Windows Home Server 2011 schlägt fehl: Running MSI threw an exception RRS feed

  • Frage

  • Hallo zusammen,


    seit dem 21.08.2012, als sowohl auf dem WHS 2011 wie auch auf einem Windows 7-64 PC (mit AMD-CPU) via Windows Update mehrere Patches Installiert wurden, läßt sich der Home Server Connector auf dem W7-64 und einem W8-Preview nicht mehr installieren. Bis dahin hatte ich bei dem W7 Rechner ein Jahr keinerlei Probleme, auch W8 lief monatelang gut.

    Bis ca. 95% des Installationsdialoges sieht es gut aus (auf dem WHS startet sogar schon das Client-BackUp), dann (nach ca. 20 Minuten Stillstand) wird die Installation (sehr schnell) zurückgerollt und mit einem 'Unbekannten Fehler" beendet.

    Hier ein Auszug aus dem C:\ProgramData\Microsoft\Windows Server\Logs\ClientDeploy.log:
    >>>
    [3932] 120903.210509.7010: ClientSetup: Entering DownloadSoftwareTask.Run
    [3932] 120903.210509.7010: ClientSetup: Download client package ClientCore.cab
    [3932] 120903.210509.7010: ClientSetup: Download file ClientCore.cab from server
    [3932] 120903.210509.7010: ClientSetup: Making web request: System.Net.HttpWebRequest
    [3932] 120903.210534.4270: ClientSetup: Downloaded file C:\Windows\Temp\Client Deployment Files\ClientCore.cab
    [3932] 120903.210534.6922: ClientSetup: Found MSI file within cab: ClientCore.msi
    [3932] 120903.210534.6922: ClientSetup: Found MSP file within cab: KB2705129-amd64.msp
    [3932] 120903.210534.6922: ClientSetup: Exiting DownloadSoftwareTask.Run
    [3932] 120903.210534.6922: ClientSetup: Task with Id=ClientDeploy.DownloadSoftware has TaskStatus=Success
    [3932] 120903.210534.6922: ClientSetup: Task with Id=ClientDeploy.DownloadSoftware has RebootStatus=NoReboot
    [3932] 120903.210534.6922: ClientSetup: Running Task with Id=ClientDeploy.InstallSoftware
    [3932] 120903.210534.6922: ClientSetup: Entering InstallSoftwareTask.Run
    [3932] 120903.210534.6922: ClientSetup: Install package C:\Windows\Temp\Client Deployment Files\ClientCore.msi
    [3932] 120903.210534.7078: ClientSetup: Running MSI: C:\Windows\Temp\Client Deployment Files\ClientCore.msi  SOFTWARE_NAME="Windows Home Server 2011" ADMIN_USERNAME="Administrator" ADMIN_PASSWORD=******* PATCH="C:\Windows\Temp\Client Deployment Files\KB2705129-amd64.msp" REBOOT=ReallySuppress
    [3932] 120903.212550.6313: ClientSetup: Running MSI threw an exception:Microsoft.Deployment.WindowsInstaller.InstallerException: Schwerwiegender Fehler bei der Installation.
       at Microsoft.Deployment.WindowsInstaller.Installer.CheckInstallResult(UInt32 ret)
       at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.Helper.RunMsi(String msiPathOrProductCode, String logFilePath, Dictionary`2 msiProperties, Boolean install, ProgressChangedEventHandler progressHandler)
    [3932] 120903.212550.6313: ClientSetup: RunMsi returned error: RetCode=1603
    [3932] 120903.212550.6313: ClientSetup: Failed to install C:\Windows\Temp\Client Deployment Files\ClientCore.msi
    [3932] 120903.212550.6313: ClientSetup: Exting InstallSoftwareTask.Run
    <<<

    Gruss
    Holger
    Dienstag, 4. September 2012 20:21

Alle Antworten

  • Moin Holger,

    dieser Thread im englischsprachigen WHS 2011-Forum macht Fehler in der Aufgabenplanung dafür verantwortlich. Das scheint aber nicht Dein Problem zu sein, da das dort beschriebene Failed im Log fehlt.

    Hast Du mal versucht, aus dem Internet Explorer (32 Bit) die Seite http://deinservername/connect aufzurufen und darüber die Installation zu initiieren?

    Viele Grüße
    Olaf

    Freitag, 14. September 2012 14:05