none
Start-Transcript fehler (... is not recognized as the name)

    Frage

  • Hi,

    wenn ich in der Powershell "Start-Transcript" ausführen will, erhalte ich folgenden Fehler:

    Start-Transcript : The term 'Start-Transcript' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was
    included, verify that the path is correct and try again.
    At line:1 char:1
    + Start-Transcript
    + ~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Start-Transcript:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    mein System: Win7 SP1, PS 5.1.14409.1012 und PS6 Core Portable.

    In PS6 funktioniert Transcript und in PS5 nicht mehr, seit dem ich in PS6 einen SymbolicLink auf das WindowsPowershell-Profil Verzeichnis mit

    "New-Item -ItemType SymbolicLink -Path (Join-Path -Path $Env:USERPROFILE -ChildPath Documents) -Name PowerShell -Target (Join-Path -Path $Env:USERPROFILE -ChildPath Documents\WindowsPowerShell)"

    gesetzt habe und dann wieder gelöscht habe.

    Powershell 5 deinstallieren und neu installieren hat nichts gebracht.

    Kann man CMDLets wieder neu registrieren?

    Dienstag, 13. März 2018 15:35

Antworten

  • Ich habe den Fehler gefunden.

    Im "..\WindowsPowerShell\Modules\" gab ein Ordner Namens "Add-on.Transcription". Diesen umbenannt und seit dem ist wieder alles schön.

    Trotzdem ein fettes DANKE.

    • Als Antwort markiert tytn2010 Donnerstag, 15. März 2018 16:11
    Donnerstag, 15. März 2018 16:11

Alle Antworten

  • > "New-Item -ItemType SymbolicLink -Path (Join-Path -Path $Env:USERPROFILE -ChildPath Documents) -Name PowerShell -Target (Join-Path -Path $Env:USERPROFILE -ChildPath Documents\WindowsPowerShell)"
     Hm - wenn ich die Variablen mal auflöse, hast Du einen Symlink

    C:\Users\Hugo\Documents\Powershell

    erstellt, der auf

    C:\Users\Hugo\Documents\WindowsPowershell

    zeigt?

    Wie hast Du den denn wieder gelöscht?

    Mittwoch, 14. März 2018 11:39
  • Händisch im Windows-Explorer.
    Mittwoch, 14. März 2018 14:00
  • Dann bin ich raus - keine Ahnung, was das mit dem Vorhandensein von Cmdlets zu tun haben sollte?!?

    Mittwoch, 14. März 2018 14:49
  • Ich habe den Fehler gefunden.

    Im "..\WindowsPowerShell\Modules\" gab ein Ordner Namens "Add-on.Transcription". Diesen umbenannt und seit dem ist wieder alles schön.

    Trotzdem ein fettes DANKE.

    • Als Antwort markiert tytn2010 Donnerstag, 15. März 2018 16:11
    Donnerstag, 15. März 2018 16:11