none
SBS 2003 + ISA 2004 - EventID 7001 - Zeitüberschreitung (30000 ms) beim Warten auf eine Transaktionsrückmeldung RRS feed

  • Frage

  • Hallo,

    ich erhalte bei einem SBS 2003 Premium alle 2-3 Tage einen kompletten Abbruch der Komunikation intern und extern. Im Ereignisprotokoll wird folgende Meldung protokolliert:

    Zeitüberschreitung (30000 ms) beim Warten auf eine Transaktionsrückmeldung von Dienst MSSQL$MSFW. EventID 7001.

    Der Firewalldienst steht anschließend auf gestoppt und kann per ISA Konsole bzw. Dienstemanager neu gestartet werden. Das ist aber nicht unbedingt die Lösung ...

    Im RAID Manager sind keine Probleme protokolliert.

    Hat hierzu jemand evtl. eine Idee?

    Herzlichen Dank vorab,

    Gruß Martin

    Montag, 29. August 2011 14:08

Antworten

  • Hallo Tobias,

    der Experte meiner Wahl bin ich selbst - inzwischen konnte das Problem gelöst werden: Der IBM RAID Controller war defekt und wurde getauscht. Mit neuem Controller und neuem BIOS ist das Problem nun endlich behoben.

    Vielen Dank noch mal für die Lösungsvorschläge.

    Danke Martin

    • Als Antwort markiert sys1 Mittwoch, 22. Februar 2012 17:16
    Mittwoch, 22. Februar 2012 17:16

Alle Antworten

  • Hi Martin,
     
    > ich erhalte bei einem SBS 2003 Premium alle 2-3 Tage einen kompletten
    > Abbruch der Komunikation intern und extern. Im Ereignisprotokoll wird
    > folgende Meldung protokolliert:
    >
    > Zeitüberschreitung (30000 ms) beim Warten auf eine
    > Transaktionsrückmeldung von Dienst MSSQL$MSFW. EventID 7001.
    >
    > Der Firewalldienst steht anschließend auf gestoppt und kann per ISA
    > Konsole bzw. Dienstemanager neu gestartet werden. Das ist aber nicht
    > unbedingt die Lösung ...
    >
    > Im RAID Manager sind keine Probleme protokolliert.
    >
    > Hat hierzu jemand evtl. eine Idee?
     
    höchstwahrscheinlich hat Dein SQL-Dienst "MSSQL$MSFW" ein Problem, was noch
    näher untersucht werden muss.
     
    Das Standard-Verhalten einer ISA 2004 ist, dass, wenn es nicht mehr
    protokolieren kann, es in "Lockdown-Mode" übergeht (s.a.
    Schaden für das Netzwerk (z.b. bei einer DoS-Attacke gegen ISA) zu
    gewährelisten.
     
    Deswegen:
     
    1, Untersuche, wieso der SQL-Server "MSSQL$MSFW" Performance-Probleme hat
    2. Als Workaround bis dahin kannst Du das Logging auf eine andere
    Logging-Methode (z.B. File) umstellen
     
    Weitere informationen bekommst Du hier:
     
    How to configure logging in ISA Server 2004
     
     
    Hintergrundinformationen:
     
    Disabling Firewall Service Lockdown due to Logging Failures
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    Dienstag, 30. August 2011 09:42
    Moderator
  • Hallo Tobia,

    vielen Herzlichen Dank für Deine Info und Links!

    Ich habe zuerst wie vorgeschlagen die Logging Methode auf File umgestellt und von der System Partition verschoben.

    Ich werde das die nächsten Tage beobachten und melde mich dann.

    Gruß

    Martin

    Dienstag, 30. August 2011 15:07
  • Hallo Tobias,

    nachdem ich das Logging komplett deaktiviert habe, ist das Problem nicht mehr aufgetreten - die Umstellung bzgl. File und alternative Partition hat leider keine Verbesserung gebracht.

    Warum der ISA Server im "Lockdown-Mode" seinen Betrieb quasi einstellt ist mir nicht klar - das Einstellen des Loggings wäre für mich noch nachzuvollziehbar, aber die komplette Funktionalität?

    Der Server hat trotz aktueller Hardware anscheinend Performance Probleme beim Festplattenzugriff - was dafür verantwortlich ist, kann ich trotz intensiver Suche nicht feststellen. Evtl. hast Du noch einen Tip in dieser Richtung. Ich habe versucht mit dem Leistungsmonitor zu arbeiten, aber hier wird nur kurz (3-4 Sek.) eine 100%ige Auslastung angezeigt.

    Ich habe als Alternative einen Service geschrieben, der die DNS Auflösung prüft und ggfs. den ISA Dienst neu startet. Das klappt, ist aber nicht so ganz die erhoffte Lösung.

    Danke und Gruß

    Martin 

    Donnerstag, 6. Oktober 2011 15:20
  • Hi Martin,
     
    > nachdem ich das Logging komplett deaktiviert habe, ist das Problem nicht
    > mehr aufgetreten - die Umstellung bzgl. File und alternative Partition
    > hat leider keine Verbesserung gebracht.
    >
    > Warum der ISA Server im "Lockdown-Mode" seinen Betrieb quasi einstellt
    > ist mir nicht klar - das Einstellen des Loggings wäre für mich noch
    > nachzuvollziehbar, aber die komplette Funktionalität?
     
    Hintergründe und Workaround dazu wird hier beschrieben:
     
    Disabling Firewall Service Lockdown due to Logging Failures
     
     
    > Der Server hat trotz aktueller Hardware anscheinend Performance Probleme
    > beim Festplattenzugriff - was dafür verantwortlich ist, kann ich trotz
    > intensiver Suche nicht feststellen. Evtl. hast Du noch einen Tip in
    > dieser Richtung. Ich habe versucht mit dem Leistungsmonitor zu arbeiten,
    > aber hier wird nur kurz (3-4 Sek.) eine 100%ige Auslastung angezeigt.
    >
    > Ich habe als Alternative einen Service geschrieben, der die DNS
    > Auflösung prüft und ggfs. den ISA Dienst neu startet. Das klappt, ist
    > aber nicht so ganz die erhoffte Lösung.
     
    Eine tiefergehende Analyse des Servers ist im Rahmen dieses Forum leider
    nicht zu machen.
     
    Da ich auch aktuell ziemlich ausgelastet bin, wende Dich diesbzgl. an einen
    Experten Deiner Wahl, der Dir (gegen Bezahlung) dabei hilft.
     
     
    Mögliche Analyse:
     
    Microsoft Windows Server 2003 Performance Advisor
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    Donnerstag, 6. Oktober 2011 16:44
    Moderator
  • Hallo Tobias,

    der Experte meiner Wahl bin ich selbst - inzwischen konnte das Problem gelöst werden: Der IBM RAID Controller war defekt und wurde getauscht. Mit neuem Controller und neuem BIOS ist das Problem nun endlich behoben.

    Vielen Dank noch mal für die Lösungsvorschläge.

    Danke Martin

    • Als Antwort markiert sys1 Mittwoch, 22. Februar 2012 17:16
    Mittwoch, 22. Februar 2012 17:16