none
Ausführung eines Powershell-Skripts per Aufgabenplanung schlägt fehl (0x41306) RRS feed

  • Frage

  • Hallo Leute,

    ich möchte jeden morgen ein Powershell-Skript automatisch ausführen lassen. Dazu habe ich eine entsprechende Aufgabe in der Aufgabenplanung erstellt. Die Aufgabe ist so eingestellt, dass sie unabhängig von der Benutzeranmeldung ausgeführt werden soll. Mit dieser Einstellung wird die Aufgabe aber nicht ausgeführt und immer mit folgender Meldung beendet:

    Die letzte Ausführung dieser Aufgabe wurde durch den Benutzer beendet. (0x41306)

    Wenn ich das Skript manuell aus dem Windows-Explorer unter demselben Benutzer starte (Domänenadministrator) gibt es keinerlei Probleme.

    Hier ist die Konfiguration der Aufgabe:

    <?xml version="1.0" encoding="UTF-16"?>
    <Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
      <RegistrationInfo>
        <Date>2014-12-03T09:27:34.1179748</Date>
        <Author>domäne\administrator</Author>
      </RegistrationInfo>
      <Triggers>
        <CalendarTrigger>
          <StartBoundary>2014-12-03T05:00:00</StartBoundary>
          <Enabled>true</Enabled>
          <ScheduleByDay>
            <DaysInterval>1</DaysInterval>
          </ScheduleByDay>
        </CalendarTrigger>
      </Triggers>
      <Principals>
        <Principal id="Author">
          <UserId>domäne\administrator</UserId>
          <LogonType>Password</LogonType>
          <RunLevel>HighestAvailable</RunLevel>
        </Principal>
      </Principals>
      <Settings>
        <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
        <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
        <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
        <AllowHardTerminate>true</AllowHardTerminate>
        <StartWhenAvailable>false</StartWhenAvailable>
        <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
        <IdleSettings>
          <StopOnIdleEnd>true</StopOnIdleEnd>
          <RestartOnIdle>false</RestartOnIdle>
        </IdleSettings>
        <AllowStartOnDemand>true</AllowStartOnDemand>
        <Enabled>true</Enabled>
        <Hidden>false</Hidden>
        <RunOnlyIfIdle>false</RunOnlyIfIdle>
        <WakeToRun>false</WakeToRun>
        <ExecutionTimeLimit>PT2H</ExecutionTimeLimit>
        <Priority>7</Priority>
      </Settings>
      <Actions Context="Author">
        <Exec>
          <Command>%windir%\System32\cmd.exe</Command>
          <Arguments>C:\skripte\backupreport.cmd</Arguments>
          <WorkingDirectory>C:\skripte</WorkingDirectory>
        </Exec>
      </Actions>
    </Task>

    Und hier der Aufruf der Powershell:

    C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -NoProfile -NoLogo -NonInteractive -ExecutionPolicy Bypass -command ". 'C:\Program Files\Microsoft\Exchange Server\V14\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto; C:\skripte\backupreport.ps1"

    Habt Ihr eine Idee woran das liegen könnte?

    Gruß Markus


    • Bearbeitet Markus114 Donnerstag, 11. Dezember 2014 07:25
    Donnerstag, 11. Dezember 2014 07:24

Antworten

Alle Antworten