none
Hyper-V und Netzwerkübersicht RRS feed

  • Frage

  • Moin,

    sobald ich hier einen Hyper-V in der Domäne habe (Hyper-V Rolle auf Server 2008 R2), melden alle Domänenmitglieder beim Aufruf der Netzwerkübersicht, dass diese wegen eines Fehlers nicht erstellt werden könne. Wird die Hyper-V Rolle vom Server entfernt, klappts auch wieder mit der Netzwerkübersicht.

    Die Netzwerkübersicht wurde via Gruppenrichtlinie für die Domäne aktiviert. Was genau hat der Hyper-V mit eben dieser Netzwerkübersicht zu schaffen?


    cu, Ingo
    Dienstag, 1. Juni 2010 20:56

Antworten

  • Hallo Ingo,

    ja, aber leider keine erfreuliche. LLTD wird in einer virtuellen Umgebung weiterhin nicht unterstützt.

    Gruß,
    Andrei

    Donnerstag, 1. Juli 2010 11:00
    Moderator

Alle Antworten

  • Moin,

    kannst du mir eben sagen, von welcher "Netzwerkübersicht" du sprichst? Der Begriff sagt mir grad nix.

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Mittwoch, 2. Juni 2010 10:28
  • kannst du mir eben sagen, von welcher "Netzwerkübersicht" du sprichst?

    Vielleicht das hier:

    http://www.home-network-help.com/network-discovery.html


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Mittwoch, 2. Juni 2010 12:50
  • Moin,

    hm, okay. Und wozu braucht man sowas in einer Domäne?

    Gibt es auf dem Hyper-V-Host evtl. noch weitere Probleme im Zusammenhang mit IPv6?

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Mittwoch, 2. Juni 2010 13:42
  • "Braucht" man sicherlich nicht, ist aber in der heimischen Testumgebung trotzdem schön zu haben. Aber mich würde halt schon interessieren, wieso sich diese Features beeinflussen.

    IPv6 läuft problemlos. Im Netz werkelt eine Fritz Box mit IPv6 Firmware und SixXS Tunnel. IP Adressen werden via DHCPv6 verteilt. Konnektivität ist problemlos.

    cu, Ingo
    Mittwoch, 2. Juni 2010 18:18
  • Um die geht es, ja.
    cu, Ingo
    Mittwoch, 2. Juni 2010 18:20
  • Hallo Ingo,

    du schreibst, wegen eines Fehlers... ist dieser Fehler genauer spezifiziert oder steht wirklich nur wegen eines Fehlers?


    Peter Forster, MVP Virtual Machine, Austria
    Donnerstag, 3. Juni 2010 09:16
  • Beim Aufruf der Netzwerkübersicht kommt nach wenigen Sekunden statt des Fensterinhaltes nur der Text, dass die Netzwerkübersicht wegen eines Fehlers nicht aufgebaut werden könne. Es wird kein weiterer Fehlercode genannt, es finden sich keine Eventlogeinträge.
    cu, Ingo
    Donnerstag, 3. Juni 2010 18:36
  • Moin,

    beschreib doch bitte mal das Netzwerk - was für Server, was für Clients, wie vernetzt, und auf welchem Server aktivierst du Hyper-V? Tritt das Problem auch auf, wenn du Hyper-V auf einem anderen Server aktivierst (sofern möglich)? Tritt es auf, wenn der Hyper-V-Server nicht Domänenmitglied ist?

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Donnerstag, 3. Juni 2010 19:04
  • Irgendwie ist das mal wieder typisch. Ich habe mir gedacht, ich richte nochmal wieder die Hyper-V Rolle auf dem Server ein - und nun gehts. Verstehen muss ich das nicht. Lässt sich höchstens dadurch erklären, dass seit dem letzten Versuch mit Hyper-V irgendein Update die Problematik korrigiert hat.

    Also danke für die Aufmerksamkeit und die Hilfe.


    cu, Ingo
    Donnerstag, 3. Juni 2010 19:53
  • Moin,

    was auch immer. Schön, dass es jetzt geht.

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Donnerstag, 3. Juni 2010 20:34
  • Moin allerseits,

    Und da war ich dann doch etwas vorschnell. Es geht nämlich nicht mehr. Der Trick ist, dass das Problem tatsächlich nur auftaucht, wenn eine virtuelle Maschine läuft.

    Also ein wenig zum Netz:

    - drei physikalische Server, alle W2k8 R2 (1x DC, 1x File/Mail, 1x Backup und Hyper-V) als kleines Test- und Bastelnetz. Vernetzt mit einem nicht managementfähigen GBit Switch von 3com, an dem eine Fritzbox 7270 mit aktueller IPv6 Firmware und SixXS Tunnel hängt.

    - eine virtuelle Maschine, ebenfalls W2k8 R2, allerdings als Server Core installiert - bisher ohne weitere Funktion.

    - einige Clients, normalerweise Windows 7 x64, ein XP SP3 gibts auch noch

    IPs der Server sind fest vergeben, sowohl IPv4 als auch IPv6. Auf dem DC ist ein DHCP aktiv, der IPv4 und IPv6 an die Clients verteilt. dcdiag läuft sauber durch, DNS funktioniert. Microsofts IT Environment Health Scanner läuft ebenfalls durch und meldet keine Fehler.

    Sobald die virtuelle Maschine aktiv ist, meldet die Netzwerkerkennung "Während der Erstellung der Netzwerkübersicht ist ein Fehler aufgetreten." Im Hilfetext dazu wird erwähnt, dass möglicherweise ein Gerät im Netz sei, welches LLTD blockiert. Nach dem Shutdown der virtuellen Maschine klappts sofort wieder.

    So, und jetzt hat vielleicht jemand eine oder mehrere Ideen.


    cu, Ingo
    Freitag, 4. Juni 2010 18:11
  • Hallo Ingo,

    könntest du testhalber den LLTD Responder auf den Core Server deaktivieren damit dieser als Ursache ausgeschlossen werden kann?

    Computerkonfiguration\Administrative Vorlagen\Netzwerk\Verbindungsschicht-Topologieerkennung\Treiber für den Beantworter (RSPNDR) aktivieren

    Gruß
    Andrei

    Montag, 7. Juni 2010 09:45
    Moderator
  • Moin,

    auch wenn die Frage jetzt nicht besonders originell ist: Was sagt denn die VM zu der ganzen Geschichte? Wie ist die eingerichtet?

    Äußert sich der Hyper-V-BPA dazu?

    Gruß, Nils

     


    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Montag, 7. Juni 2010 13:15
  • Ich habe einfach mal testweise einen normalen Server 2008 R2 installiert, das macht die Sache dann einfacher. Der Dienst rspndr wurde beendet, damit klappt die Netzwerkübersicht an allen anderen Systemen. Sobald der Dienst wieder gestartet wird, meldet sich sofort der Fehler wieder, dass die Übersicht nicht erstellt werden könne.

     


    cu, Ingo
    Montag, 7. Juni 2010 20:58
  • Der BPA meckert natürlich erst einmal an, dass die Maschine kein ECC unterstützt. Zudem meckert er ebenfalls, dass nur eine Netzwerkkarte im System verwendet wird. Spätestens das wäre der einzige Punkt, wo ich noch ansetzen könnte.

    Ansonsten gibt es ein paar Warnungen bezüglich geringem Arbeitsspeicher der Gäste, da der Server Core und die andere Testmaschine nur jeweils 1 GB zugewiesen bekommen haben. Was interessiert noch bei der Einrichtung der VMs?


    cu, Ingo
    Montag, 7. Juni 2010 21:09
  • Hallo Ingo,

    ok, einen Schritt näher. Was sagt nvspbind zum Thema ms_rspndr und ms_lltdio? Sind diese für die betroffene Schnitstelle und dem virtuellen Switch aktiviert?

    Gruß,
    Andrei

    Dienstag, 8. Juni 2010 06:44
    Moderator

  • Habe nvspbind auf dem Host ausgeführt und dort werden beide Protokolle als aktiv für den virtuellen Switch angezeigt. Bei der virtuellen Maschine ist für die dortige LAN-Verbindung ebenfalls beides aktiv.

    cu, Ingo
    Dienstag, 8. Juni 2010 19:38
  • Hallo Ingo,

    konnte inzwischen herausfinden, dass das Problem "bei Design" in Vista/Server 2008 war, da LLTD in einer virtuellen Umgebung nicht unterstützt wurde.

    Bezüglich Win 7/Server 2008 R2 habe ich Feedback angefordert. Sobald ich etwas Neues erfahre gebe ich hier bescheid.

    Gruß,
    Andrei

    Freitag, 11. Juni 2010 07:23
    Moderator
  • Und gab es schon Neuigkeiten zum Thema?
    cu, Ingo
    Mittwoch, 30. Juni 2010 23:42
  • Hallo Ingo,

    ja, aber leider keine erfreuliche. LLTD wird in einer virtuellen Umgebung weiterhin nicht unterstützt.

    Gruß,
    Andrei

    Donnerstag, 1. Juli 2010 11:00
    Moderator
  • Okay, ich werde das in der Gruppenrichtlinie dann wieder deaktivieren, damit nicht der Dienst sinnlos versucht, etwas zu erstellen, was er nicht erstellen kann. Danke für die Info.

     


    cu, Ingo
    Donnerstag, 1. Juli 2010 21:44
  • Hallo Ingo,

    ja, aber leider keine erfreuliche. LLTD wird in einer virtuellen Umgebung weiterhin nicht unterstützt.

    Hall Ingo,
    hallo Andrei,

    bin jetzt erst über Umwege [1] auf diesen Thread gestoßen. Die Thematik LLTD scheint eine tiefergehende zu sein, da der Effekt auch bei physischen Win XP-Maschinen innerhalb eines Netzwerks auftreten kann. Ich habe das Thema unter [2] für Windows 7 mal zur Diskussion eingestellt und zwischenzeitlich meine Erkenntnisse unter [3,4] halbwegs zusammen gefasst - hier scheint es auf einen nForce Network controller bzw. dessen Treiber hinauszulaufen.

    1: http://www.winsupportforum.de/forum/windows-7-netzwerk/10135-problem-mit-netzwerkuebersicht-und-lltd.html#post62780
    2: http://social.answers.microsoft.com/Forums/de-DE/w7networkde/thread/d7153e44-dee8-4f8b-be83-82cc7a64eea6/
    3: http://www.borncity.com/blog/2010/11/09/netzwerkeinbindung-fr-virtuelle-maschinen/
    4: http://www.borncity.com/blog/2010/11/08/die-netzwerkbersicht-funktioniert-nicht/


    Gruß/greetings G. Born - Blogs: http://blog.borncity.com
    Sonntag, 14. November 2010 07:04