none
Power Options RRS feed

  • Frage

  • Hallo,

     

    kleines Problem. Hab in User Configuration -> Preferences -> Control Panel Settings -> Power options eine neue "Power Options (Windowx XP)" angelegt und diese

    so definiert, dass beim Schließen der Laptopklappe (Power Buttons -> When I close the lid of my portable Computer: Do nothing) nichts passieren soll. Diese wird aber auf den XP Clients für den User nicht geändert.

    Wobei ich noch im selben Kontext ein neues "Power Scheme" anlege, diese angewandt wird.

    Ich kann mir leider keinen Reim drauf machen.

    Über jegliche Hilfe wäre ich echt dankbar.

     

    Gruß,

    Lars

    Donnerstag, 4. November 2010 15:38

Antworten

  • Nachtrag:

    Da wir nicht wollten, dass die User Hauptbenutzer werden musste eine andere Lösung her.

    Per GPO wurden auf folgenden Regschlüsseln für den "normalen" User die Rechte auf "Full Control" gesetzt. Somit sind die Einstellungen in Powerscheme's und Poweroptions für den User frei änderbar, ohne dass dieser Hauptbenutzer ist oder sonst irgend welchen speziellen Gruppen angehören muss:

     

    MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\PowerCfg\GlobalPowerPolicy

    MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\PowerCfg\PowerPolicies

     

    Gruß,

    Lars

    Freitag, 12. November 2010 12:03

Alle Antworten

  • Am 04.11.2010 schrieb LarsB_from_GER:

    kleines Problem. Hab in User Configuration -> Preferences -> Control Panel Settings -> Power options eine neue "Power Options (Windowx XP)" angelegt und diese

    so definiert, dass beim Schließen der Laptopklappe (Power Buttons -> When I close the lid of my portable Computer: Do nothing) nichts passieren soll. Diese wird aber auf den XP Clients für den User nicht geändert.

    Ist KB943729 auf den Clients installiert? Was sagt RSOP.MSC auf dem
    Client? Fehlermeldungen im Ereignisprotokoll?

    Wobei ich noch im selben Kontext ein neues "Power Scheme" anlege, diese angewandt wird.

    Im Kontext des gleichen Benutzers?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Donnerstag, 4. November 2010 16:15
  • Hi

    Am 04.11.2010 16:38, schrieb LarsB_from_GER:

    When I close the lid of my portable Computer: Do nothing) nichts
    passieren soll. Diese wird aber auf den XP Clients für den User
    nicht geändert.

    Grün unterstrichen oder rot gestrichelt?
    F5 - alle grün, aktiviert
    F6 - einer grün, aktiviert
    F7 - einer rot, nicht konfiguriert
    F8 - alle rot, nicht konfiguriert

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    Donnerstag, 4. November 2010 20:54
  • => Ist KB943729 auf den Clients installiert?

    Yep, KB ist installiert

     

    => Im Kontext des gleichen Benutzers?

    Hiermit meinte ich, in der selben GPO habe ich Power Options und Power Scheme angelegt. Power Scheme wird angewendet und Power Options eben nicht bin hier wirklich lost ;-)

    Montag, 8. November 2010 08:26
  • Hi,

     

    also in den Poweroptions ist alles grün unterstrichen. Jetzt weiß ich wenigstens, was das heißt ... wußte ich vorher auch noch nicht. Hierfür schon mal DANKE!

     

    Gruß,

    Lars

    Montag, 8. November 2010 08:28
  • Hi,

    vielleicht noch eine kleine Zusatzinfo. Nach dem ich Group Policy Results ausgeführt habe, bekomme ich für Power Options folgende Meldung, die mir aber leider nicht so richtig auf die Sprünge helfen will und Google ist auch ziemlich schweigsam ;-)

     

    An error has occurred while collecting data for Power Options.

    The following errors were encountered:
    An unknown error occurred while data was gathered for this extension. Details: Invalid class

     

    Montag, 8. November 2010 10:43
  • Am 08.11.2010 schrieb LarsB_from_GER:

    vielleicht noch eine kleine Zusatzinfo. Nach dem ich Group Policy Results ausgeführt habe, bekomme ich für Power Options folgende Meldung, die mir aber leider nicht so richtig auf die Sprünge helfen will und Google ist auch ziemlich schweigsam ;-)

     
    An error has occurred while collecting data for Power Options.

    The following errors were encountered:An unknown error occurred while data was gathered for this extension. Details: Invalid class

    Und im Eventlog hast Du auch keine Fehlermeldungen?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 8. November 2010 10:45
  • Hallo Winfried,

    hätt' auf den Eventvwr selber kommen können :-(, aber ja da steht folgendes:

     

    Das Benutzer "Power Options (Windows XP)"-Einstellungselement im Gruppenrichtlinienobjekt
    "NKDLaptopDockingStation {EA0A542A-069C-4BB5-9944-4EC80281D0F9}" wurde nicht übernommen,
    da ein Fehler mit Fehlercode "0xc0000061 <unknown-message-text>"
    Dieser Fehler wurde unterdrückt. aufgetreten ist.

     

    Servus,

    Lars

    Montag, 8. November 2010 11:08
  • Am 08.11.2010 schrieb LarsB_from_GER:

    Das Benutzer "Power Options (Windows XP)"-Einstellungselement im Gruppenrichtlinienobjekt
    "NKDLaptopDockingStation {EA0A542A-069C-4BB5-9944-4EC80281D0F9}" wurde nicht übernommen,
    da ein Fehler mit Fehlercode "0xc0000061 <unknown-message-text>"
    Dieser Fehler wurde unterdrückt. aufgetreten ist.

    Was ist für dieses Objekt im Reiter Gemeinsam der GPO angehakt?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 8. November 2010 11:28
  • Ich hab das Objekt "Run in logged-on user's security context (user policy option)." angehackt. Hab ich mal testweise ausprobiert, da ich dachte ich benötige diese Option.

    Diese Option hab ich jetzt wieder deaktiviert aber die GPO wird leider trotzdem nicht angewandt.

     

    Montag, 8. November 2010 12:02
  • Am 08.11.2010 schrieb LarsB_from_GER:

    Ich hab das Objekt "Run in logged-on user's security context (user policy option)." angehackt. Hab ich mal testweise ausprobiert, da ich dachte ich benötige diese Option.

    Ich hab grade nichts zum testen da, gibts das Objekt nicht auch als
    Computerobjekt? Wenn ja, würde ich das mal probieren.

    Diese Option hab ich jetzt wieder deaktiviert aber die GPO wird leider trotzdem nicht angewandt.

    Ist SP3 für XP installiert?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 8. November 2010 12:07
  • Yep, diese Objekt gibt's auch auf Computer Ebene und nicht nur in User Ebene. Hab ich auch schon ausprobiert, leider ohne Erfolg. Und bei uns sind auch auf allen Clients das SP3 installiert.

    Diese GPO wird einfach nicht angewandt und hab keinen schimmer warum ...

    Montag, 8. November 2010 12:13
  • Am 08.11.2010 schrieb LarsB_from_GER:

    Yep, diese Objekt gibt's auch auf Computer Ebene und nicht nur in User Ebene.

    Was steht in den Erklärungen dabei? Ist die Einstellung denn auch für
    XP geeignet?

    Diese GPO wird einfach nicht angewandt und hab keinen schimmer warum ...

    Probier doch mal Beispiel No. 17 aus:
    http://www.gruppenrichtlinien.de/adm/Beispiele.htm

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 8. November 2010 12:26
  • Hi

    Am 08.11.2010 13:13, schrieb LarsB_from_GER:

    Diese GPO wird einfach nicht angewandt und hab keinen schimmer warum ...

    Ich erinnere mich dunkel an ein Problem mit "Lid close" und "Hibernate"
    als GPP noch PolicyMaker hiess, denn die GPO/CSE kann die Hibernate
    Datei nicht erstellen, wenn sie nicht existiert.

    Hast du in den Poweroptions die Hibernate Geschichte auch konfiguriert,
    oder ist die "nicht konfiguriert".

    ... ich glaube ich brauche doch mal wieder eine XP VM :-)

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    Dienstag, 9. November 2010 20:16
  • Hi Mark,

    danke für den Tipp. Kann aber nur bei den Poweroptions oben eine Haken setzen bei "Enable hibernation". Meintest Du damit dieses? Und jetzt wird's noch unübersichtlicher. Wenn ich nämlich bei den Poweroptions im oberen Bereich entweder bei "Always show icon on the taskbar", "Prompt for password when computer resumes from standby" oder "Enable hibernation" einen Haken setze, wird dies auch auf dem Client übernommen.

    Aber wenn ich im unteren Bereich ("Power buttons") Veränderungen vornehme, wendet der Client diese nicht an.

     

    Servus,

    Lars

    Mittwoch, 10. November 2010 07:01
  • Hi,

    Am 10.11.2010 08:01, schrieb LarsB_from_GER:

    "Enable hibernation". Meintest Du damit dieses?

    Jo. Denn das geht nur, wenn die Datei hyberfil.sys schon existiert, wenn
    sie nicht existiert, dann kann er Hybernate nicht aktivieren, wenn der
    Bereich in den gespeichert werden soll nicht erstellen kann.

    [...] wird dies auch auf dem Client übernommen. Aber wenn ich im
    unteren Bereich ("Power buttons") Veränderungen vornehme, wendet der
    Client diese nicht an.

    Also ist es nur eine Teilkomponente die fehlschlägt.
    Hast du irgendwelche Einträge in Anwendungsprotokoll?

    Fällt mir im Moment nichts sinnvolles zu ein. Mir fehlt auch ein
    XP Notebook zum basteln, denn die Vista/W7 Konfiguration ist
    komplett geändert zu XP.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    GPO Tool:    www.reg2xml.com - Registry Export File Converter
    NNTP Bridge: http://communitybridge.codeplex.com/releases

    Mittwoch, 10. November 2010 21:55
  • Hallo an alle,

    zuerstmal danke an alle, die mir hier mit Rat und Tat zur Seite gestanden haben. Leider konnte ich die GPO nicht dazu "überreden" die Poweroptions anzuwenden. Als workaround haben wir jetzt die Laptopuser per GPO in die Gruppe "Hauptbenutzer" gesteckt und dürfen somit auf den Laptops die Poweroptions selbst einstellen.

    Und leider blieb das Anwendungsprotokoll ziemlich ruhig ...

     

     

    Servus

    Lars

    Donnerstag, 11. November 2010 10:21
  • Nachtrag:

    Da wir nicht wollten, dass die User Hauptbenutzer werden musste eine andere Lösung her.

    Per GPO wurden auf folgenden Regschlüsseln für den "normalen" User die Rechte auf "Full Control" gesetzt. Somit sind die Einstellungen in Powerscheme's und Poweroptions für den User frei änderbar, ohne dass dieser Hauptbenutzer ist oder sonst irgend welchen speziellen Gruppen angehören muss:

     

    MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\PowerCfg\GlobalPowerPolicy

    MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\PowerCfg\PowerPolicies

     

    Gruß,

    Lars

    Freitag, 12. November 2010 12:03