locked
Kein Netzwerkadapter im XP Mode verfügbar RRS feed

  • Frage

  • Seit ich eine Aktualisierung meines Netzwerkadaptertreibers durchgeführt habe (WIN7 Ultimate 64-Bit - Marvell Yukon 88E8056 PCI-E-Gigabit-Ethernet-Controller), wird dieser in den XP Mode Einstellungen nicht mehr angeboten d.h. ich kann nur NAT oder internes Netzwerk auswählen.
    Folgende Maßnahmen habe ich bereits versucht: Deinstallation des Netzwerkadapters und Neuinstallation auf der physikalischen Maschine, Deinstallation und Neuinstallation von Windows Virtual PC. Der Virtual-PC Netzwerkfiltertreiber ist an die physikalische Netzwerkkarte gebunden.
    Was muss ich tun, dass die physikalische Netzwerkkarte im virtuellen Computer wieder auswählbar wird?
    Ich habe ansonsten nur in einer virtuellen XP Umgebung, aber nicht bei WIN7 bzw. Vista Internetzugang. Hier beschränkt sich der Netzwerkzugriff dann leider nur auf lokal. Warum auch immer.
    Hier die Fehlermeldung mit Event-ID 19:
    Virtual PC konnte den eigenen emulierten Ethernet-Switchtreiber nicht öffnen. Aktivieren Sie zum Beheben dieses Problems den emulierten Ethernet-Switchdienst von Virtual PC auf einem oder mehreren Ethernetadaptern erneut, oder installieren Sie Virtual PC erneut.

    Jürgen
    Freitag, 20. November 2009 22:40

Antworten

  • könntest du testhalber eine neue VM erstellen und dessen Netzwerk-Einstellungen überprüfen ohne diese zu starten?
    Danke für den Tipp, hatte ich auch schon dran gedacht. Ergebnis: nur NAT verfügbar, Konsequenz: Vista und Win7 VM nur lokales Netz.
    Hab jetzt folgendes gemacht:
    Backup Image des Systems auf eine zusätzlich verfügbare HD zurückgelesen und siehe da: im Backup waren die Einstellungen noch vorhanden.
    Also Image auf meine richtige Systemplatte zurückgelesen und alles ist gut :-).
    Danke und Gruß
    Jürgen
    Mittwoch, 25. November 2009 21:26

Alle Antworten

  • Hallo Jürgen

    könntest du bitte überprüfen ob in den Eigenschaften deiner Lan-Verbindung (im Win 7 Host-Betriebssystem) der Virtual PC-Netzwerkfiltertreiber vorhanden und aktiviert ist?

    Gruß
    Andrei
    Dienstag, 24. November 2009 15:31
  • Sorry, dass ich jetzt dazwischen funke - geht es auch mit wLAN?
    Dienstag, 24. November 2009 15:45
  • .... könntest du bitte überprüfen ob in den Eigenschaften deiner Lan-Verbindung (im Win 7 Host-Betriebssystem) der Virtual PC-Netzwerkfiltertreiber vorhanden und aktiviert ist? ...

    Zitat aus meinem Posting: "Der Virtual-PC Netzwerkfiltertreiber ist an die physikalische Netzwerkkarte gebunden."  d.h. vorhanden und aktiviert (Eigenschaften LAN-Verbindng), als PNP-Gerät auch im Gerätemanager.
    Dienstag, 24. November 2009 16:01
  • .... geht es auch mit wLAN?
    Habe kein WLAN am PC!
    Dienstag, 24. November 2009 16:02
  • aber dafür den Moderator am Hacken :)  Er ist Microsoft :)  er weiß es
    Dienstag, 24. November 2009 16:44
  • Hallo Jürgen

    sorry ist mir beim durchlesen entgangen :-)

    nächster Versuch ist den Virtual PC-Netzwerkfiltertreiber erneut zu installieren. Dafür bitte folgende Schritte ausführen:

    1. Den Virtual PC-Netzwerkfiltertreiber von den Lan-Verbindung-Eigenschaften deinstallieren.
    2. Den Computer neustarten (sehr wichtig)
    3. Den Virtual PC-Netzwerkfiltertreiber von den Lan-Verbindung-Eigenschaften wieder installieren. Beim Netzwerkfeature auswählen Menü sollte dieser als Dienst erkannt werden.

    Lass uns bitte wissen, ob es dadurch behoben wurde.

    Gruß
    Andrei
    Dienstag, 24. November 2009 16:53
  • Sorry, dass ich jetzt dazwischen funke - geht es auch mit wLAN?
    Hallo mimatete

    dazu sind ja die Foren da :-) jeder Beitrag/Frage zum Thema sind willkommen

    meinst du das im allgemeinen Fall oder spezifisch für dieses Problem? Im allgemeinem Fall gelten dieselben Regeln für ein wlan Adapter wie auch für einen normalen LAN Adapter, also muss der Virtual PC-Netzwerkfiltertreiber aktiviert sein.

    Gruß
    Andrei
    Dienstag, 24. November 2009 17:01
  • 1. Den Virtual PC-Netzwerkfiltertreiber von den Lan-Verbindung-Eigenschaften deinstallieren.
    2. Den Computer neustarten (sehr wichtig )
    3. Den Virtual PC-Netzwerkfiltertreiber von den Lan-Verbindung-Eigenschaften wieder installieren. Beim Netzwerkfeature auswählen Menü sollte dieser als Dienst erkannt werden.
    Danke für die schnelle Reaktion!
    1. - 3. habe ich bereits durchgeführt. Der Dienst wird problemlos nach Neustart neuinstalliert, aber:
    Beim Starten des virtuellen Computers habe ich wieder das Problem und den o.g. Eintrag in der Ereignisanzeige.
    Ich kann nur NAT auswählen ud dann steht nur eine lokale Verbindung in einer Win7 bzw. Vista Maschine.
    Der XP-Modus gelangt allerdings ohne weiteres über NAT ins Internet.
    Jürgen
    Dienstag, 24. November 2009 17:21
  • Hallo Jürgen

    könntest du testhalber eine neue VM erstellen und dessen Netzwerk-Einstellungen überprüfen ohne diese zu starten?

    Gruß
    Andrei
    Mittwoch, 25. November 2009 14:57
  • könntest du testhalber eine neue VM erstellen und dessen Netzwerk-Einstellungen überprüfen ohne diese zu starten?
    Danke für den Tipp, hatte ich auch schon dran gedacht. Ergebnis: nur NAT verfügbar, Konsequenz: Vista und Win7 VM nur lokales Netz.
    Hab jetzt folgendes gemacht:
    Backup Image des Systems auf eine zusätzlich verfügbare HD zurückgelesen und siehe da: im Backup waren die Einstellungen noch vorhanden.
    Also Image auf meine richtige Systemplatte zurückgelesen und alles ist gut :-).
    Danke und Gruß
    Jürgen
    Mittwoch, 25. November 2009 21:26
  • Hallo zusammen!

    Dieser Thread ist zwar schon "etwas" älter, beschreibt genau mein Problem:

    Der NIC auf dem Mainboard ist defekt und wurde durch eine PCIe NIC (Realtek RTL8168B/8111B) ersetzt. Diese Karte hat quasi den gleichen Chip wie er Onboard verbaut ist.

    Leider bekomme ich unter Einstellungen->Netzwerk->Adapter der VM die Karte nicht angezeigt.

    Man kann nur noch Gemeinsam genutztes Netzwerk (NAT) oder internes Netzwerk auswählen, was jedoch leider nicht ausreicht, da ich einige Ports auf die VM geroutet habe und die VM so eine eigene IP braucht.

    An der PCIe NIC Karte kann es nicht liegen, da ich auch bereits 2 andere (1 Intel, 1 Bigfoot Networks) ausprobiert habe. Bei allen das gleiche!

    Bei allen Karten wurde auch der Dienst "Virtual PC Network Filter Driver" an den Adapter "gebunden". Auch eine Deinstallation, Neustart und Neuinstallation brachte keine Abhilfe.

    Deinstallation, Neustart und Neuinstallation des KB958559 und der VM ebenso ohne Erfolg. Der Fehler ist auch bei einem neuen "virtuellen Computer" vorhanden.

    Es macht den Anschein, dass keine neu eingebauten Karten von dem Filter Driver mehr erkannt werden.

    Wo sucht der Filter Driver nach entsprechenden NICs??? Das ist doch bestimmt wieder nur ein REG-Key, der geändert werden muss.

    Bitte dringend um Hilfe!

    Gregor

    Montag, 2. April 2012 12:23
  • Dann packe ich auch mal hier die Lösung rein, ohne komplett Backup per Image.

    So, habe die Lösung nun selber gefunden!

    Falls die Reinstallation des "Virtual PC-Netzwerktreibers" wie unter Kein Netzwerkadapter im XP Mode verfügbar beschrieben, nicht ausreicht, einfach folgendes durchführen:

    1. Ein Backup der VM anlegen: Dazu einfach den Ordner <Windows-Laufwerk>\Benutzer\<Username>\AppDate\Local\Microsoft\Windows Virtual PC\... mit Unterordnern kopieren.

    2. In dem unter 1 genannten Ordner die Options.xml löschen.

    3. Die Einstellungen der VM aufrufen.

    Falls der Netzwerkadapter immer noch nicht auftaucht, die VM manuell starten durch Doppelklick auf die Datei: <Name der VM>.vmc im Ordner:

    <Windows-Laufwerk>\Benutzer\<Username>\AppDate\Local\Microsoft\Windows Virtual PC\Virtuelle Computer\

    VM dann Herunterfahren und dann die Einstellungen aufrufen.

    Die Options.xml beinhaltet die erkannten Netzwerkadapter, und die Default VM. Die Datei wird neu angelegt, wenn sie nicht vorhanden ist.

    Schade das es unter Einstellungen nicht einfach einen Knopf "Systeminformationen akualisieren" gibt, der die Options.xml neu erzeugt und an geänderte Treiber/Hardware nach Installation des XP-Modes anpasst.


    • Bearbeitet GregorAlex Mittwoch, 4. April 2012 12:15
    • Als Antwort vorgeschlagen GregorAlex Mittwoch, 4. April 2012 12:15
    Mittwoch, 4. April 2012 12:15