locked
Roaming Profil wird nicht mehr zurückgeschrieben... RRS feed

  • Frage

  • Hallo!

    PDC: SBS 2003 auf diesem werden auch die servergespeicherten Profile abegelgt.

    Grundsätzlich funktionieren unsere Roaming-Profile seit Jahren einwandfrei.

    Hin und wieder passiert es, dass ein Profil nicht mehr auf den Server zurück geschrieben wird (jedoch geladen wird es).

    In diesen Fällen liegt es weder an Berechtigungseinstellungen, noch an irgendwelchen nVidia Treiber, noch am Betriebssystem (kann von XP bis 7 vorkommen) und es stehen keine Hinweise in den Ereignisanzeigen.

    Welche Schritte solllte man in solchen Fällen durchgehen um das Profil so schnell wie möglich wieder zum Laufen zu bringen?

    Schöne Grüße

    Freitag, 2. April 2010 06:47

Antworten

  • Hi,

    Am 26.05.2010 07:22, schrieb florinho:
    > es sind keine nVidia Einträge in den RUN Keys, da keine nVidia
    > Grafikkarte bei diesem PC verwendet wird.
    > Sondern ein Intel(R) Q965/Q963 Express Chipset Family.
    > Hast du noch eine Idee?

    Ja, alle anderen Einträge im RUN Key.

    Eins der Tools oder einer der Dienste im System, wird der Verursacher
    sein.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    • Als Antwort markiert florinho Mittwoch, 2. Juni 2010 14:46
    Mittwoch, 26. Mai 2010 19:13
  • Hi Mark,

    das Problem war der Dienst der das Fernwartungstool TeamViewer automatisch startete.

    Lt. TeamViewer-Support ist dies ein Bug der mit der neuesten Version bereits behoben ist.

    Dies kann ich leider nicht bestätigen, somit habe ich diesen Dienst vorläufig entfernt.

    Das Profil wird nun wieder ordnungsgemäß zurück geschrieben.

    Danke und Schöne Grüße

    • Als Antwort markiert florinho Mittwoch, 2. Juni 2010 14:46
    Mittwoch, 2. Juni 2010 14:46

Alle Antworten

  • Hallo,

    > In diesen Fällen liegt es weder an Berechtigungseinstellungen, noch an irgendwelchen nVidia Treiber, noch am Betriebssystem

    und welche Sicherheitssoftware arbeitet dazwischen?

     


    Gruß Sven
    Freitag, 2. April 2010 08:12
  • Hallo Sven,

    was meinst du mit Sicherheitssoftware?

    AntiVirus: CA eTrust Antivirus 8.1.660

    Schöne Grüße

    Freitag, 2. April 2010 10:20
  • Hi,

    Am 02.04.2010 08:47, schrieb florinho:
    > Hin und wieder passiert es, dass ein Profil nicht mehr auf den Server
    > zurück geschrieben wird (jedoch geladen wird es).
    > In diesen Fällen liegt es weder an Berechtigungseinstellungen, noch an
    > irgendwelchen nVidia Treiber, noch am Betriebssystem (kann von XP bis 7
    > vorkommen) und es stehen keine Hinweise in den Ereignisanzeigen.

    Aktiviere das USerenvironment Logging und beobachte.
    Evtl. Ärgert dich ein Dienst, Tool was auch immer, sodass die
    Netzwerkverbindung zu früh beendet wird.

    Da du die Reihenfolge beim SchutDown nicht beeinflussen kannst,
    kriegst du aber zumindest den Schuldigen zu fassen.

    http://www.gruppenrichtlinien.de/Grundlagen/faq.htm#37
    bzw.
    http://support.microsoft.com/kb/221833/en-us

    Tschö
    Mark

    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Freitag, 2. April 2010 14:04
  • Hallo Mark,

    ich habe diesen Reg-Schlüssel angelegt. Allerdings bin ich mir nicht sicher, ob dieser unter Win7 funktioniert?

    UserEnvDebugLevel - REG_DWORD HEX 10002

    Ich bekomme unter C:\Windows\debug\UserMode lediglich eine gpsvc.log Datei.

    Schöne Grüße

    Dienstag, 6. April 2010 14:27
  • Hi Mark,

    ich glaube nicht, dass es an einen Dienst, Tool usw. liegt, da es mit einem anderen Benutzer an diesem PC wunderbar funktioniert.

    Aber leider bekomme ich dieses Userenvironment Logging nicht zum Laufen.

    Gibt es für Win7 eventuell einen neuen Reg-Schlüssel dafür?

    Schöne Grüße

    Freitag, 9. April 2010 08:50
  • Hallo florinho

    ist evtl. etwas im Ereignisprotokoll unter Anwendungs- und Dienstprotokolle/Microsoft/Windows/User Profile Service diesbezüglich zu erkennen?

    Gruß
    Andrei

    Dienstag, 13. April 2010 06:37
  • Hallo Andrei,

    bei der Abmeldung gibt es nur folgende Einträge:

    Benutzerabmeldebenachrichtigung für Sitzung 1 empfangen.
    Das Deaktivieren des Uploads der Hintergrundbenutzerstruktur war erfolgreich.
    Verarbeitung der Benutzerabmeldebenachrichtigung für Sitzung 1 beendet.

    Bei der Anmeldung jedoch gibt es mehr (auch mit Synchronisierung):

    Benutzeranmeldebenachrichtigung für Sitzung 1 empfangen.
    Die Synchronisierung des Profils von \\file$NOCSC$\profile$\Username.V2\ auf C:\Users\Username wird gestartet.
    Die Synchronisierung des Profils von \\file$NOCSC$\profile$\Username.V2\ auf C:\Users\Username wurde beendet.
    Ergebnis: Der Vorgang wurde erfolgreich beendet.
    Die Registrierungsdatei "C:\Users\Username\ntuser.dat" wird im Registrierungspfad "HKU\S-1-5-21-3468034860-2848183390-1895049852-1213" geladen.
    Die Registrierungsdatei "C:\Users\Username\AppData\Local\Microsoft\Windows\\UsrClass.dat" wird im Registrierungspfad "HKU\S-1-5-21-3468034860-2848183390-1895049852-1213_Classes" geladen.
    Das Deaktivieren des Uploads der Hintergrundbenutzerstruktur war erfolgreich.
    Verarbeitung der Benutzeranmeldebenachrichtigung für Sitzung 1 beendet.

    Kann man daraus etwas ableiten?

    Gruß

    Dienstag, 13. April 2010 06:58
  • Das sieht soweit normal aus. Die häufigsten Roaming Profiles Fehlermeldung haben ein EventID in der Art 15xx.

    Ab Vista/Server 2008 kann ein ausführlicher Log mithilfe vom logman -start profile -p {eb7428f5-ab1f-4322-a4cc-1f1a9b2c5e98} 255 3 -ets Befehl für den User Profile Dienst erzeugt werden. Dieser Log kann aber nur intern von Microsoft konvertiert und analysiert werden.

    Du hattest ja erwähnt, dass dieses Verhalten auch auf XP Maschinen nachweisbar ist, daher würde ich zuerst vorschlagen den von Mark erwähnten Registry Wert auf eine der betroffenen XP Maschinen zu setzen und das Userenv.log dort zu verfolgen.

    Dienstag, 13. April 2010 09:41
  • Hallo florinho

    konntest du etwas im Userenv.log auf einer der betroffenen XP Maschinen erkennen?

    Gruß
    Andrei

    Montag, 19. April 2010 14:20
  • Hallo Andrei,

    diese Probleme treten zur Zeit nur bei einem Vista Client und bei einem Win7 Client auf.

    Ich hatte sie auch manchmal unter XP, dort hat es meist mit dem nVidia Treiber Probleme gegeben.

    Ich weiß nicht wie ich diese 2 Profile zum Laufen (zurück schreiben) bringe?

    Schöne Grüße

    Montag, 19. April 2010 14:30
  • Hast Du schon mal probiert, das profil manuell auf den Server zu kopieren?
    Hatte auch schon mal Problem mit zu langen Dateinamen...

    Gruss Rainer

    Mittwoch, 21. April 2010 14:28
  • Hallo Rainer,

    danke für den Ansatz. Habe ich geprüft. Doch leider liegt es auch nicht an zu langen Dateinamen...

    Schöne Grüße

    Dienstag, 27. April 2010 12:49
  • Hallo Andrei,

    Gibt es unter Vista/Win7 keine Möglichkeit das zurückschreiben des Roaming-Profils zu überwachen?

    Schöne Grüße
    Dienstag, 27. April 2010 12:50
  • Hi,
     
    Am 27.04.2010 14:50, schrieb florinho:
    > Gibt es unter Vista/Win7 keine Möglichkeit das zurückschreiben des
    > Roaming-Profils zu überwachen?
     
    Ja das UserEnvironment -> gpsvc.log (Vista/7/2008, userenv.log bei XP)
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
     
    Dienstag, 27. April 2010 16:20
  • Hallo!

    Mit diesem Log sehe ich die Gruppenrichtlinien-Dienstaktivität.

    Die Gruppenrichtlinien funktionieren korrekt.

    Darum hilft mir dieses Log nicht wirklich weiter, da z.B. bei der Abmeldung nichts mitprotokolliert wird.

    Hast du eventuell noch eine Idee warum ein Roaming Profil nicht zurück geschrieben wird?

    Schöne Grüße

    Mittwoch, 28. April 2010 14:59
  • Hallo!

    Ich habe folgendes getestet um das Profil wieder zum Laufen zu bringen:

    Anmeldung als lokaler Admin.

    Das Profil unter C:\Users entfernt.

    Anschließend das Profil in der Registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList) entfernt.

    Neustart.

    Anmeldung - Profil wird erfolgreich vom Server geladen.

    Erstellen einiger Desktopdateien zum Testen.

    Abmeldung. Profil wurde korrekt zurückgeschrieben.

    Erneute Anmeldung und Ändern einiger Daten (z.B. Dateien am Desktop), Öffnen von Outlook usw.

    Abmeldung. Profil wird nicht zurückgeschrieben.

    Hat niemand eine Idee dazu?

     

    Schöne Grüße

    Freitag, 7. Mai 2010 09:24
  • Hallo florinho

    erstelle bitte eine .etl Datei mithilfe unterer Anweisungen und lade diese auf Skydrive oder einem Upload Provider hoch so dass wir uns diese anschauen können:

    1. logman -start profile -p {eb7428f5-ab1f-4322-a4cc-1f1a9b2c5e98} 255 3 -ets
    2. Problem reproduzieren
    3. logman -stop profile -ets

    Gruß
    Andrei

    Freitag, 7. Mai 2010 10:21
  • Habe ich laut Anweisung gemacht.

    Wo finde ich nun diese .etl Datei?

    Gruß

    Freitag, 7. Mai 2010 10:31
  • im selben Ordner von wo aus der logman Befehl ausgeführt wurde
    Freitag, 7. Mai 2010 10:42
  • Hallo Andrei!

    Hier ist die gewünschte Datei:

    http://cid-67a5e6eeab642a1c.skydrive.live.com/self.aspx/.Public/profile.etl

    Danke für deine Hilfe.

    Schöne Grüße

    Montag, 10. Mai 2010 06:52
  • Hallo Andrei

    hast du schon Zeit gefunden meine .etl Datei zu analysieren?

    Gruß florinho

    Mittwoch, 19. Mai 2010 09:38
  • Hallo florinho

    ja, konnte mir vor kurzem die Log Datei anschauen. Das Problem ist dass ein anderer Prozess dazwischen funkt und das Profil nicht auf dem Server zurückgespeichert werden kann.

     [0] 0398.01F8::05/07/2010-13:28:19.878 [profsvc](:CUserProfile::Unload:profile_cpp574) Ref count is 8, do not unload user profile.

     [0] 0398.01F8::05/07/2010-13:28:19.899 [profsvc](:CUserProfile::Unload:profile_cpp574) Ref count is 10, do not unload user profile.

     [0] 0398.01F8::05/07/2010-13:28:19.904 [profsvc](:CUserProfile::Unload:profile_cpp574) Ref count is 10, do not unload user profile.

    usw.

    Procmon sollte dir bei der Identifizierung des Prozesses behilflich sein. Beobachte welcher Prozess auf die ntuser.dat zugreifft.

    Gruß
    Andrei

    Freitag, 21. Mai 2010 13:41
  • Hallo Andrei,

    lt. Procmon gfreift nur die svchost.exe auf die ntuser.dat zu. --> Profil wird jedoch nicht zurück geschrieben.

    Folgende Einträge werden unter Procmon angezeigt, wenn ich nach ntuser.dat suche:

    Process Name: svchost.exe

    Date & Time:    25.05.2010 13:09:00
    Event Class:    Registry
    Operation:    RegQueryValue
    Result:    SUCCESS
    Path:    HKLM\System\CurrentControlSet\Control\hivelist\\Registry\User\S-1-5-21-3468034860-2848183390-1895049852-1213
    TID:    2448
    Duration:    0.0000053
    Type:    REG_SZ
    Length:    112
    Data:    \Device\HarddiskVolume1\Users\Pfeil.Florian\NTUSER.DAT

    Ich habe testweise auch alle Dienste wie Virenscan, usw. beendet. --> Profil wird jedoch nicht zurück geschrieben.

    Dienstag, 25. Mai 2010 11:19
  • Hi,

    Am 25.05.2010 11:19, schrieb florinho:
    > lt. Procmon gfreift nur die svchost.exe auf die ntuser.dat zu. -->
    > Profil wird jedoch nicht zurück geschrieben.

    Lösche alle nVidia Einträge aus den RUN Keys der Registry.

    Tschö
    Mark

    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Dienstag, 25. Mai 2010 11:37
  • Hallo Mark,

    es sind keine nVidia Einträge in den RUN Keys, da keine nVidia Grafikkarte bei diesem PC verwendet wird.

    Sondern ein Intel(R) Q965/Q963 Express Chipset Family.

    Hast du noch eine Idee?

    Schöne Grüße

    Mittwoch, 26. Mai 2010 07:22
  • Hi,

    Am 26.05.2010 07:22, schrieb florinho:
    > es sind keine nVidia Einträge in den RUN Keys, da keine nVidia
    > Grafikkarte bei diesem PC verwendet wird.
    > Sondern ein Intel(R) Q965/Q963 Express Chipset Family.
    > Hast du noch eine Idee?

    Ja, alle anderen Einträge im RUN Key.

    Eins der Tools oder einer der Dienste im System, wird der Verursacher
    sein.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    • Als Antwort markiert florinho Mittwoch, 2. Juni 2010 14:46
    Mittwoch, 26. Mai 2010 19:13
  • Hi,

    folgende Einträge sind in den RUN Keys zu finden:

    Current_User:
    "C:\Program Files\Microsoft Office\Office14\MSOSYNC.EXE"
    C:\Program Files\Windows Sidebar\sidebar.exe /autoRun

    LOCAL_MACHINE:
    "C:\Program Files\Common Files\Adobe\ARM\1.0\AdobeARM.exe"
    "C:\Program Files\Adobe\Reader 9.0\Reader\Reader_sl.exe"
    "C:\Program Files\Common Files\MAYComputer\eDocPrintPro\\ApplyEsf.exe"
    "C:\Program Files\Microsoft Office\Office14\BCSSync.exe" /DelayServices
    "C:\Program Files\CA\eTrustITM\realmon.exe" -s

    3 Microsoft, 2 Adobe, 1 CA eTrust, 1 PDF-Drucker

    Ich werde nun testen, ob einer dieser Einträge das Zurückschreiben des Roaming-Profils verhindert.

    Grüße

    Donnerstag, 27. Mai 2010 09:56
  • florinho schrieb:

    > folgende Eintr�ge sind in den RUN Keys zu finden:
    >
    > Current_User:
    > "C:\Program Files\Microsoft Office\Office14\MSOSYNC.EXE"
    > C:\Program Files\Windows Sidebar\sidebar.exe /autoRun
    >
    > LOCAL_MACHINE:
    > "C:\Program Files\Common Files\Adobe\ARM\1.0\AdobeARM.exe"
    > "C:\Program Files\Adobe\Reader 9.0\Reader\Reader_sl.exe"

    Die beiden Eintr�ge von Adobe kann man IMHO l�schen.

    > "C:\Program Files\Common Files\MAYComputer\eDocPrintPro\\ApplyEsf.exe"
    > "C:\Program Files\Microsoft Office\Office14\BCSSync.exe" /DelayServices
    > "C:\Program Files\CA\eTrustITM\realmon.exe" -s
    >
    > 3 Microsoft, 2 Adobe, 1 CA eTrust, 1 PDF-Drucker

    Beim Rest mu�t Du selbst entscheiden.

    Servus
    Winfried
    --
    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: www.gruppenrichtlinien.de
    Gruppenrichtlinien Mailingliste "gpupdate":
    http://frickelsoft.net/cms/index.php?page=mailingliste
    Donnerstag, 27. Mai 2010 10:01
  • Hi Mark,

    das Problem war der Dienst der das Fernwartungstool TeamViewer automatisch startete.

    Lt. TeamViewer-Support ist dies ein Bug der mit der neuesten Version bereits behoben ist.

    Dies kann ich leider nicht bestätigen, somit habe ich diesen Dienst vorläufig entfernt.

    Das Profil wird nun wieder ordnungsgemäß zurück geschrieben.

    Danke und Schöne Grüße

    • Als Antwort markiert florinho Mittwoch, 2. Juni 2010 14:46
    Mittwoch, 2. Juni 2010 14:46
  • Hi,

    Am 02.06.2010 16:46, schrieb florinho:
    das Problem war der Dienst der das Fernwartungstool TeamViewer automatisch startete.
    Lt. TeamViewer-Support ist dies ein Bug der mit der neuesten Version bereits behoben ist.
    Dies kann ich leider nicht bestätigen, somit habe ich diesen Dienst vorläufig entfernt.
    Das Profil wird nun wieder ordnungsgemäß zurück geschrieben.
    Na, dann kenne ich ja jetzt 2 Schuldige für das Verhalten. Danke fürs
    (unfreiwillige) testen ;-)

    Tschö
    Mark
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:    www.gruppenrichtlinien.de - deutsch
    Discuss :    www.freelists.org/list/gpupdate
    Mittwoch, 2. Juni 2010 15:01
  • Bitte als gelöst markieren, danke.
    Freitag, 10. Februar 2012 10:41