none
Registry Einträge werden nicht übernommen RRS feed

  • Frage

  • Hallo zusammen,

    ich habe mir ein paar Registry Dateien zusammengestellt, die mir beim Arbeitsalltag helfen. Nun wollte ich sie - die Dateien*¹ - ausführen und dabei kam es in der Registry zu keinerlei an Änderung. Also habe ich das richtig verstanden: man muss lediglich die Datei im Kontextmenü öffnen ⇒ Zusammenführen klicken oder via CMD ausführen*².

    Habe ich gemacht, aber dennoch fehlen alle Einstellungen. Ein Neustart hat nicht geholfen. Ich besitze Vollzugriff auf den Registry Zweig. Via PowerShell Skript*³ hat es merkwürdigerweise funktioniert.. aber wieso nicht beim direkten ausführen der .REG Datei?

    Windows Registry Editor Version 5.00
    
    [HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    "Start_TrackDocs"=dword:00000000

    *² C:\Users\User\Desktop\Explorer.reg

    Set-ItemProperty -Path Registry::HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced -Name Start_TrackDocs -Value 0


    VG crazyyzarc


    • Bearbeitet crazyyzarc Dienstag, 28. Mai 2019 09:21 Formatierung
    Dienstag, 28. Mai 2019 09:19

Alle Antworten

  • Wenn du das nicht als Admin (also ausführen als Admin) durchführst ist die Registry in den meisten Knoten schreibgeschützt.

    Du kannst "regedit" als Admin ausführen und dann unter Datei->importieren die Schlüssel anlegen oder führst deine .ps1 "als Admin"aus.

    • Bearbeitet bfuerchau Dienstag, 28. Mai 2019 10:23
    Dienstag, 28. Mai 2019 10:21
  • Wenn du das nicht als Admin (also ausführen als Admin) durchführst ist die Registry in den meisten Knoten schreibgeschützt.

    Du kannst "regedit" als Admin ausführen und dann unter Datei->importieren die Schlüssel anlegen oder führst deine .ps1 "als Admin"aus.


    Über die CMD mit Adminrechten bereits getestet. So wie es aussieht, tritt das Phänomen lediglich nur bei Registry Einträgen auf, die bereits angelegt sind. Somit schlussfolgere ich, dass die .REG Datei (+ Adminrechten) bereits existierende Einträge NICHT überschreibt. Wie kann ich die neuen Einträge denn dazu forcen dass sie übernommen werden?
    Dienstag, 28. Mai 2019 11:32
  • UPDATE!

    Lösungsansatz: Anscheinend nimmt der Registry Editor die Kurzform für die Registry Zweige nicht an.

    Umsetzung: HKEY_CURRENT_USER statt HKCU, HKEY_LOCAL_MACHINE statt HKLM etc.

    Dienstag, 28. Mai 2019 11:39
  • Das wundert mich eigentlich, da das Kommand "reg import file" mit der Datei so zurechtkommt wie sie ist.
    Ich glaube nicht, dass sich jeder die Mühe macht, die Exporte zu überarbeiten.

    Der Fehler liegt im Cmd-Let:

    https://docs.microsoft.com/de-de/powershell/module/Microsoft.PowerShell.Management/Set-ItemProperty?view=powershell-5.1

    Ein Pfad lautet "HKCU:\..."

    Man unterscheide hier deutlich den ":"!

    Dienstag, 28. Mai 2019 11:50